summaryrefslogtreecommitdiffstats
path: root/main/lua-soap
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-08-28 09:21:27 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-08-28 09:22:26 +0300
commit36efa779e14801c653767bf4c62dbc3ca339750b (patch)
treeaacb75d962d214928141fb55e04f9e74d46e5129 /main/lua-soap
parentc79f83116dfe0565cafc9dba6c760adab9251835 (diff)
downloadaports-36efa779e14801c653767bf4c62dbc3ca339750b.tar.bz2
aports-36efa779e14801c653767bf4c62dbc3ca339750b.tar.xz
main/lua-soap: new aport
Lua library to ease the use of SOAP http://tomasguisasola.github.io/luasoap/
Diffstat (limited to 'main/lua-soap')
-rw-r--r--main/lua-soap/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/lua-soap/APKBUILD b/main/lua-soap/APKBUILD
new file mode 100644
index 000000000..b009aa93d
--- /dev/null
+++ b/main/lua-soap/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-soap
+pkgver=3.0
+_pkgver=${pkgver/./_}
+pkgrel=0
+pkgdesc="Lua library to ease the use of SOAP"
+url="http://tomasguisasola.github.io/luasoap/"
+arch="noarch"
+license="MIT"
+depends="lua-expat lua-socket"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="https://github.com/tomasguisasola/luasoap/archive/v$_pkgver.tar.gz"
+
+_builddir="$srcdir"/luasoap-$_pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make LUA_DIR="$pkgdir"/usr/share/lua/5.1 install || return 1
+
+ # https://github.com/tomasguisasola/luasoap/issues/7
+ mv "$pkgdir"/usr/share/lua/5.1/soap/soap.lua \
+ "$pkgdir"/usr/share/lua/5.1/soap.lua || return 1
+}
+
+md5sums="0ca112b934d007f46015ddd08aa9df93 v3_0.tar.gz"
+sha256sums="09e9bc26bfe834038a9a71156a6e3590f359142b324f8da464894748ac3e3528 v3_0.tar.gz"
+sha512sums="de0fa591f5bc9bbf9740660edd4482289bca2139e60119cb5607304cd7afdf6b0d63aedf5c67386022d538a5f8d206323fada49e8ae268f297dec71eda2bc0ad v3_0.tar.gz"