summaryrefslogtreecommitdiffstats
path: root/main/lua-subprocess
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2012-12-12 14:30:45 +0000
committerTed Trask <ttrask01@yahoo.com>2012-12-12 14:30:45 +0000
commit414d7bc16e0bd9fd882215b5a5107530f3433527 (patch)
tree341080d183f399d59051c1b652e0a8fda4815742 /main/lua-subprocess
parent1239b4d79d72c18b8c8cee8940f9ade58a740149 (diff)
downloadaports-414d7bc16e0bd9fd882215b5a5107530f3433527.tar.bz2
aports-414d7bc16e0bd9fd882215b5a5107530f3433527.tar.xz
main/lua-subprocess: move from testing
Diffstat (limited to 'main/lua-subprocess')
-rw-r--r--main/lua-subprocess/APKBUILD63
-rw-r--r--main/lua-subprocess/makefile.patch12
-rw-r--r--main/lua-subprocess/openexception.patch11
3 files changed, 86 insertions, 0 deletions
diff --git a/main/lua-subprocess/APKBUILD b/main/lua-subprocess/APKBUILD
new file mode 100644
index 000000000..f72c33068
--- /dev/null
+++ b/main/lua-subprocess/APKBUILD
@@ -0,0 +1,63 @@
+# Contributor: Ted Trask <ttrask01@yahoo.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=lua-subprocess
+pkgver=0.0.20121211
+pkgrel=1
+pkgdesc="A Lua module written in C that allows you to create child processes and communicate with them"
+url="https://github.com/xlq/lua-subprocess"
+arch="all"
+license="AS-IS"
+depends=""
+depends_dev=""
+makedepends="$depends_dev lua-dev"
+install=""
+subpackages=""
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ openexception.patch
+ makefile.patch"
+_builddir="$srcdir/$pkgname-$pkgver"
+_giturl="git://github.com/xlq/lua-subprocess.git"
+_upload="dev.alpinelinux.org:/archive/$pkgname/"
+
+snapshot() {
+ local _date=$(date +%Y%m%d)
+ local _ver=0.0.$_date
+ local _pkg=$pkgname-$_ver.tar.gz
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ msg "Creating snapshot: $_pkg"
+ rm -rf ${_giturl##*/}
+ git clone --depth=1 --bare $_giturl || return 1
+ git --git-dir ${_giturl##*/} archive -o $_pkg \
+ --prefix=$pkgname-$_ver/ HEAD \
+ || return 1
+ msg "Uploading to $_upload"
+ rsync -Lave ssh $_pkg $_upload || return 1
+ cd "$startdir"
+ sed -i -e "s/^pkgver=.*/pkgver=$_ver/" \
+ APKBUILD || return 1
+ abuild checksum
+}
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="c2f13ef8e1fb83af43d61586ff611957 lua-subprocess-0.0.20121211.tar.gz
+fa869a7c9a11faf77ad9fd98ba35f62a openexception.patch
+cc680a0ec32e0461215ce61a44bbb540 makefile.patch"
diff --git a/main/lua-subprocess/makefile.patch b/main/lua-subprocess/makefile.patch
new file mode 100644
index 000000000..7567ca92c
--- /dev/null
+++ b/main/lua-subprocess/makefile.patch
@@ -0,0 +1,12 @@
+--- ./src/lua-subprocess-20121211/Makefile
++++ ./Makefile
+@@ -36,7 +36,8 @@
+
+ .PHONY: install
+ install: subprocess.so
+- $(INSTALL) -m755 subprocess.so $(INSTALL_CMOD)/
++ mkdir -p $(DESTDIR)$(INSTALL_CMOD)/
++ $(INSTALL) -m755 subprocess.so $(DESTDIR)$(INSTALL_CMOD)/
+
+ .PHONY: uninstall
+ uninstall:
diff --git a/main/lua-subprocess/openexception.patch b/main/lua-subprocess/openexception.patch
new file mode 100644
index 000000000..1a36d05aa
--- /dev/null
+++ b/main/lua-subprocess/openexception.patch
@@ -0,0 +1,11 @@
+--- ./src/lua-subprocess-0.0.20121211/subprocess.c
++++ ./subprocess.c
+@@ -1130,6 +1130,8 @@
+ if (r != 1){
+ return r;
+ }
++ lua_replace(L, 1);
++ lua_settop(L, 1);
+ return proc_wait(L);
+ }
+