summaryrefslogtreecommitdiffstats
path: root/main/lua-zmq
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-09 14:44:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-09 14:44:18 +0000
commit01467f37f55580e52795a464b926cd1c84729fa6 (patch)
tree5d1ea81057921262f90aca0e9386eb44bc334623 /main/lua-zmq
parent353eb923a5600204a267899a817532953429ba57 (diff)
downloadaports-01467f37f55580e52795a464b926cd1c84729fa6.tar.bz2
aports-01467f37f55580e52795a464b926cd1c84729fa6.tar.xz
main/lua-zmq: fix depends
Diffstat (limited to 'main/lua-zmq')
-rw-r--r--main/lua-zmq/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/lua-zmq/APKBUILD b/main/lua-zmq/APKBUILD
index 4eb764808..0389b587b 100644
--- a/main/lua-zmq/APKBUILD
+++ b/main/lua-zmq/APKBUILD
@@ -6,12 +6,12 @@ _luaversions="5.1 5.2"
pkgname=lua-zmq
pkgver=1.1_git20130709
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
pkgdesc="Lua zeromq2 binding"
url="https://github.com/Neopallium/lua-zmq"
arch="all"
license="MIT"
-depends="lua-llthreads lua5.1-zmq"
+depends="lua5.1-zmq"
makedepends="zeromq-dev cmake"
for _i in $_luaversions; do
makedepends="$makedepends lua$_i-dev"
@@ -60,6 +60,7 @@ _split() {
local d= _ver=$1
pkgdesc="Filesystem functions for Lua $_ver"
replaces="$pkgname"
+ depends="lua$_ver-llthreads"
for d in usr/lib/lua usr/share/lua; do
if [ -d "$pkgdir"/$d/$_ver ]; then
mkdir -p "$subpkgdir"/$d