summaryrefslogtreecommitdiffstats
path: root/main/lua-zmq
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-20 14:57:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-20 14:57:33 +0000
commit8cb0af0c69a5285a40f616d8d6f66d7aea089625 (patch)
tree5d9d723bb3231072a3b483d44e146fa4cbc65d4b /main/lua-zmq
parent957a0f2f9252238d0b81a70a808e068e51bf027d (diff)
downloadaports-8cb0af0c69a5285a40f616d8d6f66d7aea089625.tar.bz2
aports-8cb0af0c69a5285a40f616d8d6f66d7aea089625.tar.xz
main/lua-zmq: moved from testing
Diffstat (limited to 'main/lua-zmq')
-rw-r--r--main/lua-zmq/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/lua-zmq/APKBUILD b/main/lua-zmq/APKBUILD
new file mode 100644
index 000000000..1cf29100f
--- /dev/null
+++ b/main/lua-zmq/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-zmq
+pkgver=1.1
+pkgrel=0
+pkgdesc="Lua zeromq2 binding"
+url="https://github.com/Neopallium/lua-zmq"
+arch="all"
+license="MIT"
+depends=""
+makedepends="wget zeromq-dev cmake"
+install=""
+subpackages=
+source="saveas-http://github.com/Neopallium/lua-zmq/tarball/v1.1/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Neopallium-lua-zmq-5cf558e
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="d3813c48a9e2b88426fd79604862966d lua-zmq-1.1.tar.gz"