summaryrefslogtreecommitdiffstats
path: root/main/lxc/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-02-08 12:31:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-02-08 12:31:54 +0000
commit7295e430353ba1187da268f2167aaced0bce342b (patch)
treea1c3379f6491847e838a1588508154b35a51e548 /main/lxc/APKBUILD
parentd4c29909a98bd939bf6443fcc7e8d1613ffc3a61 (diff)
downloadaports-7295e430353ba1187da268f2167aaced0bce342b.tar.bz2
aports-7295e430353ba1187da268f2167aaced0bce342b.tar.xz
main/lxc: provide lxc-alpine template
Diffstat (limited to 'main/lxc/APKBUILD')
-rw-r--r--main/lxc/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index e30f8a671..53c73044e 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lxc
pkgver=0.8.0
_mypkgver=${pkgver/_rc/-rc}
-pkgrel=2
+pkgrel=3
pkgdesc="linux containers - tools"
url="http://lxc.sourceforge.net/"
arch="all"
@@ -38,16 +38,22 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--disable-apparmor \
- || reeturn 1
+ || return 1
make || return 1
}
package() {
+ set -e
cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
+ install -d "$pkgdir"/var/lib/lxc
+ install -Dm755 "$srcdir"/lxc-alpine \
+ "$pkgdir"/usr/share/lxc/templates/lxc-alpine
install -Dm755 "$srcdir"/lxc.initd "$pkgdir"/etc/init.d/lxc
- install -Dm755 "$srcdir"/setup-lxc-template "$pkgdir"/usr/bin/setup-lxc-template
+ install -Dm755 "$srcdir"/setup-lxc-template \
+ "$pkgdir"/usr/bin/setup-lxc-template
install -Dm755 "$srcdir"/setup-lxc-guest "$pkgdir"/usr/bin/setup-lxc-guest
+ set +e
}
md5sums="7304fa57146ce687f749b5df876bb20d lxc-0.8.0.tar.gz