summaryrefslogtreecommitdiffstats
path: root/main/lxc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-09 18:45:36 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-09 18:46:12 +0000
commit40bb1cc7f163fd0420e2363b53b9478500842cba (patch)
treef13c94283ba0fd3a9f57acd7fc70b2d3ef3b69a4 /main/lxc
parentbb302967564af6f7b6ecb598c197050bca4916fa (diff)
downloadaports-40bb1cc7f163fd0420e2363b53b9478500842cba.tar.bz2
aports-40bb1cc7f163fd0420e2363b53b9478500842cba.tar.xz
main/lxc: fix musl build, add arm support to alpine template
Diffstat (limited to 'main/lxc')
-rw-r--r--main/lxc/0002-lxc-alpine-add-arm.patch10
-rw-r--r--main/lxc/APKBUILD11
-rw-r--r--main/lxc/lxc-fix-headers.patch352
3 files changed, 372 insertions, 1 deletions
diff --git a/main/lxc/0002-lxc-alpine-add-arm.patch b/main/lxc/0002-lxc-alpine-add-arm.patch
new file mode 100644
index 000000000..2ec898a91
--- /dev/null
+++ b/main/lxc/0002-lxc-alpine-add-arm.patch
@@ -0,0 +1,10 @@
+--- lxc-0.9.0.orig/templates/lxc-alpine.in
++++ lxc-0.9.0/templates/lxc-alpine.in
+@@ -334,6 +334,7 @@
+ x86)
+ lxc_arch=i686;;
+ x86_64|"") ;;
++ arm*) apk_arch=armhf;;
+ *) die "unsupported architecture: $arch";;
+ esac
+
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 25b900750..4d59192ef 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lxc
pkgver=0.9.0
_mypkgver=${pkgver/_rc/-rc}
-pkgrel=2
+pkgrel=3
pkgdesc="linux containers - tools"
url="http://lxc.sourceforge.net/"
arch="all"
@@ -18,6 +18,8 @@ source="http://lxc.sourceforge.net/download/lxc/$pkgname-$_mypkgver.tar.gz
bb-shutdown.patch
alpine-template-backport.patch
0001-lxc-alpine-create-dev-zero.patch
+ 0002-lxc-alpine-add-arm.patch
+ lxc-fix-headers.patch
lxc.initd
"
@@ -35,6 +37,7 @@ prepare() {
build() {
cd "$_builddir"
+ [ "$CLIBC" = musl ] && export CFLAGS="$CFLAGS -Dutmpxname=utmpname"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -58,16 +61,22 @@ a0894c2ddf9133c3cc33c264e4596a3c bb-rm.patch
e96514860ee34b62d1b208ab03c569bc bb-shutdown.patch
25dd200bd158d16a05bb3e7aaef84697 alpine-template-backport.patch
e08b77b3b35adac290b49b9c9e04754c 0001-lxc-alpine-create-dev-zero.patch
+181c01649399b2c2dbadab9713381358 0002-lxc-alpine-add-arm.patch
+bcd59a1ca21bf83cb902b7ebe6cbced5 lxc-fix-headers.patch
f3c6998798b13425b8d0647bad0834a8 lxc.initd"
sha256sums="1e1767eae6cc5fbf892c0e193d25da420ba19f2db203716c38f7cdea3b654120 lxc-0.9.0.tar.gz
c9caea06b87baf5e335821c7e9ce3caca849b33f8176fbd48126c605583e78fc bb-rm.patch
0e5706cb077f750afdd6a5a4fd2afdf0b9113126c85e130d92680bed4ce9c20e bb-shutdown.patch
df193c4cf08e171c23b0b472750b7b1e0e7a66971c03201a0523e4039909f33b alpine-template-backport.patch
8b3b314d99209ae27d78cd4e9469638a945d68d03beefaec499bad373a7cb8cd 0001-lxc-alpine-create-dev-zero.patch
+415e28eae4d0611c899509835c70e82a06b2bae0b8f380b40de6eb0b5a039684 0002-lxc-alpine-add-arm.patch
+9e51ceb970e83b300f7dc6cded724f88da54a5ceb6ed71171144151bc9ac5138 lxc-fix-headers.patch
77c64e6137457be89c150b82d681a3eb5c7c1f06af142a321703fc9a43bff200 lxc.initd"
sha512sums="a96133660ca6ea45dc4b8d167267120328577339e933ff9510f03e9d368ca5db77031dc1e7e4529b3e506f63f79c2ce3f8f72571a7dfdbeb2a8799777782a606 lxc-0.9.0.tar.gz
b8fe47af6b1341ca472b6337c304f52402c53d400fc1d13895f2f568dd4d81b9ff281efc70bc1ddc221ac457db3bed4a199491059a15f66755deddc93ce91bf1 bb-rm.patch
86df52e380a01d6d3f588ca395925e8f774529c72e5b4c8dcb701d79fad7697ed8800f0ff51fded2896b2d2af49faa7f26960234fc8c1a6b4bc8f42d85078e6d bb-shutdown.patch
d10e25aeee0aba61a4c3420fe1b2bfd9213e7ef10f399ed5f0ba5d978a97a49fd23044b098f73f6d9651c23b1bb025f30d81deb6aec9edf4d2267afc22a09d60 alpine-template-backport.patch
0304aabfac3280cbc18347f1168b2289a98e03b9f6a3134770e43bb914978a64a108a0b0ec709856db161e98366c06c8a65d5a30e730add4cee2968718cdc93a 0001-lxc-alpine-create-dev-zero.patch
+d1860b5a47303762ec82d65c2f2c6feaac0115aeb2ddaaf6c052085e9b8dc1d8f6bd05af1c8596c7c978391af75cbe97b38f98f37dd036d61bd9cea9b81226dd 0002-lxc-alpine-add-arm.patch
+9f33cd349cca920221b73c07714607e15cd3c4a873ce44600d745c42df1214000448776244c787d14127c4e05645ad8d33dd4d4604193a9e41ec6655f0da1f9e lxc-fix-headers.patch
4e56f7b869345f936df54c4359abdd3b8d0244c0fd71a9a787bc2393c4caabca22ca8417f16da47f02c86294750986fd674d0d2e7c1b1d096076873b22c07a29 lxc.initd"
diff --git a/main/lxc/lxc-fix-headers.patch b/main/lxc/lxc-fix-headers.patch
new file mode 100644
index 000000000..229f3aade
--- /dev/null
+++ b/main/lxc/lxc-fix-headers.patch
@@ -0,0 +1,352 @@
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lua-lxc/core.c lxc-0.9.0/src/lua-lxc/core.c
+--- lxc-0.9.0.orig/src/lua-lxc/core.c 2013-03-18 22:17:00.000000000 +0000
++++ lxc-0.9.0/src/lua-lxc/core.c 2013-09-10 12:07:34.069998459 +0000
+@@ -21,7 +21,6 @@
+ */
+
+ #define LUA_LIB
+-#define _GNU_SOURCE
+ #include <lua.h>
+ #include <lauxlib.h>
+ #include <string.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/attach.c lxc-0.9.0/src/lxc/attach.c
+--- lxc-0.9.0.orig/src/lxc/attach.c 2013-04-05 09:45:22.000000000 +0000
++++ lxc-0.9.0/src/lxc/attach.c 2013-09-10 12:18:59.499998326 +0000
+@@ -21,13 +21,14 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#define _GNU_SOURCE
++#include "config.h"
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <sched.h>
+ #include <sys/param.h>
+ #include <sys/prctl.h>
+ #include <sys/mount.h>
+@@ -44,7 +45,6 @@
+ #include "log.h"
+ #include "attach.h"
+ #include "caps.h"
+-#include "config.h"
+ #include "apparmor.h"
+
+ lxc_log_define(lxc_attach, lxc);
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/caps.c lxc-0.9.0/src/lxc/caps.c
+--- lxc-0.9.0.orig/src/lxc/caps.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/caps.c 2013-09-10 12:19:34.019998319 +0000
+@@ -21,7 +21,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#define _GNU_SOURCE
++#include "config.h"
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <stdlib.h>
+@@ -29,7 +29,6 @@
+ #include <sys/prctl.h>
+ #include <errno.h>
+
+-#include "config.h"
+ #include "log.h"
+
+ lxc_log_define(lxc_caps, lxc);
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/cgroup.c lxc-0.9.0/src/lxc/cgroup.c
+--- lxc-0.9.0.orig/src/lxc/cgroup.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/cgroup.c 2013-09-10 12:07:34.149998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <unistd.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/commands.c lxc-0.9.0/src/lxc/commands.c
+--- lxc-0.9.0.orig/src/lxc/commands.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/commands.c 2013-09-10 12:10:17.479998427 +0000
+@@ -28,7 +28,7 @@
+ #include <fcntl.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/param.h>
+ #include <malloc.h>
+ #include <stdlib.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/conf.c lxc-0.9.0/src/lxc/conf.c
+--- lxc-0.9.0.orig/src/lxc/conf.c 2013-04-05 09:45:22.000000000 +0000
++++ lxc-0.9.0/src/lxc/conf.c 2013-09-10 12:07:34.239998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <stdlib.h>
+ #include <stdarg.h>
+ #include <errno.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/confile.c lxc-0.9.0/src/lxc/confile.c
+--- lxc-0.9.0.orig/src/lxc/confile.c 2013-04-05 09:45:22.000000000 +0000
++++ lxc-0.9.0/src/lxc/confile.c 2013-09-10 12:07:34.299998459 +0000
+@@ -20,7 +20,6 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/freezer.c lxc-0.9.0/src/lxc/freezer.c
+--- lxc-0.9.0.orig/src/lxc/freezer.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/freezer.c 2013-09-10 12:07:34.329998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <unistd.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_attach.c lxc-0.9.0/src/lxc/lxc_attach.c
+--- lxc-0.9.0.orig/src/lxc/lxc_attach.c 2013-04-05 09:45:22.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_attach.c 2013-09-10 12:07:34.379998459 +0000
+@@ -21,7 +21,6 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#define _GNU_SOURCE
+ #include <unistd.h>
+ #include <errno.h>
+ #include <pwd.h>
+Binary files lxc-0.9.0.orig/src/lxc/lxc_attach.o and lxc-0.9.0/src/lxc/lxc_attach.o differ
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_checkpoint.c lxc-0.9.0/src/lxc/lxc_checkpoint.c
+--- lxc-0.9.0.orig/src/lxc/lxc_checkpoint.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_checkpoint.c 2013-09-10 12:07:34.379998459 +0000
+@@ -20,7 +20,6 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <assert.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_console.c lxc-0.9.0/src/lxc/lxc_console.c
+--- lxc-0.9.0.orig/src/lxc/lxc_console.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_console.c 2013-09-10 12:10:46.179998421 +0000
+@@ -21,9 +21,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <string.h>
+@@ -35,7 +33,7 @@
+ #include <sys/param.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/ioctl.h>
+
+ #include "error.h"
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_execute.c lxc-0.9.0/src/lxc/lxc_execute.c
+--- lxc-0.9.0.orig/src/lxc/lxc_execute.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_execute.c 2013-09-10 12:07:34.399998459 +0000
+@@ -20,7 +20,6 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <errno.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_init.c lxc-0.9.0/src/lxc/lxc_init.c
+--- lxc-0.9.0.orig/src/lxc/lxc_init.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_init.c 2013-09-10 12:07:34.409998459 +0000
+@@ -30,7 +30,6 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+-#define _GNU_SOURCE
+ #include <getopt.h>
+
+ #include "log.h"
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_restart.c lxc-0.9.0/src/lxc/lxc_restart.c
+--- lxc-0.9.0.orig/src/lxc/lxc_restart.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_restart.c 2013-09-10 12:07:34.419998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <errno.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_start.c lxc-0.9.0/src/lxc/lxc_start.c
+--- lxc-0.9.0.orig/src/lxc/lxc_start.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_start.c 2013-09-10 12:07:34.429998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <libgen.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxc_unshare.c lxc-0.9.0/src/lxc/lxc_unshare.c
+--- lxc-0.9.0.orig/src/lxc/lxc_unshare.c 2013-03-19 10:17:27.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxc_unshare.c 2013-09-10 12:07:34.439998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <libgen.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxccontainer.c lxc-0.9.0/src/lxc/lxccontainer.c
+--- lxc-0.9.0.orig/src/lxc/lxccontainer.c 2013-04-05 09:45:22.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxccontainer.c 2013-09-10 12:21:27.039998297 +0000
+@@ -800,7 +800,7 @@
+ if (pid < 0)
+ return false;
+ if (pid == 0) { // child
+- ret = execlp("lxc-destroy", "lxc-destroy", "-n", c->name, "-P", c->config_path, NULL);
++ ret = execlp("lxc-destroy", "lxc-destroy", "-n", c->name, "-P", c->config_path, (void*)0);
+ perror("execl");
+ exit(1);
+ }
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxclock.c lxc-0.9.0/src/lxc/lxclock.c
+--- lxc-0.9.0.orig/src/lxc/lxclock.c 2013-03-19 10:17:26.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxclock.c 2013-09-10 12:20:50.019998304 +0000
+@@ -18,8 +18,8 @@
+ */
+
+ #include "lxclock.h"
+-#include <malloc.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #define OFLAG (O_CREAT | O_RDWR)
+ #define SEMMODE 0660
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/lxcutmp.c lxc-0.9.0/src/lxc/lxcutmp.c
+--- lxc-0.9.0.orig/src/lxc/lxcutmp.c 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/lxcutmp.c 2013-09-10 12:29:25.499998205 +0000
+@@ -63,6 +63,8 @@
+ #include "lxc.h"
+ #include "log.h"
+
++#include <utmp.h>
++
+ #ifndef __USE_GNU
+ #define __USE_GNU
+ #endif
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/network.c lxc-0.9.0/src/lxc/network.c
+--- lxc-0.9.0.orig/src/lxc/network.c 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/network.c 2013-09-10 12:07:34.539998459 +0000
+@@ -20,7 +20,6 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+ #undef _GNU_SOURCe
+ #include <stdlib.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/parse.c lxc-0.9.0/src/lxc/parse.c
+--- lxc-0.9.0.orig/src/lxc/parse.c 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/parse.c 2013-09-10 12:07:34.559998459 +0000
+@@ -20,9 +20,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _GNU_SOURCE
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/restart.c lxc-0.9.0/src/lxc/restart.c
+--- lxc-0.9.0.orig/src/lxc/restart.c 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/restart.c 2013-09-10 12:07:34.559998459 +0000
+@@ -24,7 +24,6 @@
+ #include "config.h"
+
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/seccomp.c lxc-0.9.0/src/lxc/seccomp.c
+--- lxc-0.9.0.orig/src/lxc/seccomp.c 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/seccomp.c 2013-09-10 12:07:34.579998459 +0000
+@@ -21,7 +21,6 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <seccomp.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/start.c lxc-0.9.0/src/lxc/start.c
+--- lxc-0.9.0.orig/src/lxc/start.c 2013-04-05 09:45:22.000000000 +0000
++++ lxc-0.9.0/src/lxc/start.c 2013-09-10 12:10:30.929998424 +0000
+@@ -24,7 +24,6 @@
+ #include "config.h"
+
+ #include <stdio.h>
+-#undef _GNU_SOURCE
+ #include <string.h>
+ #include <stdlib.h>
+ #include <dirent.h>
+@@ -43,7 +42,7 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/un.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/syscall.h>
+
+ #if HAVE_SYS_CAPABILITY_H
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/utils.c lxc-0.9.0/src/lxc/utils.c
+--- lxc-0.9.0.orig/src/lxc/utils.c 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/utils.c 2013-09-10 12:07:34.629998459 +0000
+@@ -21,7 +21,6 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
+-#define _GNU_SOURCE
+ #include <errno.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+diff -x '*.Po' -ru lxc-0.9.0.orig/src/lxc/utils.h lxc-0.9.0/src/lxc/utils.h
+--- lxc-0.9.0.orig/src/lxc/utils.h 2013-03-19 10:17:28.000000000 +0000
++++ lxc-0.9.0/src/lxc/utils.h 2013-09-10 12:17:15.499998346 +0000
+@@ -23,6 +23,8 @@
+ #ifndef _utils_h
+ #define _utils_h
+
++#include <sys/types.h>
++
+ extern int lxc_copy_file(const char *src, const char *dst);
+ extern int lxc_setup_fs(void);
+ extern int get_u16(unsigned short *val, const char *arg, int base);