summaryrefslogtreecommitdiffstats
path: root/main/lxc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-20 10:34:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-20 10:34:57 +0000
commitaa5e512833c517b59570326b5eee07f177256d98 (patch)
treed0369f70a6668fc3edd09c6c5934fd16bb29b137 /main/lxc
parentc534f259093b41d28bf0a2d8e1b67b0612b558f9 (diff)
downloadaports-aa5e512833c517b59570326b5eee07f177256d98.tar.bz2
aports-aa5e512833c517b59570326b5eee07f177256d98.tar.xz
main/lxc: upgrade to 1.0.0_rc4
Diffstat (limited to 'main/lxc')
-rw-r--r--main/lxc/0001-Don-t-include-linux-if_bridge.h.patch39
-rw-r--r--main/lxc/0001-fallback-from-udev-to-mdev.patch29
-rw-r--r--main/lxc/0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch31
-rw-r--r--main/lxc/0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch36
-rw-r--r--main/lxc/0001-lxc-alpine-allow-dev-full.patch33
-rw-r--r--main/lxc/0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch29
-rw-r--r--main/lxc/0001-lxc-alpine-create-dev-zero.patch26
-rw-r--r--main/lxc/0001-lxc-alpine-enable-4-consoles-by-default.patch30
-rw-r--r--main/lxc/0001-lxc-alpine-enable-loopback-interface-by-default.patch34
-rw-r--r--main/lxc/0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch28
-rw-r--r--main/lxc/0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch33
-rw-r--r--main/lxc/0002-lxc-alpine-add-arm.patch10
-rw-r--r--main/lxc/0002-lxc-alpine-add-support-for-architecture-arm.patch27
-rw-r--r--main/lxc/APKBUILD113
14 files changed, 97 insertions, 401 deletions
diff --git a/main/lxc/0001-Don-t-include-linux-if_bridge.h.patch b/main/lxc/0001-Don-t-include-linux-if_bridge.h.patch
deleted file mode 100644
index 4ebf2db5d..000000000
--- a/main/lxc/0001-Don-t-include-linux-if_bridge.h.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From a7673ab3ebaaf9bdb6bd840791c1ad672ab7f341 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 29 Jan 2014 13:36:37 +0000
-Subject: [PATCH] Don't include linux/if_bridge.h
-
-Instead rely on struct ethhdr from net/ethernet.h
-
-This fixes build error with musl libc:
-In file included from /usr/include/linux/if_bridge.h:17:0,
- from network.c:47:
-/usr/include/linux/if_ether.h:133:8: error: redefinition of 'struct ethhdr'
- struct ethhdr {
- ^
-In file included from /usr/include/net/ethernet.h:10:0,
- from network.c:42:
-/usr/include/netinet/if_ether.h:93:8: note: originally defined here
- struct ethhdr {
- ^
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/lxc/network.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/lxc/network.c b/src/lxc/network.c
-index bd2a37c..34845d1 100644
---- a/src/lxc/network.c
-+++ b/src/lxc/network.c
-@@ -44,7 +44,6 @@
- #include <linux/netlink.h>
- #include <linux/rtnetlink.h>
- #include <linux/sockios.h>
--#include <linux/if_bridge.h>
-
- #include "nl.h"
- #include "network.h"
---
-1.8.5.3
-
diff --git a/main/lxc/0001-fallback-from-udev-to-mdev.patch b/main/lxc/0001-fallback-from-udev-to-mdev.patch
deleted file mode 100644
index a14feff59..000000000
--- a/main/lxc/0001-fallback-from-udev-to-mdev.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From bd784acbbf0ea501d2b63be2c6f7fe0cfa179886 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Mon, 17 Feb 2014 14:00:08 +0000
-Subject: [PATCH] fallback from udev to mdev
-
----
- src/lxc/lxc-create.in | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/lxc/lxc-create.in b/src/lxc/lxc-create.in
-index ebbdd7b..44ac8e6 100644
---- a/src/lxc/lxc-create.in
-+++ b/src/lxc/lxc-create.in
-@@ -330,7 +330,11 @@ fi
- if [ "$backingstore" = "lvm" ]; then
- [ -d "$rootfs" ] || mkdir $rootfs
- lvcreate -L $fssize -n $lvname $vgname || exit 1
-- udevadm settle
-+ if [ -x /sbin/udevadm ]; then
-+ udevadm settle
-+ else
-+ mdev -s
-+ fi
- mkfs -t $fstype $rootdev || exit 1
- mount -t $fstype $rootdev $rootfs
- fi
---
-1.8.5.4
-
diff --git a/main/lxc/0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch b/main/lxc/0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch
new file mode 100644
index 000000000..02a5b02f6
--- /dev/null
+++ b/main/lxc/0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch
@@ -0,0 +1,31 @@
+From aa0337f7856feefab804c8a7bba4eaca205d3bab Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 20 Feb 2014 09:48:37 +0000
+Subject: [PATCH 1/2] lua: Do not link Lua module to the Lua core library
+
+Modules should not link to the Lua core library.
+
+See http://lua-users.org/wiki/BuildingModules under
+"Do Not Link Modules to the Lua Core Libraries"
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ src/lua-lxc/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lua-lxc/Makefile.am b/src/lua-lxc/Makefile.am
+index 7bbaf61..540238f 100644
+--- a/src/lua-lxc/Makefile.am
++++ b/src/lua-lxc/Makefile.am
+@@ -18,7 +18,7 @@ core_so_LDFLAGS = \
+ -L$(top_srcdir)/src/lxc \
+ -Wl,-soname,core.so.$(firstword $(subst ., ,$(VERSION)))
+
+-core_so_LDADD = -llxc $(LUA_LIBS)
++core_so_LDADD = -llxc
+
+ lxc.lua:
+
+--
+1.8.5.4
+
diff --git a/main/lxc/0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch b/main/lxc/0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch
deleted file mode 100644
index 432c86c34..000000000
--- a/main/lxc/0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 75b5535282453b3442a41df4a3ba6d3058cd6e48 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 4 Sep 2013 17:01:09 +0200
-Subject: [PATCH] lxc-alpine: add hwaddr for a single macvlan interface
-
-We already add harware address for a single veth interface. Do the same
-with a single macvlan interface.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
-Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
----
- templates/lxc-alpine.in | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index 2ab10bb..05aec74 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -173,9 +173,11 @@ lxc.network.flags = up
- EOF
- fi
-
-- # if there is exactly one veth network entry, make sure it has an
-- # associated mac address.
-- nics=$(grep -e '^lxc\.network\.type[ \t]*=[ \t]*veth' $path/config | wc -l)
-+ # if there is exactly one veth or macvlan network entry, make sure
-+ # it has an associated mac address.
-+ nics=$(awk -F '[ \t]*=[ \t]*' \
-+ '$1=="lxc.network.type" && ($2=="veth" || $2=="macvlan") {print $2}' \
-+ $path/config | wc -l)
- if [ "$nics" -eq 1 ] && ! grep -q "^lxc.network.hwaddr" $path/config; then
- # see http://sourceforge.net/tracker/?func=detail&aid=3411497&group_id=163076&atid=826303
- hwaddr="fe:$(dd if=/dev/urandom bs=8 count=1 2>/dev/null |od -t x8 | \
---
-1.8.4.1
-
diff --git a/main/lxc/0001-lxc-alpine-allow-dev-full.patch b/main/lxc/0001-lxc-alpine-allow-dev-full.patch
deleted file mode 100644
index 5abbf22e6..000000000
--- a/main/lxc/0001-lxc-alpine-allow-dev-full.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 6bd3f98c469f311f6afbffbb3586efddae3c4eb4 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 22 Oct 2013 13:23:31 +0200
-Subject: [PATCH] lxc-alpine: allow /dev/full
-
-The template creates /dev/full for the container but needs also give
-permission to access it.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
-Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
----
- templates/lxc-alpine.in | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index 5fdf36f..8600a34 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -197,9 +197,10 @@ lxc.cap.drop = sys_module mac_admin mac_override sys_time
-
- # devices
- lxc.cgroup.devices.deny = a
--# /dev/null and zero
-+# /dev/null, zero and full
- lxc.cgroup.devices.allow = c 1:3 rwm
- lxc.cgroup.devices.allow = c 1:5 rwm
-+lxc.cgroup.devices.allow = c 1:7 rwm
- # consoles
- lxc.cgroup.devices.allow = c 5:1 rwm
- lxc.cgroup.devices.allow = c 5:0 rwm
---
-1.8.4.1
-
diff --git a/main/lxc/0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch b/main/lxc/0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch
deleted file mode 100644
index 5ea417db5..000000000
--- a/main/lxc/0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From e4a08b5ec1798c6c2fcf129018f666148aeedf8b Mon Sep 17 00:00:00 2001
-From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-Date: Sat, 25 Jan 2014 22:58:58 +0200
-Subject: [PATCH] lxc-alpine: copy /etc/TZ to container if present
-
-Signed-off-by: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
----
- templates/lxc-alpine.in | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index ac328a4..50a6a71 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -109,6 +109,11 @@ tty4:12345:respawn:/sbin/getty 38400 tty4
- ::ctrlaltdel:/sbin/reboot
- ::shutdown:/sbin/rc shutdown
- EOF
-+ # set up timezone
-+ if [ -f /etc/TZ ]; then
-+ cp /etc/TZ "$rootfs/etc/TZ"
-+ fi
-+
- # set up nameserver
- grep nameserver /etc/resolv.conf > "$rootfs/etc/resolv.conf"
-
---
-1.8.3.1
-
diff --git a/main/lxc/0001-lxc-alpine-create-dev-zero.patch b/main/lxc/0001-lxc-alpine-create-dev-zero.patch
deleted file mode 100644
index b42049656..000000000
--- a/main/lxc/0001-lxc-alpine-create-dev-zero.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 48c63f8d035045af1103b677b5ec577aec59a5b5 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Mon, 26 Aug 2013 13:47:58 +0200
-Subject: [PATCH] lxc-alpine: create /dev/zero
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
-Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
----
- templates/lxc-alpine.in | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index ce7226f..2ab10bb 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -126,6 +126,7 @@ EOF
- echo "Setting up device nodes"
- mkdir -p -m 755 "$rootfs/dev/pts"
- mkdir -p -m 1777 "$rootfs/dev/shm"
-+ mknod -m 666 "$rootfs/dev/zero" c 1 5
- mknod -m 666 "$rootfs/dev/full" c 1 7
- mknod -m 666 "$rootfs/dev/random" c 1 8
- mknod -m 666 "$rootfs/dev/urandom" c 1 9
---
-1.8.4
-
diff --git a/main/lxc/0001-lxc-alpine-enable-4-consoles-by-default.patch b/main/lxc/0001-lxc-alpine-enable-4-consoles-by-default.patch
deleted file mode 100644
index c971a5410..000000000
--- a/main/lxc/0001-lxc-alpine-enable-4-consoles-by-default.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 11a944612ca93b8e39f6681c265c70e108f3caf2 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 24 Oct 2013 13:13:28 +0200
-Subject: [PATCH] lxc-alpine: enable 4 consoles by default
-
-We allow 4 consoles in the LXC config file so we can enable 4 in the
-inittab as well.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- templates/lxc-alpine.in | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index 2756b89..258eed4 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -103,6 +103,9 @@ configure_alpine() {
- ::sysinit:/sbin/rc sysinit
- ::wait:/sbin/rc default
- tty1:12345:respawn:/sbin/getty 38400 tty1
-+tty2:12345:respawn:/sbin/getty 38400 tty2
-+tty3:12345:respawn:/sbin/getty 38400 tty3
-+tty4:12345:respawn:/sbin/getty 38400 tty4
- ::ctrlaltdel:/sbin/reboot
- ::shutdown:/sbin/rc shutdown
- EOF
---
-1.8.4.1
-
diff --git a/main/lxc/0001-lxc-alpine-enable-loopback-interface-by-default.patch b/main/lxc/0001-lxc-alpine-enable-loopback-interface-by-default.patch
deleted file mode 100644
index 4d13d0124..000000000
--- a/main/lxc/0001-lxc-alpine-enable-loopback-interface-by-default.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 3d460a3856376a043b3fa9addee50f89d21fa747 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 16 Oct 2013 14:55:31 +0200
-Subject: [PATCH] lxc-alpine: enable loopback interface by default
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-It was probably disabled by a mistake
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
-Acked-by: Stéphane Graber <stgraber@ubuntu.com>
----
- templates/lxc-alpine.in | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index 05aec74..5fdf36f 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -110,9 +110,8 @@ EOF
- grep nameserver /etc/resolv.conf > "$rootfs/etc/resolv.conf"
-
- # configure the network using the dhcp
-- # note that lxc will set up lo interface
- cat <<EOF > $rootfs/etc/network/interfaces
--#auto lo
-+auto lo
- iface lo inet loopback
-
- auto eth0
---
-1.8.4.1
-
diff --git a/main/lxc/0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch b/main/lxc/0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch
deleted file mode 100644
index bb52c4a3a..000000000
--- a/main/lxc/0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 8b591d7f16bf65eb712d71c3e103d7fbef338579 Mon Sep 17 00:00:00 2001
-From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-Date: Mon, 27 Jan 2014 16:52:31 +0200
-Subject: [PATCH v2] lxc-alpine: mount tmpfs on /dev/shm
-
-Signed-off-by: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
----
-Changes since v1:
- Added missing sign-off
-
- templates/lxc-alpine.in | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index 50a6a71..40957ab 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -227,6 +227,7 @@ lxc.cgroup.devices.allow = c 254:0 rm
- lxc.mount.entry=proc proc proc nodev,noexec,nosuid 0 0
- lxc.mount.entry=run run tmpfs nodev,noexec,nosuid,relatime,size=1m,mode=0755 0 0
- lxc.mount.entry=none dev/pts devpts gid=5,mode=620 0 0
-+lxc.mount.entry=shm dev/shm tmpfs nodev,nosuid,noexec 0 0
-
- EOF
-
---
-1.8.3.1
-
diff --git a/main/lxc/0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch b/main/lxc/0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch
deleted file mode 100644
index a24abbb96..000000000
--- a/main/lxc/0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d19e00ae49f654b90f26f4c7828f74ea1b664343 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 24 Oct 2013 08:13:34 +0200
-Subject: [PATCH] lxc-alpine: run bootmisc and syslog at boot runlevel
-
-The bootmisc script is needed to clean up various temp dirs like /tmp
-and migrate /var/run to /run if needed.
-
-The syslog service is started in 'boot' runlevel when running on real
-hardware so we do the same for containers.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- templates/lxc-alpine.in | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index 8600a34..2756b89 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -140,7 +140,8 @@ EOF
- mknod -m 666 "$rootfs/dev/ptmx" c 5 2
-
- # start services
-- ln -s /etc/init.d/syslog "$rootfs"/etc/runlevels/default/syslog
-+ ln -s /etc/init.d/bootmisc "$rootfs"/etc/runlevels/boot/bootmisc
-+ ln -s /etc/init.d/syslog "$rootfs"/etc/runlevels/boot/syslog
-
- return 0
- }
---
-1.8.4.1
-
diff --git a/main/lxc/0002-lxc-alpine-add-arm.patch b/main/lxc/0002-lxc-alpine-add-arm.patch
deleted file mode 100644
index 2ec898a91..000000000
--- a/main/lxc/0002-lxc-alpine-add-arm.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- lxc-0.9.0.orig/templates/lxc-alpine.in
-+++ lxc-0.9.0/templates/lxc-alpine.in
-@@ -334,6 +334,7 @@
- x86)
- lxc_arch=i686;;
- x86_64|"") ;;
-+ arm*) apk_arch=armhf;;
- *) die "unsupported architecture: $arch";;
- esac
-
diff --git a/main/lxc/0002-lxc-alpine-add-support-for-architecture-arm.patch b/main/lxc/0002-lxc-alpine-add-support-for-architecture-arm.patch
new file mode 100644
index 000000000..f4bfad2fc
--- /dev/null
+++ b/main/lxc/0002-lxc-alpine-add-support-for-architecture-arm.patch
@@ -0,0 +1,27 @@
+From 882bdfc07672202fbade0d8e38d26cf0a5309b5d Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 20 Feb 2014 10:30:22 +0000
+Subject: [PATCH 2/2] lxc-alpine: add support for architecture arm
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ templates/lxc-alpine.in | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
+index afda971..d8c6674 100644
+--- a/templates/lxc-alpine.in
++++ b/templates/lxc-alpine.in
+@@ -368,6 +368,9 @@ case "$arch" in
+ ;;
+ x86_64|"")
+ ;;
++ arm*)
++ apk_arch=armhf
++ ;;
+ *)
+ die "unsupported architecture: $arch"
+ ;;
+--
+1.8.5.4
+
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index ac60349ed..36537eca4 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -1,54 +1,40 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxc
-pkgver=0.9.0
-_mypkgver=${pkgver/_rc/-rc}
-pkgrel=11
+pkgver=1.0.0_rc4
+_mypkgver=${pkgver/_rc/.rc}
+pkgrel=0
pkgdesc="linux containers - tools"
url="http://lxc.sourceforge.net/"
arch="all"
license="GPL"
depends="bash"
depends_dev="libcap-dev"
-makedepends="$depends_dev lvm2 util-linux"
+makedepends="$depends_dev lvm2 util-linux automake autoconf libtool lua5.2-dev"
install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lvm"
-source="http://linuxcontainers.org/downloads/lxc-$_mypkgver.tar.gz
- bb-rm.patch
- bb-shutdown.patch
- alpine-template-backport.patch
- 0001-lxc-alpine-create-dev-zero.patch
- 0002-lxc-alpine-add-arm.patch
-
- 0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch
- 0001-lxc-alpine-allow-dev-full.patch
- 0001-lxc-alpine-enable-4-consoles-by-default.patch
- 0001-lxc-alpine-enable-loopback-interface-by-default.patch
- 0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch
- 0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch
- 0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch
- 0001-Don-t-include-linux-if_bridge.h.patch
- 0001-fallback-from-udev-to-mdev.patch
-
- lxc-fix-headers.patch
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lvm lua5.2-lxc:_lua52
+ $pkgname-templates $pkgname-libs"
+source="https://github.com/lxc/lxc/archive/lxc-$_mypkgver.tar.gz
+ 0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch
+ 0002-lxc-alpine-add-support-for-architecture-arm.patch
lxc.initd
"
-_builddir="${srcdir}/${pkgname}-${_mypkgver}"
+_builddir="${srcdir}/lxc-lxc-${_mypkgver}"
prepare() {
local i
cd "$_builddir"
- update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ ./autogen.sh
}
build() {
cd "$_builddir"
- [ "$CLIBC" = musl ] && export CFLAGS="$CFLAGS -Dutmpxname=utmpname -D_GNU_SOURCE"
+ LUA_VERSION=5.2 \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -56,6 +42,9 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--disable-apparmor \
+ --enable-lua \
+ --with-lua-pc=lua5.2 \
+ --with-distro=alpine \
|| return 1
make || return 1
}
@@ -74,54 +63,30 @@ lvm() {
mkdir "$subpkgdir"
}
-md5sums="8552a4479090616f4bc04d8473765fc9 lxc-0.9.0.tar.gz
-a0894c2ddf9133c3cc33c264e4596a3c bb-rm.patch
-e96514860ee34b62d1b208ab03c569bc bb-shutdown.patch
-25dd200bd158d16a05bb3e7aaef84697 alpine-template-backport.patch
-e08b77b3b35adac290b49b9c9e04754c 0001-lxc-alpine-create-dev-zero.patch
-181c01649399b2c2dbadab9713381358 0002-lxc-alpine-add-arm.patch
-c57d7008ab6e7f652159a5f2856a343d 0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch
-ee3339a1c5d388b65b24bdea924387a8 0001-lxc-alpine-allow-dev-full.patch
-c12ea194274b6c8d3b05bd43ed70c61d 0001-lxc-alpine-enable-4-consoles-by-default.patch
-999a89373f5e2c61d1369526de7e5850 0001-lxc-alpine-enable-loopback-interface-by-default.patch
-75979789ec45ef865895f5ce5721dd3e 0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch
-6c188f8dd2ba18e895eed2dec79fcab9 0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch
-c172314d12b6bc2ef7b39e891bb74a9c 0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch
-83e105a961993d46fb901e49230c69f2 0001-Don-t-include-linux-if_bridge.h.patch
-97279f1d46b9f7c07d43b7ca69513bad 0001-fallback-from-udev-to-mdev.patch
-24e7ae51da3c8c483d5228b821cc7244 lxc-fix-headers.patch
+_lua52() {
+ pkgdesc="Lua 5.2 module for LXC"
+ for i in lib share; do
+ mkdir -p "$subpkgdir"/usr/$i || return 1
+ mv "$pkgdir"/usr/$i/lua "$subpkgdir"/usr/$i/ || return 1
+ done
+}
+
+templates() {
+ pkgdesc="Templates for LXC"
+ mkdir -p "$subpkgdir"/usr/share/lxc
+ mv "$pkgdir"/usr/share/lxc/templates "$subpkgdir"/usr/share/lxc/
+}
+
+
+md5sums="6d9297d795dedc28c89e8517dc620872 lxc-1.0.0.rc4.tar.gz
+5efd75de6d122e1a1734537e96a4bd7c 0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch
+9fda3e60b50507139856fec83f7ec036 0002-lxc-alpine-add-support-for-architecture-arm.patch
9f780f761dcaec3ce40d083c6df044d4 lxc.initd"
-sha256sums="1e1767eae6cc5fbf892c0e193d25da420ba19f2db203716c38f7cdea3b654120 lxc-0.9.0.tar.gz
-c9caea06b87baf5e335821c7e9ce3caca849b33f8176fbd48126c605583e78fc bb-rm.patch
-0e5706cb077f750afdd6a5a4fd2afdf0b9113126c85e130d92680bed4ce9c20e bb-shutdown.patch
-df193c4cf08e171c23b0b472750b7b1e0e7a66971c03201a0523e4039909f33b alpine-template-backport.patch
-8b3b314d99209ae27d78cd4e9469638a945d68d03beefaec499bad373a7cb8cd 0001-lxc-alpine-create-dev-zero.patch
-415e28eae4d0611c899509835c70e82a06b2bae0b8f380b40de6eb0b5a039684 0002-lxc-alpine-add-arm.patch
-526ed739247422e0d326d0892612bec520508763203136c620c3c1ee4a9329bf 0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch
-66c10a207380f5c0f1945ed6f6b1254c554b68127bc3729d7bf335137ab0750d 0001-lxc-alpine-allow-dev-full.patch
-264cbc4efe6983050b3043fb4df031c4d9b93d35eb3c02463bddf530f8701880 0001-lxc-alpine-enable-4-consoles-by-default.patch
-eb5043672ef81cd5b20f25dc847bfad7e9e14b42a794856c3a8c8c1e4e408dfc 0001-lxc-alpine-enable-loopback-interface-by-default.patch
-51bd2fc5f166499c8996d1b89f324168b0c1bbb6b2b79260591d442120098a34 0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch
-92d7f479d8d466e03f187076a1187112a116f3a37426ba6d1dfd87ed7999c4c8 0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch
-b85e307faaacfa79854564032e17325bc30efdccf9e8ab3929ab7b44a5a74205 0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch
-f0911ff82ef8fc3f1832f3af771fe6d9944f12d7409feb7d4233136e6720ad05 0001-Don-t-include-linux-if_bridge.h.patch
-ccc57c12f81f68b6d21688982bebb11f98840ca2288b8e9966d2078cd95bd9f8 0001-fallback-from-udev-to-mdev.patch
-82d584e30b1963bd638b5a640b2788d8ac3757b480f61fd2ab55a09b9a6f4ccd lxc-fix-headers.patch
+sha256sums="7b39c519b8eca6e502453f7e494ac6ce55b0850d526e1ed12ba9f44ef548b2fe lxc-1.0.0.rc4.tar.gz
+a245d3c218fba2f281c7326f3f25e67f82fcbdee78bd7588c2f57c0593550a77 0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch
+d2a266cbe7f877e41406381079a9d2a24151e0532d61ad3a6630bcbb3106bc52 0002-lxc-alpine-add-support-for-architecture-arm.patch
8bdb64ecf100b648396456f6765230aab8649665bfcf320baede529ce6c5484d lxc.initd"
-sha512sums="a96133660ca6ea45dc4b8d167267120328577339e933ff9510f03e9d368ca5db77031dc1e7e4529b3e506f63f79c2ce3f8f72571a7dfdbeb2a8799777782a606 lxc-0.9.0.tar.gz
-b8fe47af6b1341ca472b6337c304f52402c53d400fc1d13895f2f568dd4d81b9ff281efc70bc1ddc221ac457db3bed4a199491059a15f66755deddc93ce91bf1 bb-rm.patch
-86df52e380a01d6d3f588ca395925e8f774529c72e5b4c8dcb701d79fad7697ed8800f0ff51fded2896b2d2af49faa7f26960234fc8c1a6b4bc8f42d85078e6d bb-shutdown.patch
-d10e25aeee0aba61a4c3420fe1b2bfd9213e7ef10f399ed5f0ba5d978a97a49fd23044b098f73f6d9651c23b1bb025f30d81deb6aec9edf4d2267afc22a09d60 alpine-template-backport.patch
-0304aabfac3280cbc18347f1168b2289a98e03b9f6a3134770e43bb914978a64a108a0b0ec709856db161e98366c06c8a65d5a30e730add4cee2968718cdc93a 0001-lxc-alpine-create-dev-zero.patch
-d1860b5a47303762ec82d65c2f2c6feaac0115aeb2ddaaf6c052085e9b8dc1d8f6bd05af1c8596c7c978391af75cbe97b38f98f37dd036d61bd9cea9b81226dd 0002-lxc-alpine-add-arm.patch
-55c2a67eff5c90721de5949b21afc5aa77bf28323616f551beb4404cacfd0ba38cbb7d5046ed54d685414b5fdbbd5b5f20df9cb0c8ee2c0c12e48bd35866e033 0001-lxc-alpine-add-hwaddr-for-a-single-macvlan-interface.patch
-dd686d8ce9cd73807b744163e6b20e41eca17f3ee618cef66f19488cb2527b56d38c04231d25177de6295f2df224cd567add90e257dfa9d6be7f9a50f5c7bf21 0001-lxc-alpine-allow-dev-full.patch
-372490dc5a459778e97b75691ed48b2c070c0a9b16f08c7f5ef3a791ded64fe5f23ca1e145314fea355664a2b055eb572546dd0793560137baae0898184c9e19 0001-lxc-alpine-enable-4-consoles-by-default.patch
-47d31ed9d0cdde58b0ee97b3f179db270534b73fe8c77fe72fdef1483a545e608a533d41e8b4041474493016cd445fe02751663ad0cbc7fc9af241b344454dea 0001-lxc-alpine-enable-loopback-interface-by-default.patch
-75130578c4103586b973c6e9586833acfa89de8021f4dd320385905c4f9d3d1bf7a1e8d3cfe8704a3add00d41d19c30a371bce232a863e9c837a148e9066a0d6 0001-lxc-alpine-run-bootmisc-and-syslog-at-boot-runlevel.patch
-7c5e6656565ed0ec51449baab4d310520cc43805428515d6541d4c4e03cc2f44b6762b3239983ee06596dcdec68d395250f944aabe92afc91ba2432f4847555b 0001-lxc-alpine-copy-etc-TZ-to-container-if-present.patch
-850bc35c56e7c7b7e7a3efde504e2ceefbb790a3298d96e195ab610a83a946b3783e409ce14639fb9e8ac03ccc05b973c0c81803c514148c0e1c726249277eaa 0001-lxc-alpine-mount-tmpfs-on-dev-shm.patch
-ebdc01504a3e4d48ba96f6e9c6786c02f6803a14ae6754f52aee12c462c7a24e678cf520318662e2f7e4efcd65cd577c2d415ca13fcb7ace323f59bdcfec9f75 0001-Don-t-include-linux-if_bridge.h.patch
-fa5d69ced46ecb5994f615f70589fd70eaecd8b9d8873887afff6ce0671efbf0e2518ed3e873c25ca8367d860d0f1ba34b17f57563a9c18b84cf6c20c1bdf52a 0001-fallback-from-udev-to-mdev.patch
-2c4138e57021714d66bd4d30cfedd768965a0ec11776363b83db7d4efa8c06901c42ee1ad13dff68fd8e3e6a1c34034c529c1f8995d9d3a57a318bc7023fbc05 lxc-fix-headers.patch
+sha512sums="838d709c96002426069f8eea9c2153f06fe964516998408753ffefdcdefc16c30819c0c40923572f842f7448403134c3cbbc46a6bd17085e16d410bce402ba39 lxc-1.0.0.rc4.tar.gz
+910d37d794435753c69729e83f258ed7f6acc38b5d8c07446bc5937b2ebacb09cc0282ed8f24bbf587236e0dfbad81e40860a2b9bf24c868df867b9cebb24f20 0001-lua-Do-not-link-Lua-module-to-the-Lua-core-library.patch
+16429f40fa3a6a8dc7f4198cc780f4003c14fd67a2796c09624ef951f879d238f345ab5a645c4c4ab1f029626e2d3f9e7c237378188b7c92b5af289987eee50e 0002-lxc-alpine-add-support-for-architecture-arm.patch
e3aa39c60db6ba73cbe3fcb27170dd83a03a0a175d8a28513f242a81eef5cb0e90b78dc63fc8da5c7160e60bc780111679fd6d0e401a0d6626e574c328c5afb0 lxc.initd"