summaryrefslogtreecommitdiffstats
path: root/main/m4
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-08 14:29:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-08 14:29:48 +0000
commit2e9f2610e8718044c7718061c65226867e14f179 (patch)
treea20d7c9864f744079cf03e4a7b99676dfa82a3f4 /main/m4
parent1b4681b401bd5782d1e69217ccd4d9b7082a54d8 (diff)
downloadaports-2e9f2610e8718044c7718061c65226867e14f179.tar.bz2
aports-2e9f2610e8718044c7718061c65226867e14f179.tar.xz
main/m4: minor build fix
Diffstat (limited to 'main/m4')
-rw-r--r--main/m4/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/main/m4/APKBUILD b/main/m4/APKBUILD
index 65a998eaf..0d5a63e80 100644
--- a/main/m4/APKBUILD
+++ b/main/m4/APKBUILD
@@ -3,18 +3,21 @@ pkgname=m4
pkgver=1.4.13
pkgrel=0
pkgdesc="GNU macro processor"
-arch=i486
url="http://www.gnu.org/software/m4"
source=ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
-depends=uclibc
-license=GPL
+depends=
+license="GPL"
subpackages="m4-doc"
-origin="core/$pkgname"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$_builddir"
./configure --prefix=/usr
make
+}
+
+package() {
+ cd "$_builddir"
make install DESTDIR="$pkgdir"
}