summaryrefslogtreecommitdiffstats
path: root/main/m4
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-30 17:38:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-30 17:38:20 +0000
commit4fe58eca059e61cda63b82b4fede532db09a8d15 (patch)
tree6d85d4bef4d2aa92fd4cdf57afa568e041c55857 /main/m4
parentfecb3a7dbb06f80aae47047987cd0edcea23f611 (diff)
downloadaports-4fe58eca059e61cda63b82b4fede532db09a8d15.tar.bz2
aports-4fe58eca059e61cda63b82b4fede532db09a8d15.tar.xz
main/m4: upgrade to 1.4.14
Diffstat (limited to 'main/m4')
-rw-r--r--main/m4/APKBUILD13
-rw-r--r--main/m4/gnulib-uclibc.patch13
2 files changed, 23 insertions, 3 deletions
diff --git a/main/m4/APKBUILD b/main/m4/APKBUILD
index 0d5a63e80..b1350037e 100644
--- a/main/m4/APKBUILD
+++ b/main/m4/APKBUILD
@@ -1,15 +1,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=m4
-pkgver=1.4.13
+pkgver=1.4.14
pkgrel=0
pkgdesc="GNU macro processor"
url="http://www.gnu.org/software/m4"
-source=ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
depends=
license="GPL"
subpackages="m4-doc"
+source="ftp://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
+ gnulib-uclibc.patch"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/gnulib-uclibc.patch
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr
@@ -21,4 +27,5 @@ package() {
make install DESTDIR="$pkgdir"
}
-md5sums="e9e36108b5f9855a82ca4a07ebc0fd2e m4-1.4.13.tar.gz"
+md5sums="f0542d58f94c7d0ce0d01224e447be66 m4-1.4.14.tar.gz
+20a7dedec0e9e0ee7107e33e798ffdbe gnulib-uclibc.patch"
diff --git a/main/m4/gnulib-uclibc.patch b/main/m4/gnulib-uclibc.patch
new file mode 100644
index 000000000..09775d6b1
--- /dev/null
+++ b/main/m4/gnulib-uclibc.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/spawn.in.h b/lib/spawn.in.h
+index 84ba93c..6df4599 100644
+--- a/lib/spawn.in.h
++++ b/lib/spawn.in.h
+@@ -31,7 +31,7 @@
+
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+ But avoid namespace pollution on glibc systems. */
+-#ifndef __GLIBC__
++#if !defined(__GLIBC__) || defined(__UCLIBC__)
+ # include <sched.h>
+ # include <signal.h>
+ #endif