summaryrefslogtreecommitdiffstats
path: root/main/make
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-25 09:29:57 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-25 19:36:37 +0000
commit05fc9a20c9e73d348ae95f2590969828b0672afc (patch)
tree023d5e965d3586615b6970e7b2b1a6b257f9c9da /main/make
parentc20ca9f3a1cc91f6537237ba43457419eac247e5 (diff)
downloadaports-05fc9a20c9e73d348ae95f2590969828b0672afc.tar.bz2
aports-05fc9a20c9e73d348ae95f2590969828b0672afc.tar.xz
main/make: switch to bz2 and added checks
Diffstat (limited to 'main/make')
-rw-r--r--main/make/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/make/APKBUILD b/main/make/APKBUILD
index a7ae27722..e474de724 100644
--- a/main/make/APKBUILD
+++ b/main/make/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="GPL3+"
depends=""
subpackages="$pkgname-doc"
-source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
make-3.82-savannah-bugs-30612-30723.patch
make-3.82-copy-on-expand.patch
make-3.82-memory-corruption.patch
@@ -35,14 +35,15 @@ build() {
--infodir=/usr/share/info \
--disable-nls
make || return 1
+ make check || return 1
}
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install || return 1
}
-md5sums="7f7c000e3b30c6840f2e9cf86b254fac make-3.82.tar.gz
+md5sums="1a11100f3c63fcf5753818e59d63088f make-3.82.tar.bz2
74e598a2052f7d98e3495ea9d917ecf4 make-3.82-savannah-bugs-30612-30723.patch
9545e667ab5eafdef5b658941290cc26 make-3.82-copy-on-expand.patch
0436e740edbc81cf27fd598241b8dcf0 make-3.82-memory-corruption.patch