summaryrefslogtreecommitdiffstats
path: root/main/mesa
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-04 19:11:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-04 19:11:40 +0000
commit026e30ff3b765132d37b0aeb45bb75e0801f31cd (patch)
tree98658b08c24761ae5a0e43beea00efb879018019 /main/mesa
parent7e31912085782e33f25baf5d53b8321c9439918c (diff)
downloadaports-026e30ff3b765132d37b0aeb45bb75e0801f31cd.tar.bz2
aports-026e30ff3b765132d37b0aeb45bb75e0801f31cd.tar.xz
main/mesa: upgrade to 7.10.2 and enable nouveau again
Diffstat (limited to 'main/mesa')
-rw-r--r--main/mesa/APKBUILD16
-rw-r--r--main/mesa/Mesa-7.10.1-nouveau-compile.patch139
2 files changed, 149 insertions, 6 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index db53d75a5..01ce8d408 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
-pkgver=7.10.1
-pkgrel=3
+pkgver=7.10.2
+pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
arch="all"
@@ -17,6 +17,7 @@ subpackages="$pkgname-dev
$pkgname-dri-swrast:swrast
$pkgname-dri-tdfx:tdfx
$pkgname-dri-unichrome:unichrome
+ $pkgname-dri-nouveau:nouveau
$pkgname-egl
"
@@ -26,7 +27,9 @@ makedepends="pkgconfig libdrm-dev libxxf86vm-dev libxdamage-dev expat-dev
source="ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2
mesa-7.10-uclibc.patch
mesa-7.10-uclibc-glsl.patch
- mesa-7.10-uclibc-gallium.patch"
+ mesa-7.10-uclibc-gallium.patch
+ Mesa-7.10.1-nouveau-compile.patch
+ "
depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
libxdamage-dev libxfixes-dev libxcb-dev glproto"
@@ -70,7 +73,7 @@ build() {
--enable-xcb \
--enable-egl \
--enable-gles2 \
- --disable-gallium-nouveau \
+ --enable-gallium-nouveau \
--disable-gallium-egl \
--disable-glut \
--disable-glw || return 1
@@ -119,7 +122,8 @@ unichrome() { _mv_dri unichrome_dri; }
nouveau() { _mv_dri nouveau_dri; }
swrast() { _mv_dri swrast_dri; }
-md5sums="efe8da4d80c2a5d32a800770b8ce5dfa MesaLib-7.10.1.tar.bz2
+md5sums="f5de82852f1243f42cc004039e10b771 MesaLib-7.10.2.tar.bz2
9c8c161f954f0d08895cd9d45e63f498 mesa-7.10-uclibc.patch
03e9685b0d714e915c35fd0fb5fde810 mesa-7.10-uclibc-glsl.patch
-90a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch"
+90a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch
+34e3d4bb5f16bae55929958083087c0a Mesa-7.10.1-nouveau-compile.patch"
diff --git a/main/mesa/Mesa-7.10.1-nouveau-compile.patch b/main/mesa/Mesa-7.10.1-nouveau-compile.patch
new file mode 100644
index 000000000..96dafceb0
--- /dev/null
+++ b/main/mesa/Mesa-7.10.1-nouveau-compile.patch
@@ -0,0 +1,139 @@
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c.ark 2011-04-11 10:26:00.717291484 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c 2011-04-11 10:26:05.600624698 +0200
+@@ -24,6 +24,8 @@
+ #include "pipe/p_defines.h"
+ #include "pipe/p_state.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+
+ void
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c.ark 2011-04-11 10:25:55.913958268 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c 2011-04-11 10:26:00.663958154 +0200
+@@ -23,6 +23,8 @@
+ #include "draw/draw_context.h"
+ #include "pipe/p_defines.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+ #include "nv50_screen.h"
+ #include "nv50_resource.h"
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c.ark 2011-04-11 10:25:50.250625073 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c 2011-04-11 10:25:55.873958269 +0200
+@@ -4,6 +4,8 @@
+ #include "util/u_format.h"
+ #include "util/u_split_prim.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+ #include "nv50_resource.h"
+
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c.ark 2011-04-11 10:25:44.790625206 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c 2011-04-11 10:25:50.183958407 +0200
+@@ -23,6 +23,8 @@
+ #include "pipe/p_context.h"
+ #include "util/u_inlines.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+
+ struct nv50_query {
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c.ark 2011-04-11 10:25:32.790625497 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c 2011-04-11 10:25:38.633958688 +0200
+@@ -23,6 +23,8 @@
+ #include "util/u_format_s3tc.h"
+ #include "pipe/p_screen.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+ #include "nv50_screen.h"
+ #include "nv50_resource.h"
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c.ark 2011-04-11 10:25:38.710625354 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c 2011-04-11 10:25:44.713958540 +0200
+@@ -26,6 +26,8 @@
+ #include "pipe/p_state.h"
+ #include "util/u_inlines.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+
+ static void
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c.ark 2011-04-11 10:25:27.520625626 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c 2011-04-11 10:25:32.737292166 +0200
+@@ -22,6 +22,7 @@
+
+ #include "util/u_format.h"
+
++#include <nouveau/nv04_pushbuf.h>
+ #include "nv50_context.h"
+ #include "nv50_resource.h"
+ #include "nouveau/nouveau_stateobj.h"
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c.ark 2011-04-11 10:25:22.407292417 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c 2011-04-11 10:25:27.450625628 +0200
+@@ -22,6 +22,7 @@
+
+ #define __NOUVEAU_PUSH_H__
+ #include <stdint.h>
++#include <nouveau/nv04_pushbuf.h>
+ #include "nouveau/nouveau_pushbuf.h"
+ #include "nv50_context.h"
+ #include "nv50_resource.h"
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c.ark 2011-04-11 10:25:14.903959267 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c 2011-04-11 10:25:22.353959086 +0200
+@@ -4,6 +4,8 @@
+ #include "util/u_format.h"
+ #include "util/u_math.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+ #include "nv50_transfer.h"
+ #include "nv50_resource.h"
+--- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c.ark 2011-04-11 10:25:01.717292921 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c 2011-04-11 10:25:14.850625935 +0200
+@@ -26,6 +26,8 @@
+ #include "util/u_format.h"
+ #include "util/u_split_prim.h"
+
++#include <nouveau/nv04_pushbuf.h>
++
+ #include "nv50_context.h"
+ #include "nv50_resource.h"
+
+--- Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c.ark 2011-04-11 10:23:22.800628664 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c 2011-04-11 10:25:01.640626257 +0200
+@@ -39,6 +39,7 @@
+ #include <nouveau/nouveau_bo.h>
+ #include <nouveau/nouveau_notifier.h>
+ #include <nouveau/nouveau_grobj.h>
++#include <nouveau/nv04_pushbuf.h>
+ #include "nv04_2d.h"
+
+ #include "nouveau/nv_object.xml.h"
+--- Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c.ark 2011-04-11 10:27:59.380621927 +0200
++++ Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c 2011-04-11 10:28:02.833955176 +0200
+@@ -3,6 +3,7 @@
+ #include "util/u_format_s3tc.h"
+ #include "util/u_simple_screen.h"
+
++#include <nouveau/nv04_pushbuf.h>
+ #include "nouveau/nouveau_screen.h"
+ #include "nouveau/nv_object.xml.h"
+ #include "nvfx_context.h"
+--- Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c.ark 2011-04-11 10:27:27.220622711 +0200
++++ Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c 2011-04-11 11:09:24.147228063 +0200
+@@ -24,6 +24,8 @@
+ *
+ */
+
++#include <stdint.h>
++#include <nouveau/nv04_pushbuf.h>
+ #include "nouveau_driver.h"
+ #include "nouveau_context.h"
+ #include "nouveau_fbo.h"