summaryrefslogtreecommitdiffstats
path: root/main/mesa
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-17 10:56:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-17 10:57:37 +0000
commit227591463010f6f2423d3789245a4d774c6df033 (patch)
tree1b2de113a60d0936b61031a3819f140d1e6a7420 /main/mesa
parent5b2397a4b51c03ddc034d0c8cc04d30ab7d56f57 (diff)
downloadaports-227591463010f6f2423d3789245a4d774c6df033.tar.bz2
aports-227591463010f6f2423d3789245a4d774c6df033.tar.xz
main/mesa: upgrade to 8.0.4
Disable nouveau dri for now https://bugs.freedesktop.org/show_bug.cgi?id=50280
Diffstat (limited to 'main/mesa')
-rw-r--r--main/mesa/APKBUILD91
-rw-r--r--main/mesa/ccache.patch11
-rw-r--r--main/mesa/mesa-8.0.3-llvm-3.1-fixes.patch46
-rw-r--r--main/mesa/parallel.patch14
4 files changed, 146 insertions, 16 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 00276f10c..cc0dafa81 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
-pkgver=8.0.3
+pkgver=8.0.4
pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
@@ -11,21 +11,25 @@ subpackages="$pkgname-dev
$pkgname-dri-ati:ati
$pkgname-dri-intel:intel
$pkgname-dri-swrast:swrast
- $pkgname-dri-nouveau:nouveau
$pkgname-dri-vmwgfx:vmwgfx
- $pkgname-egl $pkgname-glu $pkgname-gl $pkgname-gles
+ $pkgname-glapi $pkgname-egl $pkgname-glu $pkgname-gl $pkgname-gles
+ $pkgname-xatracker $pkgname-osmesa $pkgname-gbm
"
+# $pkgname-dri-nouveau:nouveau
depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
libxdamage-dev libxfixes-dev libxcb-dev glproto"
makedepends="$depends_dev expat-dev xextproto python libxt-dev makedepend
- talloc-dev py-libxml2 flex bison llvm-dev
+ talloc-dev py-libxml2 flex bison llvm-dev udev-dev
autoconf automake"
source="ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2
mesa-8.0.3-uclibc-strtod.patch
+ mesa-8.0.3-llvm-3.1-fixes.patch
mesa-7.10-uclibc-gallium.patch
imports-uclibc.patch
glx_ro_text_segm.patch
+ ccache.patch
+ parallel.patch
"
@@ -63,15 +67,34 @@ build() {
./configure --prefix=/usr \
--with-dri-driverdir=$_dri_driverdir \
--disable-asm \
- --disable-glx-tls \
- --with-driver=dri \
- --enable-egl \
- --enable-gles2 \
- --with-gallium-drivers=i915,nouveau,r300,r600,svga,swrast \
- --disable-gallium-egl \
+ --enable-pic \
--enable-glx-rts \
+ --with-gallium-drivers=r300,r600,svga,swrast \
+ --with-dri-drivers=i915,i965,r200,radeon,swrast \
+ --enable-gallium-llvm \
+ --enable-gallium-egl \
+ --enable-shared-glapi \
+ --enable-gbm \
+ --enable-glx-tls \
+ --enable-dri \
+ --enable-glx \
+ --enable-osmesa \
+ --enable-gles1 \
+ --enable-gles2 \
+ --enable-egl \
+ --enable-texture-float \
+ --enable-xa \
+ --enable-shared-dricore \
|| return 1
+# --with-driver=dri \
+# --enable-egl \
+# --enable-gles2 \
+# --with-gallium-drivers=i915,nouveau,r300,r600,svga,swrast \
+# --enable-gallium-llvm \
+# --enable-gallium-egl \
+# --enable-glx-rts \
+ make -C src/mesa depend || return 1
make || return 1
# check so we dont have any bind NOW
@@ -88,14 +111,19 @@ egl() {
replaces="mesa"
pkgdesc="Mesa libEGL runtime libraries"
install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libEGL.so* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libEGL.so* \
+ "$pkgdir"/usr/lib/egl \
+ "$subpkgdir"/usr/lib/
}
gl() {
replaces="mesa"
pkgdesc="Mesa libGL runtime libraries"
install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libGL.so* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libGL.so* \
+ "$pkgdir"/$_dri_driverdir/libglsl.so \
+ "$pkgdir"/$_dri_driverdir/libdricore.so \
+ "$subpkgdir"/usr/lib/
}
glu() {
@@ -105,12 +133,40 @@ glu() {
mv "$pkgdir"/usr/lib/libGLU.so* "$subpkgdir"/usr/lib/
}
+glapi() {
+ replace="$pkgname-gles"
+ pkgdesc="Mesa shared glapi"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libglapi.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
gles() {
replaces="mesa"
pkgdesc="Mesa libGLESv2 runtime libraries"
install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libGLESv2.so* \
- "$pkgdir"/usr/lib/libglapi.so.* \
+ mv "$pkgdir"/usr/lib/libGLES*.so* \
+ "$subpkgdir"/usr/lib/
+}
+
+xatracker() {
+ pkgdesc="Mesa XA state tracker for vmware"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libxatracker*.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+osmesa() {
+ pkgdesc="Mesa offscreen rendering libraries"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libOSMesa.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+gbm() {
+ pkgdesc="Mesa gbm library"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libgbm.so.* \
"$subpkgdir"/usr/lib/
}
@@ -131,8 +187,11 @@ nouveau() { _mv_dri nouveau_dri nouveau_vieux_dri; }
swrast() { _mv_dri swrast_dri; }
vmwgfx() { _mv_dri vmwgfx_dri; }
-md5sums="cc5ee15e306b8c15da6a478923797171 MesaLib-8.0.3.tar.bz2
+md5sums="d546f988adfdf986cff45b1efa2d8a46 MesaLib-8.0.4.tar.bz2
13cc91257dac1311013f681705bcf3aa mesa-8.0.3-uclibc-strtod.patch
+c452ed3392468170726c004c2f4e02ca mesa-8.0.3-llvm-3.1-fixes.patch
90a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch
bc2d3e144f7577be016b44b514d0b923 imports-uclibc.patch
-a1a766b4c6a96d67cad9bd7ad5c578e8 glx_ro_text_segm.patch"
+a1a766b4c6a96d67cad9bd7ad5c578e8 glx_ro_text_segm.patch
+1f30bf8340114b455f005cc9b134c414 ccache.patch
+d6319aa729775249541550154ebf7d8f parallel.patch"
diff --git a/main/mesa/ccache.patch b/main/mesa/ccache.patch
new file mode 100644
index 000000000..c75d659fa
--- /dev/null
+++ b/main/mesa/ccache.patch
@@ -0,0 +1,11 @@
+--- ./src/gallium/targets/xa-vmwgfx/Makefile.orig
++++ ./src/gallium/targets/xa-vmwgfx/Makefile
+@@ -59,7 +59,7 @@
+ # Make the library
+ $(TOP)/$(LIB_DIR)/gallium/$(XA_LIB_NAME): depend $(OBJECTS) $(XA_LIB_DEPS) \
+ xa_symbols
+- $(MKLIB) -o $(XA_LIB) -linker $(LD) -ldflags '$(LDFLAGS)' \
++ $(MKLIB) -o $(XA_LIB) -linker '$(LD)' -ldflags '$(LDFLAGS)' \
+ -major $(XA_MAJOR) -minor $(XA_MINOR) -patch $(XA_TINY) \
+ $(MKLIB_OPTIONS) \
+ -exports xa_symbols \
diff --git a/main/mesa/mesa-8.0.3-llvm-3.1-fixes.patch b/main/mesa/mesa-8.0.3-llvm-3.1-fixes.patch
new file mode 100644
index 000000000..a567b5926
--- /dev/null
+++ b/main/mesa/mesa-8.0.3-llvm-3.1-fixes.patch
@@ -0,0 +1,46 @@
+diff --git a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
+index a50a51d..f1bb4d9 100644
+--- a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
++++ b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
+@@ -235,7 +235,24 @@ lp_disassemble(const void* func)
+ int AsmPrinterVariant = AsmInfo->getAssemblerDialect();
+ #endif
+
+-#if HAVE_LLVM >= 0x0300
++#if HAVE_LLVM >= 0x0301
++ OwningPtr<const MCRegisterInfo> MRI(T->createMCRegInfo(Triple));
++ if (!MRI) {
++ debug_printf("error: no register info for target %s\n", Triple.c_str());
++ return;
++ }
++
++ OwningPtr<const MCInstrInfo> MII(T->createMCInstrInfo());
++ if (!MII) {
++ debug_printf("error: no instruction info for target %s\n", Triple.c_str());
++ return;
++ }
++#endif
++
++#if HAVE_LLVM >= 0x0301
++ OwningPtr<MCInstPrinter> Printer(
++ T->createMCInstPrinter(AsmPrinterVariant, *AsmInfo, *MII, *MRI, *STI));
++#elif HAVE_LLVM == 0x0300
+ OwningPtr<MCInstPrinter> Printer(
+ T->createMCInstPrinter(AsmPrinterVariant, *AsmInfo, *STI));
+ #elif HAVE_LLVM >= 0x0208
+diff --git a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
+index fe7616b..68f8808 100644
+--- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
++++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
+@@ -62,7 +62,11 @@
+ extern "C" void
+ lp_register_oprofile_jit_event_listener(LLVMExecutionEngineRef EE)
+ {
++#if HAVE_LLVM >= 0x0301
++ llvm::unwrap(EE)->RegisterJITEventListener(llvm::JITEventListener::createOProfileJITEventListener());
++#else
+ llvm::unwrap(EE)->RegisterJITEventListener(llvm::createOProfileJITEventListener());
++#endif
+ }
+
+
diff --git a/main/mesa/parallel.patch b/main/mesa/parallel.patch
new file mode 100644
index 000000000..44bd7b11f
--- /dev/null
+++ b/main/mesa/parallel.patch
@@ -0,0 +1,14 @@
+--- src/mesa/Makefile.orig
++++ ./src/mesa/Makefile
+@@ -65,7 +65,10 @@
+
+ # Default: build dependencies, then asm_subdirs, GLSL built-in lib,
+ # then convenience libs (.a) and finally the device drivers:
+-default: $(DEPENDS) asm_subdirs $(MESA_LIBS) $(DRICORE_LIBS) driver_subdirs
++default: $(DEPENDS)
++ @for i in asm_subdirs $(MESA_LIBS) $(DRICORE_LIBS) driver_subdirs; do \
++ $(MAKE) $$i || exit 1; \
++ done
+
+ # include glapi_gen.mk for generating glapi headers for GLES
+ GLAPI := $(TOP)/src/mapi/glapi/gen