summaryrefslogtreecommitdiffstats
path: root/main/mesa
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-09 08:02:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-09 08:04:01 +0000
commit411733df8c36bf901753464b8e2ae4466af1be50 (patch)
tree3f1e184bea40a3daf1dc7d4e73aa410ba7d51c18 /main/mesa
parent6169e8833bdbc37c46c823c189d90050928d81be (diff)
downloadaports-411733df8c36bf901753464b8e2ae4466af1be50.tar.bz2
aports-411733df8c36bf901753464b8e2ae4466af1be50.tar.xz
main/mesa: only build intel dri driver on x86*
Diffstat (limited to 'main/mesa')
-rw-r--r--main/mesa/APKBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 7a9ce107d..a6e7935cb 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -7,9 +7,8 @@ url="http://www.mesa3d.org"
arch="all"
license="LGPL"
depends=
-subpackages="$pkgname-dev
+subpackages="$pkgname-dev
$pkgname-dri-ati:ati
- $pkgname-dri-intel:intel
$pkgname-dri-nouveau:nouveau
$pkgname-dri-swrast:swrast
$pkgname-dri-vmwgfx:vmwgfx
@@ -28,22 +27,20 @@ source="ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2
"
_dri_driverdir=/usr/lib/xorg/modules/dri
+_dri_drivers="r200,radeon,nouveau,swrast"
_builddir="$srcdir/Mesa-$pkgver"
-case "$CHOST" in
-x86_64-*)
- _intel_dri="i915_dri i965_dri"
- ;;
-i[3456789]86-*)
- _intel_dri="i915_dri i965_dri"
+_intel_dri=
+case "$CARCH" in
+x86*)
+ _dri_drivers="${_dri_drivers},i915,i965"
+ subpackages="$subpackages $pkgname-dri-intel:intel"
;;
esac
-prepare() {
+prepare() {
cd "$_builddir"
- autoreconf -vfi || return 1
- #update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -58,7 +55,7 @@ prepare() {
build() {
cd "$_builddir"
- [ "$CLIBC" == musl ] && export CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700"
+ [ "$CLIBC" = "musl" ] && export CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure \
@@ -71,7 +68,7 @@ build() {
--enable-pic \
--enable-glx-rts \
--with-gallium-drivers=r300,r600,nouveau,svga,swrast \
- --with-dri-drivers=i915,i965,r200,radeon,nouveau,swrast \
+ --with-dri-drivers=${_dri_drivers} \
--enable-gallium-llvm \
--enable-gallium-egl \
--with-egl-platforms=x11,drm \
@@ -90,7 +87,7 @@ build() {
|| return 1
make || return 1
-
+
# check so we dont have any bind NOW
scanelf -Rb . | grep NOW && return 1
return 0