summaryrefslogtreecommitdiffstats
path: root/main/mesa
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 14:28:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 18:54:03 +0000
commit4911943cce67c63321cc08411e04d049c8033659 (patch)
tree38a3979d7c611fd17bb40323af7968ec188ce332 /main/mesa
parent0a31cde9be610db83a7e7c139879038f244cd2d3 (diff)
downloadaports-4911943cce67c63321cc08411e04d049c8033659.tar.bz2
aports-4911943cce67c63321cc08411e04d049c8033659.tar.xz
main/mesa: upgrade to 7.11
Diffstat (limited to 'main/mesa')
-rw-r--r--main/mesa/APKBUILD59
-rw-r--r--main/mesa/Mesa-7.10.1-nouveau-compile.patch139
2 files changed, 39 insertions, 159 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 40cbe65f7..8bb47f286 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
-pkgver=7.10.3
+pkgver=7.11
pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
url="http://www.mesa3d.org"
@@ -18,21 +18,21 @@ subpackages="$pkgname-dev
$pkgname-dri-tdfx:tdfx
$pkgname-dri-unichrome:unichrome
$pkgname-dri-nouveau:nouveau
- $pkgname-egl
+ $pkgname-dri-vmwgfx:vmwgfx
+ $pkgname-egl $pkgname-glu $pkgname-gl $pkgname-gles
"
-makedepends="pkgconfig libdrm-dev libxxf86vm-dev libxdamage-dev expat-dev
- dri2proto xextproto libx11-dev glproto python libxt-dev makedepend
- talloc-dev py-libxml2 flex bison"
+depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
+ libxdamage-dev libxfixes-dev libxcb-dev glproto"
+makedepends="$depends_dev expat-dev xextproto python libxt-dev makedepend
+ talloc-dev py-libxml2 flex bison llvm-dev"
source="ftp://ftp.freedesktop.org/pub/mesa/$pkgver/MesaLib-$pkgver.tar.bz2
mesa-7.10-uclibc.patch
mesa-7.10-uclibc-glsl.patch
mesa-7.10-uclibc-gallium.patch
- Mesa-7.10.1-nouveau-compile.patch
"
+# Mesa-7.10.1-nouveau-compile.patch
-depends_dev="libdrm-dev dri2proto libx11-dev libxext-dev libxxf86vm-dev
- libxdamage-dev libxfixes-dev libxcb-dev glproto"
_dri_driverdir=/usr/lib/xorg/modules/dri
@@ -58,7 +58,7 @@ prepare() {
dev() {
default_dev;
- depends="$depends_dev mesa mesa-egl"
+ depends="$depends_dev mesa mesa-egl mesa-gl mesa-glu mesa-gles"
}
build() {
@@ -69,12 +69,10 @@ build() {
--disable-asm \
--disable-glx-tls \
--with-driver=dri \
- --with-state-trackers=dri,glx,egl \
--enable-xcb \
--enable-egl \
--enable-gles2 \
- --enable-gallium-nouveau \
- --enable-gallium-swrast \
+ --with-gallium-drivers=i915,i965,nouveau,r300,r600,svga,swrast \
--disable-gallium-egl \
--disable-glut \
--disable-glw || return 1
@@ -93,11 +91,32 @@ package() {
egl() {
replaces="mesa"
- pkgdesc="Mesa OpenGLES support library and modules"
-
+ pkgdesc="Mesa libEGL runtime libraries"
install -d "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libEGL.so* "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/egl "$subpkgdir"/usr/lib/egl
+}
+
+gl() {
+ replaces="mesa"
+ pkgdesc="Mesa libGL runtime libraries"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libGL.so* "$subpkgdir"/usr/lib/
+}
+
+glu() {
+ replaces="mesa"
+ pkgdesc="Mesa libGLU runtime libraries"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libGLU.so* "$subpkgdir"/usr/lib/
+}
+
+gles() {
+ replaces="mesa"
+ pkgdesc="Mesa libGLESv2 runtime libraries"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libGLESv2.so* \
+ "$pkgdir"/usr/lib/libglapi.so.* \
+ "$subpkgdir"/usr/lib/
}
_mv_dri() {
@@ -120,11 +139,11 @@ savage() { _mv_dri savage_dri; }
sis() { _mv_dri sis_dri; }
tdfx() { _mv_dri tdfx_dri; }
unichrome() { _mv_dri unichrome_dri; }
-nouveau() { _mv_dri nouveau_dri; }
-swrast() { _mv_dri swrast_dri; }
+nouveau() { _mv_dri nouveau_dri nouveau_vieux_dri; }
+swrast() { _mv_dri swrast_dri swrastg_dri; }
+vmwgfx() { _mv_dri vmwgfx_dri; }
-md5sums="8c38fe8266be8e1ed1d84076ba5a703b MesaLib-7.10.3.tar.bz2
+md5sums="ff03aca82d0560009a076a87c888cf13 MesaLib-7.11.tar.bz2
9c8c161f954f0d08895cd9d45e63f498 mesa-7.10-uclibc.patch
03e9685b0d714e915c35fd0fb5fde810 mesa-7.10-uclibc-glsl.patch
-90a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch
-34e3d4bb5f16bae55929958083087c0a Mesa-7.10.1-nouveau-compile.patch"
+90a2ea438ff328443a0436a91a74d518 mesa-7.10-uclibc-gallium.patch"
diff --git a/main/mesa/Mesa-7.10.1-nouveau-compile.patch b/main/mesa/Mesa-7.10.1-nouveau-compile.patch
deleted file mode 100644
index 96dafceb0..000000000
--- a/main/mesa/Mesa-7.10.1-nouveau-compile.patch
+++ /dev/null
@@ -1,139 +0,0 @@
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c.ark 2011-04-11 10:26:00.717291484 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_clear.c 2011-04-11 10:26:05.600624698 +0200
-@@ -24,6 +24,8 @@
- #include "pipe/p_defines.h"
- #include "pipe/p_state.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
-
- void
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c.ark 2011-04-11 10:25:55.913958268 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_context.c 2011-04-11 10:26:00.663958154 +0200
-@@ -23,6 +23,8 @@
- #include "draw/draw_context.h"
- #include "pipe/p_defines.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
- #include "nv50_screen.h"
- #include "nv50_resource.h"
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c.ark 2011-04-11 10:25:50.250625073 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_push.c 2011-04-11 10:25:55.873958269 +0200
-@@ -4,6 +4,8 @@
- #include "util/u_format.h"
- #include "util/u_split_prim.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
- #include "nv50_resource.h"
-
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c.ark 2011-04-11 10:25:44.790625206 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_query.c 2011-04-11 10:25:50.183958407 +0200
-@@ -23,6 +23,8 @@
- #include "pipe/p_context.h"
- #include "util/u_inlines.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
-
- struct nv50_query {
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c.ark 2011-04-11 10:25:32.790625497 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_screen.c 2011-04-11 10:25:38.633958688 +0200
-@@ -23,6 +23,8 @@
- #include "util/u_format_s3tc.h"
- #include "pipe/p_screen.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
- #include "nv50_screen.h"
- #include "nv50_resource.h"
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c.ark 2011-04-11 10:25:38.710625354 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_shader_state.c 2011-04-11 10:25:44.713958540 +0200
-@@ -26,6 +26,8 @@
- #include "pipe/p_state.h"
- #include "util/u_inlines.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
-
- static void
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c.ark 2011-04-11 10:25:27.520625626 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_state_validate.c 2011-04-11 10:25:32.737292166 +0200
-@@ -22,6 +22,7 @@
-
- #include "util/u_format.h"
-
-+#include <nouveau/nv04_pushbuf.h>
- #include "nv50_context.h"
- #include "nv50_resource.h"
- #include "nouveau/nouveau_stateobj.h"
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c.ark 2011-04-11 10:25:22.407292417 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_surface.c 2011-04-11 10:25:27.450625628 +0200
-@@ -22,6 +22,7 @@
-
- #define __NOUVEAU_PUSH_H__
- #include <stdint.h>
-+#include <nouveau/nv04_pushbuf.h>
- #include "nouveau/nouveau_pushbuf.h"
- #include "nv50_context.h"
- #include "nv50_resource.h"
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c.ark 2011-04-11 10:25:14.903959267 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_transfer.c 2011-04-11 10:25:22.353959086 +0200
-@@ -4,6 +4,8 @@
- #include "util/u_format.h"
- #include "util/u_math.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
- #include "nv50_transfer.h"
- #include "nv50_resource.h"
---- Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c.ark 2011-04-11 10:25:01.717292921 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nv50/nv50_vbo.c 2011-04-11 10:25:14.850625935 +0200
-@@ -26,6 +26,8 @@
- #include "util/u_format.h"
- #include "util/u_split_prim.h"
-
-+#include <nouveau/nv04_pushbuf.h>
-+
- #include "nv50_context.h"
- #include "nv50_resource.h"
-
---- Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c.ark 2011-04-11 10:23:22.800628664 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nvfx/nv04_2d.c 2011-04-11 10:25:01.640626257 +0200
-@@ -39,6 +39,7 @@
- #include <nouveau/nouveau_bo.h>
- #include <nouveau/nouveau_notifier.h>
- #include <nouveau/nouveau_grobj.h>
-+#include <nouveau/nv04_pushbuf.h>
- #include "nv04_2d.h"
-
- #include "nouveau/nv_object.xml.h"
---- Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c.ark 2011-04-11 10:27:59.380621927 +0200
-+++ Mesa-7.10.1/src/gallium/drivers/nvfx/nvfx_screen.c 2011-04-11 10:28:02.833955176 +0200
-@@ -3,6 +3,7 @@
- #include "util/u_format_s3tc.h"
- #include "util/u_simple_screen.h"
-
-+#include <nouveau/nv04_pushbuf.h>
- #include "nouveau/nouveau_screen.h"
- #include "nouveau/nv_object.xml.h"
- #include "nvfx_context.h"
---- Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c.ark 2011-04-11 10:27:27.220622711 +0200
-+++ Mesa-7.10.1/src/mesa/drivers/dri/nouveau/nv04_context.c 2011-04-11 11:09:24.147228063 +0200
-@@ -24,6 +24,8 @@
- *
- */
-
-+#include <stdint.h>
-+#include <nouveau/nv04_pushbuf.h>
- #include "nouveau_driver.h"
- #include "nouveau_context.h"
- #include "nouveau_fbo.h"