summaryrefslogtreecommitdiffstats
path: root/main/mysql
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-23 14:35:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-23 14:35:07 +0000
commit25c6bc33691a2229fdd28d5f472f138b30fa518e (patch)
tree9828d09a223bab57ac0651e5dbe5b4fbc36ad9da /main/mysql
parent317172e20de38088b05457b79daf9cef5d729a12 (diff)
downloadaports-25c6bc33691a2229fdd28d5f472f138b30fa518e.tar.bz2
aports-25c6bc33691a2229fdd28d5f472f138b30fa518e.tar.xz
main/mysql: fix circular dep
and clean up subpackages
Diffstat (limited to 'main/mysql')
-rw-r--r--main/mysql/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/main/mysql/APKBUILD b/main/mysql/APKBUILD
index 8a86d5e5b..e435a75ea 100644
--- a/main/mysql/APKBUILD
+++ b/main/mysql/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mysql
pkgver=5.5.14
-pkgrel=0
+pkgrel=1
pkgdesc="A fast SQL database server"
url="http://www.mysql.com/"
pkgusers="mysql"
@@ -122,6 +122,7 @@ libs() {
common() {
pkgdesc="MySQL common files for both server and client"
replaces="mysql"
+ depends=
mkdir -p "$subpkgdir"/usr/share/mysql \
mv "$pkgdir"/etc "$subpkgdir"/ || return 1
mv "$pkgdir"/usr/share/mysql/english \
@@ -154,13 +155,13 @@ common() {
mytest() {
pkgdesc="The test suite distributed with MySQL"
- mkdir -p "$subpkgdir"/usr || return 1
+ mkdir -p "$subpkgdir"/usr/bin || return 1
mv "$pkgdir"/usr/share/mysql-test \
"$subpkgdir"/usr/share/ \
|| return 1
mv "$pkgdir"/usr/bin/mysql_client_test \
"$pkgdir"/usr/bin/my_safe_process \
- "$pkgdir"/usr/bin/ \
+ "$subpkgdir"/usr/bin/ \
|| return 1
}
@@ -169,7 +170,7 @@ client() {
depends="mysql-common"
install=""
local bins="myisam_ftdump mysql mysqlaccess mysqladmin mysqlbug
- mysqlcheck mysql_client_test mysqldump mysqldumpslow mysql_find_rows
+ mysqlcheck mysqldump mysqldumpslow mysql_find_rows
mysql_fix_extensions mysqlimport mysqlshow mysql_waitpid"
mkdir -p "$subpkgdir"/usr/bin/ || return 1