summaryrefslogtreecommitdiffstats
path: root/main/nfdump
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2012-03-26 02:03:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-07 15:01:57 +0000
commit7f6a9e1d07f276cd24ea670032c1dd351b91750c (patch)
treef8a8c97db7968e83910caf5d6b3b1c5d59339c82 /main/nfdump
parent701cd736975f731688fbc971befcc7b1818fd1a0 (diff)
downloadaports-7f6a9e1d07f276cd24ea670032c1dd351b91750c.tar.bz2
aports-7f6a9e1d07f276cd24ea670032c1dd351b91750c.tar.xz
nfdump: Changed default port for nfcapd to match fprobe; revised init script to pass parameters to rotate command
Diffstat (limited to 'main/nfdump')
-rw-r--r--main/nfdump/APKBUILD2
-rw-r--r--main/nfdump/nfcapd.confd2
-rw-r--r--main/nfdump/nfcapd.initd16
3 files changed, 13 insertions, 7 deletions
diff --git a/main/nfdump/APKBUILD b/main/nfdump/APKBUILD
index 55083c8fc..48b40ffaa 100644
--- a/main/nfdump/APKBUILD
+++ b/main/nfdump/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nfdump
pkgver=1.6.4
-pkgrel=2
+pkgrel=3
pkgdesc="The nfdump tools collect and process netflow data on the command line."
url="http://nfdump.sourceforge.net/"
arch="all"
diff --git a/main/nfdump/nfcapd.confd b/main/nfdump/nfcapd.confd
index fb9afb6e3..be6155e44 100644
--- a/main/nfdump/nfcapd.confd
+++ b/main/nfdump/nfcapd.confd
@@ -1,7 +1,7 @@
# Config file for /etc/init.d/nfcapd
# Port we listen on
-PORT=2205
+PORT=2055
# Hostname/address we bind on - default is any available
BINDHOST=127.0.0.1
diff --git a/main/nfdump/nfcapd.initd b/main/nfdump/nfcapd.initd
index 5f8506812..028cf55ee 100644
--- a/main/nfdump/nfcapd.initd
+++ b/main/nfdump/nfcapd.initd
@@ -28,13 +28,12 @@ start() {
[ "${COMPRESS}" == "yes" ] && OPTS="${OPTS} -z"
for optname in p:PORT b:BINDHOST j:MULTICASTGROUP i:IFACE R:REPEAT \
I:IDENT l:BASEDIR n:SOURCE s:SAMPLERATE S:SUBDIR \
- T:EXTENSIONS t:INTERVAL x:ROTATECMD u:UID g:GID \
+ T:EXTENSIONS t:INTERVAL u:UID g:GID \
B:BUFFLEN ; do
opt="${optname/:*}" optvar="${optname/*:}"
eval optvalue="\$$optvar"
[ -n "$optvalue" ] && OPTS="${OPTS} -${opt} ${optvalue}"
done
- OPTS="${OPTS}"
# Attempt to make the basedir if specified
if [ -n "${BASEDIR}" ]; then
@@ -42,10 +41,17 @@ start() {
chown "${UID}":"${GID}" "${BASEDIR}"
fi
+ # Handle remote command as a special case
+ if [ -n "${ROTATECMD}" ]; then
+ start-stop-daemon --start -b --exec $BIN \
+ --pidfile ${PIDFILE} --make-pidfile \
+ -- ${OPTS} -x "${ROTATECMD}"
+ else
+ start-stop-daemon --start -b --exec $BIN \
+ --pidfile ${PIDFILE} --make-pidfile \
+ -- ${OPTS}
+ fi
- start-stop-daemon --start -b --exec $BIN \
- --pidfile ${PIDFILE} --make-pidfile \
- -- ${OPTS}
eend $?
}