summaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-17 13:11:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-17 13:11:29 +0000
commit98f1cffd2e8b1a8ff81ba3da9a229e03705bd2c7 (patch)
treed6daf3a83dddce9d40b74ab78ed1a33e98e20d5c /main/nginx
parent8aa0f149ba7868eaec539db641da554fe1ca4a71 (diff)
downloadaports-98f1cffd2e8b1a8ff81ba3da9a229e03705bd2c7.tar.bz2
aports-98f1cffd2e8b1a8ff81ba3da9a229e03705bd2c7.tar.xz
main/nginx: fix musl build
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD27
-rw-r--r--main/nginx/musl-crypt-fix.patch13
2 files changed, 31 insertions, 9 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 92778f0de..58c9f1373 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -4,7 +4,7 @@
pkgname=nginx
pkgver=1.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="lightweight HTTP and reverse proxy server"
url="http://www.nginx.org"
arch="all"
@@ -12,16 +12,22 @@ license="Custom"
install="$pkgname.pre-install $pkgname.pre-upgrade"
makedepends="pcre-dev openssl-dev zlib-dev"
source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
+ musl-crypt-fix.patch
+ ipv6.patch
+
nginx.initd
nginx.logrotate
- ipv6.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- patch -Np1 -i "$srcdir"/ipv6.patch
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
@@ -61,14 +67,17 @@ package() {
}
md5sums="5dfaba1cbeae9087f3949860a02caa9f nginx-1.4.4.tar.gz
+3aeb488921109e60d02ed64d36790aeb musl-crypt-fix.patch
+801a87f7f9d27f8ad85b41a78b4c4461 ipv6.patch
4faf8dff6ff1490edae1688baf1b2abb nginx.initd
-8823274a834332d3db4f62bf7dd1fb7d nginx.logrotate
-801a87f7f9d27f8ad85b41a78b4c4461 ipv6.patch"
+8823274a834332d3db4f62bf7dd1fb7d nginx.logrotate"
sha256sums="7c989a58e5408c9593da0bebcd0e4ffc3d892d1316ba5042ddb0be5b0b4102b9 nginx-1.4.4.tar.gz
+8c398640bd379c1c6a2fafcd2b3848a72902e47924e8e2490b312c141eec5d70 musl-crypt-fix.patch
+a24ef5843ae0afa538b00c37eb7da7870f9d7f146f52a9668678f7296cf71d9b ipv6.patch
34e9b1dbb9f5fe4d71f7469ded3eb98fac02f57ecfbfd04ba623099766b4709c nginx.initd
-cea0c6f8de55a4c3a3eccc57910de1c3116634082c8e5b660630fb927a29f38d nginx.logrotate
-a24ef5843ae0afa538b00c37eb7da7870f9d7f146f52a9668678f7296cf71d9b ipv6.patch"
+cea0c6f8de55a4c3a3eccc57910de1c3116634082c8e5b660630fb927a29f38d nginx.logrotate"
sha512sums="6007d3a6eea17a49dd3b39f2520a4f00e8dee3feaa86c582d8f0ef81dd4c1e2992cbea3b5be10cdd0ff85a8b24381aa6114ebdbf77d29c91d946639752b5c867 nginx-1.4.4.tar.gz
+21114c775e4bdd1f7b8b9abc143284945e96ed1d8c49904ddf918abad87b16253f918ba47976cd2df32f0fdb8a7dad399d4200e879db2da6cf93a28aab236a75 musl-crypt-fix.patch
+68d64a84568ec2df0366925ab282a05ebe21a85044b6c7844a47573cfd8cc8ed119cc772358bc3fff36e2d4fdf583a730592825f5f98632993ca86d1f8438d5f ipv6.patch
e153ff131ca5a62f01744c45e97421db0776be518a84a8d09896955a996e5a0133c03cdfa7ac6b03bad75b5cbb839f49dcccbb210843010da42445706f239a12 nginx.initd
-01b77cff16f6e8bfd7fa1d4d20f625bbcddd08f0509173452d060c342c93dc315a7b0560f4734323a5d29ea294de0491f2e3f32e5337574e1a28ebc005eceea8 nginx.logrotate
-68d64a84568ec2df0366925ab282a05ebe21a85044b6c7844a47573cfd8cc8ed119cc772358bc3fff36e2d4fdf583a730592825f5f98632993ca86d1f8438d5f ipv6.patch"
+01b77cff16f6e8bfd7fa1d4d20f625bbcddd08f0509173452d060c342c93dc315a7b0560f4734323a5d29ea294de0491f2e3f32e5337574e1a28ebc005eceea8 nginx.logrotate"
diff --git a/main/nginx/musl-crypt-fix.patch b/main/nginx/musl-crypt-fix.patch
new file mode 100644
index 000000000..2f11fe2e9
--- /dev/null
+++ b/main/nginx/musl-crypt-fix.patch
@@ -0,0 +1,13 @@
+--- nginx-1.4.4/src/os/unix/ngx_user.c.orig
++++ nginx-1.4.4/src/os/unix/ngx_user.c
+@@ -31,8 +31,10 @@
+ struct crypt_data cd;
+
+ cd.initialized = 0;
++#ifdef __GLIBC__
+ /* work around the glibc bug */
+ cd.current_salt[0] = ~salt[0];
++#endif
+
+ value = crypt_r((char *) key, (char *) salt, &cd);
+