summaryrefslogtreecommitdiffstats
path: root/main/nginx
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-24 16:04:03 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-24 16:04:03 -0500
commitef77ec299e797eef01a8b0f4ace1bf1ead464056 (patch)
tree318e740a9f8737c03f73faa8a94509723d4eda02 /main/nginx
parent7293ee055902cd79283a8a4743483eaa06dd3d3b (diff)
downloadaports-ef77ec299e797eef01a8b0f4ace1bf1ead464056.tar.bz2
aports-ef77ec299e797eef01a8b0f4ace1bf1ead464056.tar.xz
main/nginx: move from testing (ok'd by cbanta)
Diffstat (limited to 'main/nginx')
-rw-r--r--main/nginx/APKBUILD58
-rw-r--r--main/nginx/nginx.initd72
-rw-r--r--main/nginx/nginx.logrotate12
3 files changed, 142 insertions, 0 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
new file mode 100644
index 000000000..ca5ac9827
--- /dev/null
+++ b/main/nginx/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Cameron Banta <cbanta@gmail.com>
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+pkgname=nginx
+pkgver=0.8.54
+pkgrel=0
+pkgdesc="nginx [engine x] is a HTTP and reverse proxy server"
+url="http://www.nginx.org"
+arch="all"
+license="Custom"
+depends=
+makedepends="pcre-dev openssl-dev zlib-dev"
+#install="$pkgname.pre-install $pkgname.post-install"
+install=
+subpackages=
+source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
+ nginx.initd
+ nginx.logrotate
+ $install
+ "
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --conf-path=/etc/$pkgname/$pkgname.conf \
+ --pid-path=/var/run/$pkgname.pid \
+ --lock-path=/var/run/$pkgname.lock \
+ --error-log-path=/var/log/$pkgname/error.log \
+ --http-log-path=/var/log/$pkgname/access.log \
+ --with-http_ssl_module \
+ --with-http_gzip_static_module \
+ --http-client-body-temp-path=/tmp/$pkgname/client-body \
+ --http-proxy-temp-path=/tmp/$pkgname/proxy \
+ --http-fastcgi-temp-path=/tmp/$pkgname/fastcgi \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname
+
+ install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="44df4eb6a22d725021288c570789046f nginx-0.8.54.tar.gz
+b06f6e23753385be0076539ba1806cb6 nginx.initd
+8823274a834332d3db4f62bf7dd1fb7d nginx.logrotate"
diff --git a/main/nginx/nginx.initd b/main/nginx/nginx.initd
new file mode 100644
index 000000000..e175bb413
--- /dev/null
+++ b/main/nginx/nginx.initd
@@ -0,0 +1,72 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/files/nginx.init-r2,v 1.1 2010/01/03 19:51:41 djc Exp $
+
+opts="${opts} upgrade reload configtest"
+
+depend() {
+ need net
+ use dns logger netmount
+}
+
+start() {
+ configtest || return 1
+ ebegin "Starting nginx"
+ start-stop-daemon --start --pidfile /var/run/nginx.pid \
+ --exec /usr/sbin/nginx -- -c /etc/nginx/nginx.conf
+ eend $? "Failed to start nginx"
+}
+
+stop() {
+ configtest || return 1
+ ebegin "Stopping nginx"
+ start-stop-daemon --stop --pidfile /var/run/nginx.pid
+ eend $? "Failed to stop nginx"
+ rm -f /var/run/nginx.pid
+}
+
+reload() {
+ configtest || return 1
+ ebegin "Refreshing nginx' configuration"
+ kill -HUP `cat /var/run/nginx.pid` &>/dev/null
+ eend $? "Failed to reload nginx"
+}
+
+upgrade() {
+ configtest || return 1
+ ebegin "Upgrading nginx"
+
+ einfo "Sending USR2 to old binary"
+ kill -USR2 `cat /var/run/nginx.pid` &>/dev/null
+
+ einfo "Sleeping 3 seconds before pid-files checking"
+ sleep 3
+
+ if [ ! -f /var/run/nginx.pid.oldbin ]; then
+ eerror "File with old pid not found"
+ return 1
+ fi
+
+ if [ ! -f /var/run/nginx.pid ]; then
+ eerror "New binary failed to start"
+ return 1
+ fi
+
+ einfo "Sleeping 3 seconds before WINCH"
+ sleep 3 ; kill -WINCH `cat /var/run/nginx.pid.oldbin`
+
+ einfo "Sending QUIT to old binary"
+ kill -QUIT `cat /var/run/nginx.pid.oldbin`
+
+ einfo "Upgrade completed"
+
+ eend $? "Upgrade failed"
+}
+
+configtest() {
+ ebegin "Checking nginx' configuration"
+ mkdir -p /tmp/nginx
+ /usr/sbin/nginx -c /etc/nginx/nginx.conf -t
+ eend $? "failed, please correct errors above"
+}
diff --git a/main/nginx/nginx.logrotate b/main/nginx/nginx.logrotate
new file mode 100644
index 000000000..7778b1108
--- /dev/null
+++ b/main/nginx/nginx.logrotate
@@ -0,0 +1,12 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/files/nginx.logrotate,v 1.1 2010/01/03 20:29:40 djc Exp $
+
+/var/log/nginx/*.log {
+ missingok
+ sharedscripts
+ postrotate
+ kill -USR1 `cat /var/run/nginx.pid`
+ endscript
+}
+