summaryrefslogtreecommitdiffstats
path: root/main/nss
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-23 00:03:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-23 16:25:16 +0000
commit303ae40e14e09b8f131910d7b323a01877639244 (patch)
treeeb3533ea4fcc1f04e33d6cd64407c41216befcfb /main/nss
parentcd88b9f23246ecc860c9d841ff12b63f1b9c6c82 (diff)
downloadaports-303ae40e14e09b8f131910d7b323a01877639244.tar.bz2
aports-303ae40e14e09b8f131910d7b323a01877639244.tar.xz
main/nss: re-organize the package
libnss was a bad name since it contained various libs. We put the libs in the mai, 'nss', package and the tools in a nss-tools package. This is how fedora does. We also make sure that the .so symlinks are in nss package instead of -dev package due to the way soname is.
Diffstat (limited to 'main/nss')
-rw-r--r--main/nss/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/main/nss/APKBUILD b/main/nss/APKBUILD
index 1a60926d8..b037952f9 100644
--- a/main/nss/APKBUILD
+++ b/main/nss/APKBUILD
@@ -1,15 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nss
pkgver=3.12.8
-_ver=3_12_8
-pkgrel=4
+_ver=${pkgver/./_}
+pkgrel=5
pkgdesc="Mozilla Network Security Services"
url="http://www.mozilla.org/projects/security/pki/nss/"
arch="all"
license="MPL GPL"
depends=
makedepends="nspr-dev sqlite-dev zlib-dev perl"
-subpackages="$pkgname-dev libnss"
+subpackages="$pkgname-dev $pkgname-tools"
source="ftp://ftp.mozilla.org/pub/security/$pkgname/releases/NSS_${_ver}_RTM/src/$pkgname-$pkgver.tar.gz
nss-no-rpath.patch
nss.pc.in
@@ -51,7 +51,7 @@ build() {
}
package() {
- replaces="nss-dev"
+ replaces="nss-dev libnss"
cd "$_builddir"
@@ -118,7 +118,7 @@ dev() {
mv "$pkgdir"/usr/bin/nss-config "$subpkgdir"/usr/bin
cd "$pkgdir" || return 0
- for i in usr/include usr/lib/pkgconfig; do
+ for i in usr/include usr/lib/pkgconfig usr/lib/*.a; do
if [ -e "$pkgdir/$i" ] || [ -L "$pkgdir/$i" ]; then
d="$subpkgdir/${i%/*}" # dirname $i
mkdir -p "$d"
@@ -130,10 +130,11 @@ dev() {
return 0
}
-libnss() {
- pkgdesc="Mozilla Network Security Service libraries"
+tools() {
+ pkgdesc="Tools for the Network Security Services"
+ replaces="nss"
mkdir -p "$subpkgdir"/usr/
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
md5sums="40bf1bb0c7567827d3768d1fc6081100 nss-3.12.8.tar.gz