summaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-05 12:37:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-05 12:37:57 +0000
commit2cdac16a897049564f79ef72e48c6b98ea68d390 (patch)
tree2fcfe5045b01ad222a7c2b8ac253635a17c2d9ef /main/open-vm-tools-grsec
parent0f6a63bf9ee4f1d6031f7ef6f4a428c1efc46682 (diff)
downloadaports-2cdac16a897049564f79ef72e48c6b98ea68d390.tar.bz2
aports-2cdac16a897049564f79ef72e48c6b98ea68d390.tar.xz
main/open-vm-tools-grsec: fix for 3.10 kernel
Diffstat (limited to 'main/open-vm-tools-grsec')
-rw-r--r--main/open-vm-tools-grsec/APKBUILD6
-rw-r--r--main/open-vm-tools-grsec/linux-3.10.patch16
2 files changed, 21 insertions, 1 deletions
diff --git a/main/open-vm-tools-grsec/APKBUILD b/main/open-vm-tools-grsec/APKBUILD
index 765299532..e2b82bdc2 100644
--- a/main/open-vm-tools-grsec/APKBUILD
+++ b/main/open-vm-tools-grsec/APKBUILD
@@ -33,7 +33,7 @@ pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="http://open-vm-tools.sourceforge.net/"
-arch=
+arch="all"
license="LGPL"
subpackages=""
depends="linux-${_flavor}=${_kernelver}"
@@ -41,6 +41,7 @@ depends_dev="bash glib-dev gettext-dev linux-${_flavor}-dev=${_kernelver}"
makedepends="$depends_dev"
source="http://downloads.sourceforge.net/project/open-vm-tools/open-vm-tools/stable-${_realver%.*}.x/open-vm-tools-${_ver}.tar.gz
vmci_driver_c.patch
+ linux-3.10.patch
vmware-modules.initd
"
# constify.patch
@@ -87,10 +88,13 @@ package() {
md5sums="71a1d8065b632692af2cdcc9d82f305e open-vm-tools-9.2.3-1031360.tar.gz
16e060275e028d1edf1c5fd1a10b6a96 vmci_driver_c.patch
+cc82715976e9af9fb8f44465af2ca5aa linux-3.10.patch
afba2c3487d0b12cee80eb2f04b05ba1 vmware-modules.initd"
sha256sums="1a004ea1675101fd44cddda299e2e9ac254388769b69f41b7ff5d1797549c8f1 open-vm-tools-9.2.3-1031360.tar.gz
0c7e24a78784e2e74421b119f996eb74fd346d5634e7f58172860e2c5f5d5bf4 vmci_driver_c.patch
+f3108ab321f9b32ecb59aa4760f9958f97335492345a04de79d95bd98a7af8ff linux-3.10.patch
6ceb5c75b002991c511d9dadb6cf91720771e76b701e5f2d91ac9ede4b168265 vmware-modules.initd"
sha512sums="bad1e94e2006e2b1b20fcb4bb1ec6969fd4ed62af477ffe5dfc2e38e81677e62140bd3c5da2acd31d3adf74fdead067831de86af52b8089c57d527c8f96aa3f8 open-vm-tools-9.2.3-1031360.tar.gz
a2fb52dd5bb323e7bba62ace64e655536c5d103f66bde17266762ecd6327de1ffc629acaa9e22814b23e09239cb7685c4bb0748362d6b2f0d6c34260cb09edc6 vmci_driver_c.patch
+0b36a6318ef419832817f22d50f85d8a5ae080e9496ecdf16753b17e8a693573e46eb896c3dc83a44fc596e6737130245663908befe8aa4a038e16b08cc499a3 linux-3.10.patch
639098221975cadaed0ae0f32454a6718ceaa5f43f17d949a84a85dee56fbf5f9e6248899c10a46b12c9c9cf28b837d83a37c25aba62b11cb7849a1cf8d32e1e vmware-modules.initd"
diff --git a/main/open-vm-tools-grsec/linux-3.10.patch b/main/open-vm-tools-grsec/linux-3.10.patch
new file mode 100644
index 000000000..d3ce6f2c4
--- /dev/null
+++ b/main/open-vm-tools-grsec/linux-3.10.patch
@@ -0,0 +1,16 @@
+From:
+http://sourceforge.net/p/open-vm-tools/tracker/173/
+
+--- ./modules/linux/vmhgfs/file.c.orig 2013-08-05 12:29:23.915888235 +0000
++++ ./modules/linux/vmhgfs/file.c 2013-08-05 12:35:46.056640104 +0000
+@@ -25,6 +25,10 @@
+ /* Must come before any kernel header file. */
+ #include "driver-config.h"
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 10, 0)
++#include <linux/aio.h>
++#endif
++
+ #include <linux/errno.h>
+ #include <linux/module.h>
+ #include <linux/signal.h>