summaryrefslogtreecommitdiffstats
path: root/main/oprofile
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2012-01-29 16:11:05 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2012-01-29 16:11:24 -0600
commit0316b315bc439648ab43ef31728518050f686d28 (patch)
treebccc01c4ba7213d0382f68876c5d45f538bdbb2d /main/oprofile
parentcadf6dd9afde61bb1b27a9cd835b7017e9940de7 (diff)
downloadaports-0316b315bc439648ab43ef31728518050f686d28.tar.bz2
aports-0316b315bc439648ab43ef31728518050f686d28.tar.xz
main/oprofile: remove obsolete pic patch
Diffstat (limited to 'main/oprofile')
-rw-r--r--main/oprofile/APKBUILD9
-rw-r--r--main/oprofile/oprofile-pic.patch49
2 files changed, 2 insertions, 56 deletions
diff --git a/main/oprofile/APKBUILD b/main/oprofile/APKBUILD
index 4b96d20c6..08865b783 100644
--- a/main/oprofile/APKBUILD
+++ b/main/oprofile/APKBUILD
@@ -12,16 +12,12 @@ makedepends="libiconv-dev popt-dev gettext-dev"
install=
subpackages="$pkgname-doc"
options="libtool"
-source="http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- oprofile-pic.patch"
+source="http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
- if [ "$CARCH" != "x86_64" ]; then
- patch -p1 -i "$srcdir"/oprofile-pic.patch
- fi
}
build() {
@@ -44,5 +40,4 @@ package() {
#install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/knockd
}
-md5sums="8b5d1d9b65f84420bcc3234777ad3be3 oprofile-0.9.7.tar.gz
-e7b80603bc86f120480c3d411d532ab8 oprofile-pic.patch"
+md5sums="8b5d1d9b65f84420bcc3234777ad3be3 oprofile-0.9.7.tar.gz"
diff --git a/main/oprofile/oprofile-pic.patch b/main/oprofile/oprofile-pic.patch
deleted file mode 100644
index 8867ff243..000000000
--- a/main/oprofile/oprofile-pic.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- oprofile-0.9.6/libop/op_hw_specific.h
-+++ oprofile-0.9.6.new/libop/op_hw_specific.h
-@@ -20,7 +20,8 @@
- char v[12];
- } v;
- unsigned eax;
-- asm("cpuid" : "=a" (eax), "=b" (v.b), "=c" (v.c), "=d" (v.d) : "0" (0));
-+ asm("push %%ebx ; cpuid ; movl %%ebx, %%esi ; pop %%ebx"
-+ : "=a" (eax), "=S" (v.b), "=c" (v.c), "=d" (v.d) : "0" (0));
- return !strncmp(v.v, vnd, 12);
- }
-
-@@ -46,7 +47,7 @@
-
- if (!cpuid_vendor("GenuineIntel"))
- return;
-- asm("cpuid" : "=a" (v.eax) : "0" (1) : "ecx","ebx","edx");
-+ asm("push %%ebx; cpuid; pop %%ebx" : "=a" (v.eax) : "0" (1) : "ecx","edx");
- model = (v.ext_model << 4) + v.model;
- if (v.family != 6 || model != 26 || v.stepping > 4)
- return;
-@@ -57,7 +58,8 @@
- {
- if (cpu_type == CPU_ARCH_PERFMON) {
- unsigned ebx, eax;
-- asm("cpuid" : "=a" (eax), "=b" (ebx) : "0" (0xa) : "ecx","edx");
-+ asm("push %%ebx; cpuid; movl %%ebx, %%edx; pop %%ebx"
-+ : "=a" (eax), "=d" (ebx) : "0" (0xa) : "ecx");
- workaround_nehalem_aaj79(&ebx);
- return ebx & num_to_mask(eax >> 24);
- }
-@@ -68,7 +70,7 @@
- {
- if (cpu_type == CPU_ARCH_PERFMON) {
- unsigned v;
-- asm("cpuid" : "=a" (v) : "0" (0xa) : "ebx","ecx","edx");
-+ asm("push %%ebx; cpuid; pop %%ebx" : "=a" (v) : "0" (0xa) : "ecx","edx");
- return (v >> 8) & 0xff;
- }
- return -1;
-@@ -77,7 +79,7 @@
- static inline unsigned arch_get_counter_mask(void)
- {
- unsigned v;
-- asm("cpuid" : "=a" (v) : "0" (0xa) : "ebx","ecx","edx");
-+ asm("push %%ebx; cpuid; pop %%ebx" : "=a" (v) : "0" (0xa) : "ecx","edx");
- return num_to_mask((v >> 8) & 0xff);
- }
-