summaryrefslogtreecommitdiffstats
path: root/main/osmo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-16 19:33:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-16 19:33:30 +0000
commit0fadea5692e3f71b9ee3081b0ea7a4d686a71328 (patch)
tree455c914591d0a84042b51a69d68d9f2d8d2021a5 /main/osmo
parent36a5815db17dcf75fa0af39ef4c7c3ccb9c3db36 (diff)
downloadaports-0fadea5692e3f71b9ee3081b0ea7a4d686a71328.tar.bz2
aports-0fadea5692e3f71b9ee3081b0ea7a4d686a71328.tar.xz
main/osmo: rebuild against libnotify-0.7
Diffstat (limited to 'main/osmo')
-rw-r--r--main/osmo/APKBUILD8
-rw-r--r--main/osmo/osmo-0.2.10-libnotify-0.7.patch48
2 files changed, 53 insertions, 3 deletions
diff --git a/main/osmo/APKBUILD b/main/osmo/APKBUILD
index 80a87434e..69654eba0 100644
--- a/main/osmo/APKBUILD
+++ b/main/osmo/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=osmo
pkgver=0.2.10
-pkgrel=2
+pkgrel=3
pkgdesc="A handy personal organizer"
url="http://clayo.org/osmo/"
arch="all"
license="GPL"
makedepends="gtk+-dev libnotify-dev libical-dev libxml2-dev autoconf automake"
install=
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/$pkgname-pim/$pkgname-$pkgver.tar.gz
osmo-0.2.10-build-mo.patch
+ osmo-0.2.10-libnotify-0.7.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -36,4 +37,5 @@ package() {
}
md5sums="a774db748228efee96186158d553ade9 osmo-0.2.10.tar.gz
-6c9939fd4df9d25e1a220585e6875c78 osmo-0.2.10-build-mo.patch"
+6c9939fd4df9d25e1a220585e6875c78 osmo-0.2.10-build-mo.patch
+92f7208e2e67482df61d20e6c04747dd osmo-0.2.10-libnotify-0.7.patch"
diff --git a/main/osmo/osmo-0.2.10-libnotify-0.7.patch b/main/osmo/osmo-0.2.10-libnotify-0.7.patch
new file mode 100644
index 000000000..72e9f1ab9
--- /dev/null
+++ b/main/osmo/osmo-0.2.10-libnotify-0.7.patch
@@ -0,0 +1,48 @@
+http://pkgs.fedoraproject.org/gitweb/?p=osmo.git;a=blob_plain;f=osmo-0.2.10-libnotify-0.7.0.patch;hb=HEAD
+
+--- ./src/check_events.c
++++ ./src/check_events.c
+@@ -454,9 +454,9 @@
+ a->date = 0;
+
+ if (textdesc != NULL)
+- a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING, NULL);
++ a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING);
+ else
+- a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING, NULL);
++ a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING);
+
+ g_free (textdesc);
+ g_free (text);
+@@ -483,9 +483,6 @@
+ #endif /* HAVE_LIBNOTIFY */
+
+ if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
+-#ifdef HAVE_LIBNOTIFY
+- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
+-#endif /* HAVE_LIBNOTIFY */
+ gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
+
+ if (config.blink_on_events) {
+@@ -532,9 +529,9 @@
+ a->time = -1;
+ a->date = 0;
+ if (textdesc != NULL)
+- a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO, NULL);
++ a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO);
+ else
+- a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO, NULL);
++ a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO);
+
+ notify_notification_set_timeout (a->notify, NOTIFY_EXPIRES_NEVER);
+ notify_notification_set_urgency (a->notify, NOTIFY_URGENCY_NORMAL);
+@@ -545,9 +542,6 @@
+ #endif /* HAVE_LIBNOTIFY */
+
+ if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
+-#ifdef HAVE_LIBNOTIFY
+- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
+-#endif /* HAVE_LIBNOTIFY */
+ gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
+
+ if (config.blink_on_events) {