summaryrefslogtreecommitdiffstats
path: root/main/osmo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-04 21:23:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-04 21:23:12 +0000
commitd50d33e52fad33834f91c76ec5409311266eb74b (patch)
tree7413d7a49fd4b6b599cd28b50fcbe8623f705fe7 /main/osmo
parent75eab2eb6e6285a00783d45546bb59b85a7bae42 (diff)
downloadaports-d50d33e52fad33834f91c76ec5409311266eb74b.tar.bz2
aports-d50d33e52fad33834f91c76ec5409311266eb74b.tar.xz
main/osmo: moved from testing
Diffstat (limited to 'main/osmo')
-rw-r--r--main/osmo/APKBUILD38
-rw-r--r--main/osmo/osmo-0.2.10-build-mo.patch20
2 files changed, 58 insertions, 0 deletions
diff --git a/main/osmo/APKBUILD b/main/osmo/APKBUILD
new file mode 100644
index 000000000..141309680
--- /dev/null
+++ b/main/osmo/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=osmo
+pkgver=0.2.10
+pkgrel=1
+pkgdesc="A handy personal organizer"
+url="http://clayo.org/osmo/"
+license="GPL"
+makedepends="gtk+-dev libnotify-dev libical-dev libxml2-dev autoconf automake"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname-pim/$pkgname-$pkgver.tar.gz
+ osmo-0.2.10-build-mo.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i##*/}"
+ patch -p1 -i "$i" || return 1
+ done
+ aclocal && autoconf && automake
+}
+
+build() {
+ cd "$_builddir"
+ CFLAGS="$CFLAGS -I/usr/include/libical"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="a774db748228efee96186158d553ade9 osmo-0.2.10.tar.gz
+6c9939fd4df9d25e1a220585e6875c78 osmo-0.2.10-build-mo.patch"
diff --git a/main/osmo/osmo-0.2.10-build-mo.patch b/main/osmo/osmo-0.2.10-build-mo.patch
new file mode 100644
index 000000000..ac1b9aa23
--- /dev/null
+++ b/main/osmo/osmo-0.2.10-build-mo.patch
@@ -0,0 +1,20 @@
+diff --git a/po/Makefile.am b/po/Makefile.am
+index b3c904a..f0ee467 100644
+--- a/po/Makefile.am
++++ b/po/Makefile.am
+@@ -16,8 +16,8 @@ all: $(MOFILES)
+
+ update-po: $(DOMAIN).pot $(POFILES) $(MOFILES)
+
+-%.mo: skip
+- @po=$(@:.mo=.po); if test $$po -nt $@ ; then $(MSGFMT) -c --statistics $$po -o $@; echo "$@ updated."; fi
++%.mo: %.po
++ @$(MSGFMT) -c --statistics $^ -o $@; echo "$@ updated."
+
+ %.po: $(DOMAIN).pot
+ $(MSGMERGE) $@ $< -o $@.in && mv $@.in $@
+@@ -41,4 +41,3 @@ uninstall-local:
+ clean-local:
+ rm -rf *.mo
+
+-skip: