summaryrefslogtreecommitdiffstats
path: root/main/patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 17:23:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 17:23:58 +0000
commitb5b15ea69f605a5c17b1d668ff656aae4b1f3d41 (patch)
tree787ca7e374679dcb4271da092e71dcc7917f337e /main/patch
parentbac1076f86c9afef03a37226757d05ffb4056340 (diff)
downloadaports-b5b15ea69f605a5c17b1d668ff656aae4b1f3d41.tar.bz2
aports-b5b15ea69f605a5c17b1d668ff656aae4b1f3d41.tar.xz
main/patch: re-add aport that got lost in move
Diffstat (limited to 'main/patch')
-rw-r--r--main/patch/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/main/patch/APKBUILD b/main/patch/APKBUILD
new file mode 100644
index 000000000..8e4691db7
--- /dev/null
+++ b/main/patch/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=patch
+pkgver=2.5.9
+pkgrel=0
+pkgdesc="Utility to apply diffs to files"
+url="http://www.gnu.org/software/patch/patch.html"
+license='GPL'
+depends=
+source=http://alpha.gnu.org/gnu/diffutils/$pkgname-$pkgver.tar.gz
+
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man
+ make || return 1
+ make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install
+}
+
+md5sums='dacfb618082f8d3a2194601193cf8716 patch-2.5.9.tar.gz'