summaryrefslogtreecommitdiffstats
path: root/main/perl-io-async
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-12 10:40:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-12 10:40:09 +0000
commite5b4ccd4a61ace435d2a4aebaa0771114f665dd9 (patch)
tree9ca108bb5faecf3a8ef8d58ffa192edfd13d49b3 /main/perl-io-async
parentf03b141f758a0ed40c8b3202138975b6dc04c3a3 (diff)
downloadaports-e5b4ccd4a61ace435d2a4aebaa0771114f665dd9.tar.bz2
aports-e5b4ccd4a61ace435d2a4aebaa0771114f665dd9.tar.xz
main/perl-io-async: moved to main
Diffstat (limited to 'main/perl-io-async')
-rw-r--r--main/perl-io-async/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/perl-io-async/APKBUILD b/main/perl-io-async/APKBUILD
new file mode 100644
index 000000000..a5e6d1541
--- /dev/null
+++ b/main/perl-io-async/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-io-async
+_pkgreal=IO-Async
+pkgver=0.45
+pkgrel=0
+pkgdesc="Asynchronous event-driven programming"
+url="http://search.cpan.org/dist/IO-Async/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-heap perl-async-mergepoint perl-cps"
+cpanmakedepends="perl-test-fatal perl-test-warn perl-test-refcount perl-test-identity"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="00f4213a413bb1fc431bfe56568c0192 IO-Async-0.45.tar.gz"