summaryrefslogtreecommitdiffstats
path: root/main/perl-switch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-23 18:27:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-23 18:27:59 +0000
commit33735d4ca2a67e16b214bbaa3dc88e2d5d5deb61 (patch)
treef993ea29499df1d0cdb139311283b40c8f279a8b /main/perl-switch
parentf64adb2e19d9899a5c758c29a46becd9027bf645 (diff)
downloadaports-33735d4ca2a67e16b214bbaa3dc88e2d5d5deb61.tar.bz2
aports-33735d4ca2a67e16b214bbaa3dc88e2d5d5deb61.tar.xz
main/perl-switch: new aport
previously shipped with perl
Diffstat (limited to 'main/perl-switch')
-rw-r--r--main/perl-switch/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/perl-switch/APKBUILD b/main/perl-switch/APKBUILD
new file mode 100644
index 000000000..0d43829d3
--- /dev/null
+++ b/main/perl-switch/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-switch
+pkgver=2.16
+pkgrel=0
+pkgdesc="A switch statement for Perl"
+url="http://search.cpan.org/~rgarcia/Switch-$pkgver/"
+arch="noarch"
+license="Perl"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/Switch-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Switch-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="bf75dc7f171b4718a2118c3d6cbe6013 Switch-2.16.tar.gz"