summaryrefslogtreecommitdiffstats
path: root/main/perl-yaml-syck
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-15 10:57:32 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-15 10:58:15 +0000
commit4445acfbaa04990754aed1cefc4510c15ad2e9ac (patch)
tree54d8f44372d96d1e4590c7e475dbb5f3339e9583 /main/perl-yaml-syck
parent7eb39fcc0e57fb06621635884df62332d4549668 (diff)
downloadaports-4445acfbaa04990754aed1cefc4510c15ad2e9ac.tar.bz2
aports-4445acfbaa04990754aed1cefc4510c15ad2e9ac.tar.xz
main/perl-yaml-syck: fix arm build
Diffstat (limited to 'main/perl-yaml-syck')
-rw-r--r--main/perl-yaml-syck/0001-Recognize-all-wide-unicode-characters.patch94
-rw-r--r--main/perl-yaml-syck/APKBUILD24
2 files changed, 111 insertions, 7 deletions
diff --git a/main/perl-yaml-syck/0001-Recognize-all-wide-unicode-characters.patch b/main/perl-yaml-syck/0001-Recognize-all-wide-unicode-characters.patch
new file mode 100644
index 000000000..702a8fa39
--- /dev/null
+++ b/main/perl-yaml-syck/0001-Recognize-all-wide-unicode-characters.patch
@@ -0,0 +1,94 @@
+From f646fa6ce15984b4a7d3c7b633be4129ad00c407 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Fri, 8 Mar 2013 13:00:52 +0100
+Subject: [PATCH] Recognize all wide unicode characters
+
+Type cast explicitly to (signed char) because sizof(char) can differ
+from sizof(int). Also do not quote bytes above 0x7F because we assume
+UTF-8 encoding.
+
+This should be fixed properly by UTF-8 to Unicode decoding but we
+need to recognize which encoding is in use before. How?
+---
+ emitter.c | 22 +++++++++++-----------
+ syck.h | 2 +-
+ 2 files changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/emitter.c b/emitter.c
+index 48141b3..1d1a609 100644
+--- a/emitter.c
++++ b/emitter.c
+@@ -16,9 +16,9 @@
+
+ #define DEFAULT_ANCHOR_FORMAT "id%03d"
+
+-const char hex_table[] =
++const unsigned char hex_table[] =
+ "0123456789ABCDEF";
+-static char b64_table[] =
++static unsigned char b64_table[] =
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
+
+ /*
+@@ -598,12 +598,12 @@ syck_scan_scalar( int req_width, char *cursor, long len )
+ /* scan string */
+ for ( i = 0; i < len; i++ ) {
+
+- if ( ! ( (unsigned)cursor[i] == 0x9 ||
+- (unsigned)cursor[i] == 0xA ||
+- (unsigned)cursor[i] == 0xD ||
+- ( (unsigned)cursor[i] >= 0x20 && (unsigned)cursor[i] <= 0x7E ) ||
+- (unsigned)cursor[i] == 0x85 ||
+- (unsigned)cursor[i] >= 0xa0 )
++ if ( ! ( (unsigned char)cursor[i] == 0x9 ||
++ (unsigned char)cursor[i] == 0xA ||
++ (unsigned char)cursor[i] == 0xD ||
++ ( (unsigned char)cursor[i] >= 0x20 &&
++ (unsigned char)cursor[i] <= 0x7E ) ||
++ (unsigned char)cursor[i] >= 0x80 )
+ ) {
+ flags |= SCAN_NONPRINT;
+ }
+@@ -812,7 +812,7 @@ void syck_emit_scalar( SyckEmitter *e, char *tag, enum scalar_style force_style,
+ }
+
+ void
+-syck_emitter_escape( SyckEmitter *e, char *src, long len )
++syck_emitter_escape( SyckEmitter *e, unsigned char *src, long len )
+ {
+ int i;
+ for( i = 0; i < len; i++ )
+@@ -927,7 +927,7 @@ void syck_emit_2quoted_1( SyckEmitter *e, int width, char *str, long len )
+ break;
+
+ default:
+- syck_emitter_escape( e, mark, 1 );
++ syck_emitter_escape( e, (unsigned char *)mark, 1 );
+ break;
+ }
+ mark++;
+@@ -990,7 +990,7 @@ void syck_emit_2quoted( SyckEmitter *e, int width, char *str, long len )
+ break;
+
+ default:
+- syck_emitter_escape( e, mark, 1 );
++ syck_emitter_escape( e, (unsigned char*)mark, 1 );
+ break;
+ }
+ mark++;
+diff --git a/syck.h b/syck.h
+index 2886561..f5118cd 100644
+--- a/syck.h
++++ b/syck.h
+@@ -411,7 +411,7 @@ void syck_emitter_handler( SyckEmitter *, SyckEmitterHandler );
+ void syck_free_emitter( SyckEmitter * );
+ void syck_emitter_clear( SyckEmitter * );
+ void syck_emitter_write( SyckEmitter *, const char *, long );
+-void syck_emitter_escape( SyckEmitter *, char *, long );
++void syck_emitter_escape( SyckEmitter *, unsigned char *, long );
+ void syck_emitter_flush( SyckEmitter *, long );
+ void syck_emit( SyckEmitter *, st_data_t );
+ void syck_emit_scalar( SyckEmitter *, char *, enum scalar_style, int, int, char, char *, long );
+--
+1.8.1.4
+
diff --git a/main/perl-yaml-syck/APKBUILD b/main/perl-yaml-syck/APKBUILD
index a3bdc3d55..f1bb4881f 100644
--- a/main/perl-yaml-syck/APKBUILD
+++ b/main/perl-yaml-syck/APKBUILD
@@ -1,10 +1,10 @@
# Automatically generated by apkbuild-cpan, template 1
-# Contributor:
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-yaml-syck
_pkgreal=YAML-Syck
pkgver=1.27
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, lightweight YAML loader and dumper"
url="http://search.cpan.org/dist/YAML-Syck/"
arch="all"
@@ -14,12 +14,19 @@ cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz
+ 0001-Recognize-all-wide-unicode-characters.patch
+ "
_builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
@@ -36,6 +43,9 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="8920091e68a078cfa9c42041e5759162 YAML-Syck-1.27.tar.gz"
-sha256sums="de74e534a0e21b05cc7e7af322d45754122c192ac871802cd9488fef50e02df9 YAML-Syck-1.27.tar.gz"
-sha512sums="c54c8d2b0cb73a0bcc5c377ce91eb50c706429832a6f3190fcdc8b4eedec2b6f8e7add53f578bc9795d8600bd5cd9a000d491077be5851a15493df6993e469fc YAML-Syck-1.27.tar.gz"
+md5sums="8920091e68a078cfa9c42041e5759162 YAML-Syck-1.27.tar.gz
+8c668a61b6b3de0a5328751f217019ef 0001-Recognize-all-wide-unicode-characters.patch"
+sha256sums="de74e534a0e21b05cc7e7af322d45754122c192ac871802cd9488fef50e02df9 YAML-Syck-1.27.tar.gz
+a04bac994563b9836f84e07bb9391a781804ecd997399e799c4d9fd9e058c205 0001-Recognize-all-wide-unicode-characters.patch"
+sha512sums="c54c8d2b0cb73a0bcc5c377ce91eb50c706429832a6f3190fcdc8b4eedec2b6f8e7add53f578bc9795d8600bd5cd9a000d491077be5851a15493df6993e469fc YAML-Syck-1.27.tar.gz
+08c380435000bda15fa9247447f0330721d7bd33c4bba8a5637c7d5487e0da187692bc63af6225214be9e0c0d19c9e79c9e4241657912a68778a3f5d79a75988 0001-Recognize-all-wide-unicode-characters.patch"