summaryrefslogtreecommitdiffstats
path: root/main/php-xcache
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-06-16 15:32:39 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-06-16 15:32:39 +0200
commit55d25f23fb3ebcb24440622c7f7687e696fd5d3c (patch)
tree8815f98f9249455dc5cf339056614932c70e1e57 /main/php-xcache
parent7a7ef77119a9d4735d404ae052c31651d044aa65 (diff)
downloadaports-55d25f23fb3ebcb24440622c7f7687e696fd5d3c.tar.bz2
aports-55d25f23fb3ebcb24440622c7f7687e696fd5d3c.tar.xz
main/php-xcache: moved from testing
Diffstat (limited to 'main/php-xcache')
-rw-r--r--main/php-xcache/APKBUILD53
-rw-r--r--main/php-xcache/xcache.ini3
2 files changed, 56 insertions, 0 deletions
diff --git a/main/php-xcache/APKBUILD b/main/php-xcache/APKBUILD
new file mode 100644
index 000000000..26c14459d
--- /dev/null
+++ b/main/php-xcache/APKBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=php-xcache
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="php opcode cacher"
+url="http://xcache.lighttpd.net/"
+arch="all"
+license="BSD"
+depends="zendframework"
+depends_dev=""
+makedepends="$depends_dev php-dev autoconf automake flex bison gawk"
+install=""
+subpackages=""
+source="http://xcache.lighttpd.net/pub/Releases/$pkgver/xcache-$pkgver.tar.bz2
+ xcache.ini"
+
+_builddir="$srcdir"/xcache-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ phpize --clean && phpize || return 1
+ ./configure \
+ --prefix=/usr \
+ --enable-xcache \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ || return 1
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 install INSTALL_ROOT="$pkgdir" || return 1
+ install -Dm644 "$srcdir"/xcache.ini \
+ "$pkgdir"/etc/php/conf.d/xcache.ini || return 1
+}
+
+md5sums="7371a057be0f53ba5a5ed09fdf11ae77 xcache-3.0.2.tar.bz2
+8fd9ce537ada9463c4b0c042243158c0 xcache.ini"
+sha256sums="cddeaf4d6b9676ba351ab92b39d8837adf8d2fa3424616d60da12cf29dc0b2df xcache-3.0.2.tar.bz2
+c8c843335028b1da1965ff71b73b42fc4bc45be08bf9ec3f71aff5744a428176 xcache.ini"
+sha512sums="d817659445da4b093ad818f759e1610f0ecfdf015fe53b2d20670b87e599b1e5357cf94f9599a1e1c0d2b15eef99fc653405d52d597e76af5a6696cb6885494e xcache-3.0.2.tar.bz2
+dc693745177ab1dfcd4e0ae1193ebcedf7d97f4ea222525fa52955be5dd68a50db27cce0c6ef069f9972e79d2cb0f88d6fa27e6e433781312c370e791a64c1cc xcache.ini"
diff --git a/main/php-xcache/xcache.ini b/main/php-xcache/xcache.ini
new file mode 100644
index 000000000..b814dbce1
--- /dev/null
+++ b/main/php-xcache/xcache.ini
@@ -0,0 +1,3 @@
+;extension=xcache.so
+xcache.size=64M
+xcache.var_size=64M