summaryrefslogtreecommitdiffstats
path: root/main/php
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-17 15:19:29 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-17 15:19:48 +0200
commit3063244af3ab02c32b142561809a983c8c0b5e59 (patch)
tree695eb92b399337b13c43159e95b94e9e367062ef /main/php
parent7f1b8389aa0564a7b44661485f9841d34caad980 (diff)
downloadaports-3063244af3ab02c32b142561809a983c8c0b5e59.tar.bz2
aports-3063244af3ab02c32b142561809a983c8c0b5e59.tar.xz
main/php: upgrade to 5.5.5
Diffstat (limited to 'main/php')
-rw-r--r--main/php/APKBUILD14
-rw-r--r--main/php/pcre_info.patch43
2 files changed, 7 insertions, 50 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index 3af1f9123..427edd6e9 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=php
-pkgver=5.5.4
-pkgrel=1
+pkgver=5.5.5
+pkgrel=0
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -103,7 +103,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-common $pkgname-cgi
$pkgname-opcache
"
-source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
+source="http://php.net/distributions/php-$pkgver.tar.xz
php-fpm.initd
php5-module.conf
php-install-pear-xml.patch
@@ -116,7 +116,7 @@ _srcdir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_srcdir"
- update_config_sub || return 1
+ update_config_sub
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -486,17 +486,17 @@ pdo_dblib() { _mv_ext pdo_dblib "php-pdo freetds"; }
wddx() { _mv_ext wddx; }
opcache() { _mv_ext opcache; }
-md5sums="456f2eb1ee36f2a277bd4cc778e720eb php-5.5.4.tar.bz2
+md5sums="a4788118fdb0c4d8cef08be72025e983 php-5.5.5.tar.xz
9ab162ff3428511a68aa9801c746e0d5 php-fpm.initd
67719f428f44ec004da18705cbabe2ee php5-module.conf
483bc0a85c50a9a9aedbe14a19ed4526 php-install-pear-xml.patch
162d8d079944387eab2bc80edab347ae gd-iconv.patch"
-sha256sums="49f87e8cf0bbec53a6e7f1c8ab132fcec37bb09990404c7c959f81dfb1637439 php-5.5.4.tar.bz2
+sha256sums="82cc9c88b946354bfe629917a85ed33d8cfc901460d432a75f823667d94f29ee php-5.5.5.tar.xz
96e68f7c545adcac56ed1f5824b33041e270680ca884a9cfe27e7f4ac8abfd3b php-fpm.initd
ceec4d5b2a128c6a97e49830af604f0bb555bca1a86a9cd0366b828ba392257f php5-module.conf
f739ca427a1dd53a388bad0823565299c5d4a5796b1171b892884e4d7d099bab php-install-pear-xml.patch
6122bf279cdb7c387dd000761b2426969a73cf63a10a132aa98a79eb1dd259b2 gd-iconv.patch"
-sha512sums="69c4c6279c0a74da7d500ffc14f5dd60e13600b69957f0d8b8ec6e94ffb65510c0a970eaa574dfc1fa89d4e9179543313d47d1a67efa100be0b1570b653237ba php-5.5.4.tar.bz2
+sha512sums="63d74b62164fddfd3b32c8ad2daa5a322f7feb277549a77abd19386e5896b999b47d3cb8b0461ede3141e4025bb85a73cca9b7edc5c3fac3b512fbe059edb328 php-5.5.5.tar.xz
33247a1c9188eba893bb0be13456eeeec9b971c7f482a4e2bd0f318fb63d8c67d379a021840768bef8e4d630be859c5bdb424c1e90b9b816ec691c078147e915 php-fpm.initd
895e94c791bd82060ad820fef049d366a09c932097faa6b7b9a2c2e9e00a18cb7c0f9b128679c7659b404379266fd0f95dba5c0333f626194cf60f7bf6044102 php5-module.conf
f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 php-install-pear-xml.patch
diff --git a/main/php/pcre_info.patch b/main/php/pcre_info.patch
deleted file mode 100644
index e6d10df06..000000000
--- a/main/php/pcre_info.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- php-5.3.10/ext/pcre/php_pcre.c 2012-01-01 14:15:04.000000000 +0100
-+++ php-5.3.10/ext/pcre/php_pcre.c 2012-02-06 13:31:36.198935107 +0100
-@@ -241,6 +241,7 @@
- char *pattern;
- int do_study = 0;
- int poptions = 0;
-+ int count = 0;
- unsigned const char *tables = NULL;
- #if HAVE_SETLOCALE
- char *locale = setlocale(LC_CTYPE, NULL);
-@@ -252,10 +252,10 @@
- back the compiled pattern, otherwise go on and compile it. */
- if (zend_hash_find(&PCRE_G(pcre_cache), regex, regex_len+1, (void **)&pce) == SUCCESS) {
- /*
-- * We use a quick pcre_info() check to see whether cache is corrupted, and if it
-+ * We use a quick pcre_fullinfo() check to see whether cache is corrupted, and if it
- * is, we flush it and compile the pattern from scratch.
- */
-- if (pcre_info(pce->re, NULL, NULL) == PCRE_ERROR_BADMAGIC) {
-+ if (pcre_fullinfo(pce->re, NULL, PCRE_INFO_CAPTURECOUNT, &count) == PCRE_ERROR_BADMAGIC) {
- zend_hash_clean(&PCRE_G(pcre_cache));
- } else {
- #if HAVE_SETLOCALE
---- php-5.3.10/ext/pcre/php_pcre.def 2009-01-11 14:59:00.000000000 +0100
-+++ php-5.3.10/ext/pcre/php_pcre.def 2012-02-06 13:31:47.775299315 +0100
-@@ -4,7 +4,6 @@
- php_pcre_exec
- php_pcre_get_substring
- php_pcre_get_substring_list
--php_pcre_info
- php_pcre_maketables
- php_pcre_study
- php_pcre_version
---- php-5.3.10/main/php_compat.h 2012-01-01 14:15:04.000000000 +0100
-+++ php-5.3.10/main/php_compat.h 2012-02-06 13:26:59.272834580 +0100
-@@ -34,7 +34,6 @@
- #define pcre_exec php_pcre_exec
- #define pcre_get_substring php_pcre_get_substring
- #define pcre_get_substring_list php_pcre_get_substring_list
--#define pcre_info php_pcre_info
- #define pcre_maketables php_pcre_maketables
- #define pcre_study php_pcre_study
- #define pcre_version php_pcre_version