summaryrefslogtreecommitdiffstats
path: root/main/php
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-12 20:38:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-12 20:49:45 +0000
commit7f0dbe56f0aa097937ea2f63295e69b3631a59d9 (patch)
treeb36de3959ba0a6e6cd94c218e4ec6f838280cc37 /main/php
parent3a6d39f8e3a5dc129a5b89c970a6f645ba94ad9a (diff)
downloadaports-7f0dbe56f0aa097937ea2f63295e69b3631a59d9.tar.bz2
aports-7f0dbe56f0aa097937ea2f63295e69b3631a59d9.tar.xz
main/php: rebuild against pcre-8.30
Diffstat (limited to 'main/php')
-rw-r--r--main/php/APKBUILD4
-rw-r--r--main/php/pcre_info.patch43
2 files changed, 46 insertions, 1 deletions
diff --git a/main/php/APKBUILD b/main/php/APKBUILD
index f85fafb55..7c8c53b98 100644
--- a/main/php/APKBUILD
+++ b/main/php/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php
pkgver=5.3.10
_suhosinver=5.3.9-0.9.10
-pkgrel=1
+pkgrel=2
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
arch="all"
@@ -74,6 +74,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-common $pkgname-cgi
source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2
http://download.suhosin.org/suhosin-patch-${_suhosinver}.patch.gz
php-install-pear-xml.patch
+ pcre_info.patch
php-fpm.initd
php5-module.conf
"
@@ -444,5 +445,6 @@ pdo_dblib() { _mv_ext pdo_dblib "php-pdo freetds"; }
md5sums="816259e5ca7d0a7e943e56a3bb32b17f php-5.3.10.tar.bz2
c099b3d7eac95018ababd41ded7f3066 suhosin-patch-5.3.9-0.9.10.patch.gz
5111e3be06d391f8772587c675240fab php-install-pear-xml.patch
+8d3806bbb19e390f9b32ccf21611d937 pcre_info.patch
8f2bb2b744a2de50025842cb51fb6a3a php-fpm.initd
67719f428f44ec004da18705cbabe2ee php5-module.conf"
diff --git a/main/php/pcre_info.patch b/main/php/pcre_info.patch
new file mode 100644
index 000000000..e6d10df06
--- /dev/null
+++ b/main/php/pcre_info.patch
@@ -0,0 +1,43 @@
+--- php-5.3.10/ext/pcre/php_pcre.c 2012-01-01 14:15:04.000000000 +0100
++++ php-5.3.10/ext/pcre/php_pcre.c 2012-02-06 13:31:36.198935107 +0100
+@@ -241,6 +241,7 @@
+ char *pattern;
+ int do_study = 0;
+ int poptions = 0;
++ int count = 0;
+ unsigned const char *tables = NULL;
+ #if HAVE_SETLOCALE
+ char *locale = setlocale(LC_CTYPE, NULL);
+@@ -252,10 +252,10 @@
+ back the compiled pattern, otherwise go on and compile it. */
+ if (zend_hash_find(&PCRE_G(pcre_cache), regex, regex_len+1, (void **)&pce) == SUCCESS) {
+ /*
+- * We use a quick pcre_info() check to see whether cache is corrupted, and if it
++ * We use a quick pcre_fullinfo() check to see whether cache is corrupted, and if it
+ * is, we flush it and compile the pattern from scratch.
+ */
+- if (pcre_info(pce->re, NULL, NULL) == PCRE_ERROR_BADMAGIC) {
++ if (pcre_fullinfo(pce->re, NULL, PCRE_INFO_CAPTURECOUNT, &count) == PCRE_ERROR_BADMAGIC) {
+ zend_hash_clean(&PCRE_G(pcre_cache));
+ } else {
+ #if HAVE_SETLOCALE
+--- php-5.3.10/ext/pcre/php_pcre.def 2009-01-11 14:59:00.000000000 +0100
++++ php-5.3.10/ext/pcre/php_pcre.def 2012-02-06 13:31:47.775299315 +0100
+@@ -4,7 +4,6 @@
+ php_pcre_exec
+ php_pcre_get_substring
+ php_pcre_get_substring_list
+-php_pcre_info
+ php_pcre_maketables
+ php_pcre_study
+ php_pcre_version
+--- php-5.3.10/main/php_compat.h 2012-01-01 14:15:04.000000000 +0100
++++ php-5.3.10/main/php_compat.h 2012-02-06 13:26:59.272834580 +0100
+@@ -34,7 +34,6 @@
+ #define pcre_exec php_pcre_exec
+ #define pcre_get_substring php_pcre_get_substring
+ #define pcre_get_substring_list php_pcre_get_substring_list
+-#define pcre_info php_pcre_info
+ #define pcre_maketables php_pcre_maketables
+ #define pcre_study php_pcre_study
+ #define pcre_version php_pcre_version