summaryrefslogtreecommitdiffstats
path: root/main/pngcrush
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2012-03-13 12:16:53 -0400
committerKiyoshi Aman <aphrael@alpinelinux.org>2012-03-13 12:17:21 -0400
commita547975afc0b1b70fd23afa577db276664e14d96 (patch)
tree81f5ed02faf6132f05de323ae8f157f44898303a /main/pngcrush
parentc37fe5f609ecef1ec68d5f79fccf90cc27c0a5d9 (diff)
downloadaports-a547975afc0b1b70fd23afa577db276664e14d96.tar.bz2
aports-a547975afc0b1b70fd23afa577db276664e14d96.tar.xz
main/pngcrush: new APKBUILD
Diffstat (limited to 'main/pngcrush')
-rw-r--r--main/pngcrush/01-makefile-sanity.patch13
-rw-r--r--main/pngcrush/APKBUILD46
-rw-r--r--main/pngcrush/license.txt12
3 files changed, 71 insertions, 0 deletions
diff --git a/main/pngcrush/01-makefile-sanity.patch b/main/pngcrush/01-makefile-sanity.patch
new file mode 100644
index 000000000..abbeff553
--- /dev/null
+++ b/main/pngcrush/01-makefile-sanity.patch
@@ -0,0 +1,13 @@
+--- pngcrush-1.7.25/Makefile
++++ pngcrush-1.7.25/Makefile
+@@ -20,8 +20,8 @@
+ #CFLAGS = -I. -O -Wall
+ #CFLAGS = -I. -O2
+ #CFLAGS = -I. -O3 -fomit-frame-pointer -Wall
+-#CFLAGS = -I. -Os -fomit-frame-pointer -Wall
+-CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
++CFLAGS = -I. -Os -fomit-frame-pointer -Wall
++#CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
+ #CFLAGS = -I${ZINC} -I. -O3 -fomit-frame-pointer -Wall
+ # [note that -Wall is a gcc-specific compilation flag ("all warnings on")]
+
diff --git a/main/pngcrush/APKBUILD b/main/pngcrush/APKBUILD
new file mode 100644
index 000000000..f6e347c98
--- /dev/null
+++ b/main/pngcrush/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer:
+pkgname=pngcrush
+pkgver=1.7.25
+pkgrel=0
+pkgdesc="PNG recompression utility"
+url="http://pngcrush.sourceforge.net"
+arch="all"
+license="zlib"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="
+ http://downloads.sourceforge.net/project/pmt/pngcrush/$pkgver/pngcrush-$pkgver.tar.bz2
+ license.txt
+ 01-makefile-sanity.patch
+ "
+
+_builddir="$srcdir"/pngcrush-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 pngcrush "$pkgdir"/usr/bin/pngcrush
+ install -D -m644 "$srcdir"/license.txt "$pkgdir"/usr/share/licenses/pngcrush
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="c891a418419efa07aa513db602d8f403 pngcrush-1.7.25.tar.bz2
+8e5d194d4197e51add36722cd3248717 license.txt
+837e46dc592ef087547372e278502b57 01-makefile-sanity.patch"
diff --git a/main/pngcrush/license.txt b/main/pngcrush/license.txt
new file mode 100644
index 000000000..641d19c0b
--- /dev/null
+++ b/main/pngcrush/license.txt
@@ -0,0 +1,12 @@
+Permission is hereby irrevocably granted to everyone to use, copy, modify,
+and distribute this source code, or portions hereof, or executable programs
+compiled from it, for any purpose, without payment of any fee, subject to
+the following restrictions:
+
+1. The origin of this source code must not be misrepresented.
+
+2. Altered versions must be plainly marked as such and must not be
+ misrepresented as being the original source.
+
+3. This Copyright notice, disclaimer, and license may not be removed
+ or altered from any source or altered source distribution.