summaryrefslogtreecommitdiffstats
path: root/main/ppp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-03-29 18:34:24 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-03-29 18:34:24 +0000
commit67c9f0ff227b2ac6e2a939714dda6b8f810d28e9 (patch)
tree22f56fad848e4032674c864d5f849aad7f8e82d8 /main/ppp
parentd90ae88d13e52429005f70793b4a3120e9eafd98 (diff)
downloadaports-67c9f0ff227b2ac6e2a939714dda6b8f810d28e9.tar.bz2
aports-67c9f0ff227b2ac6e2a939714dda6b8f810d28e9.tar.xz
main/ppp: add support for ipv6 filter and CBCP in pppd
Diffstat (limited to 'main/ppp')
-rw-r--r--main/ppp/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/ppp/APKBUILD b/main/ppp/APKBUILD
index 97439d042..f13950f54 100644
--- a/main/ppp/APKBUILD
+++ b/main/ppp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ppp
pkgver=2.4.5
-pkgrel=4
+pkgrel=5
pkgdesc="A daemon which implements the PPP protocol for dial-up networking"
url="http://www.samba.org/ppp/"
arch="all"
@@ -21,6 +21,14 @@ source="ftp://ftp.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
_builddir="$srcdir"/$pkgname-$pkgver
build () {
cd "$_builddir"
+
+ # enable active filter
+ sed -i "s:^#FILTER=y:FILTER=y:" pppd/Makefile.linux
+ # enable ipv6 support
+ sed -i "s:^#HAVE_INET6=y:HAVE_INET6=y:" pppd/Makefile.linux
+ # Enable Microsoft proprietary Callback Control Protocol
+ sed -i "s:^#CBCP=y:CBCP=y:" pppd/Makefile.linux
+
./configure --prefix=/usr
make COPTS="$CFLAGS" || return 1
}