summaryrefslogtreecommitdiffstats
path: root/main/py-boto
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-03-29 23:39:52 -0500
committerMatt Smith <mcs@darkregion.net>2011-03-29 23:39:52 -0500
commitf3e054e83191c6bddd83f639c8826e829b790e91 (patch)
treef74a690a8dc1d5c30c4707272590d104c0d70584 /main/py-boto
parent168bc56a766049485faf3805b48d42fbf4145a8c (diff)
downloadaports-f3e054e83191c6bddd83f639c8826e829b790e91.tar.bz2
aports-f3e054e83191c6bddd83f639c8826e829b790e91.tar.xz
main/py-boto: moved from testing
Diffstat (limited to 'main/py-boto')
-rw-r--r--main/py-boto/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/main/py-boto/APKBUILD b/main/py-boto/APKBUILD
new file mode 100644
index 000000000..8663a6de0
--- /dev/null
+++ b/main/py-boto/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=py-boto
+_pkgname=boto
+pkgver=1.9b
+pkgrel=1
+pkgdesc="An integrated interface to current and future infrastructural services offered by Amazon Web Services."
+url="http://code.google.com/p/boto/"
+arch="noarch"
+license="MIT"
+depends="python"
+makedepends="python-dev py-setuptools"
+install=
+subpackages="$pkgname-doc"
+source="http://$_pkgname.googlecode.com/files/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+doc() {
+ cd "$_builddir"
+
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
+ install -Dm644 README "$subpkgdir"/usr/share/doc/$pkgname/README
+
+ # Note: The documentation in the 'docs' directory can only be generated
+ # (via sphinx-build from the py-sphinx package) once this package has
+ # been installed. Copying it off for the user.
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/docs
+ cp -R ./docs/* "$subpkgdir"/usr/share/doc/$pkgname/docs/
+ chmod -R 644 "$subpkgdir"/usr/share/doc/$pkgname/docs/
+
+ # Fix subdir perms
+ find "$subpkgdir"/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
+}
+
+md5sums="4fc2fd7b70a971b1363f8465aafe7091 boto-1.9b.tar.gz"