summaryrefslogtreecommitdiffstats
path: root/main/py-ethtool
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 17:19:56 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 17:19:56 +0000
commitb5e4091e9566c9db3208d6f56ec49f42a645a8cf (patch)
tree1be6e7a2c107399030e31d109c1b73ae338f3a66 /main/py-ethtool
parente21031c82b72f124cf23a21404bfb531378ed8a8 (diff)
downloadaports-b5e4091e9566c9db3208d6f56ec49f42a645a8cf.tar.bz2
aports-b5e4091e9566c9db3208d6f56ec49f42a645a8cf.tar.xz
main/py-ethtool: fix musl build
Diffstat (limited to 'main/py-ethtool')
-rw-r--r--main/py-ethtool/APKBUILD13
-rw-r--r--main/py-ethtool/fix-includes-and-types.patch25
2 files changed, 36 insertions, 2 deletions
diff --git a/main/py-ethtool/APKBUILD b/main/py-ethtool/APKBUILD
index 0af006922..6e1718d02 100644
--- a/main/py-ethtool/APKBUILD
+++ b/main/py-ethtool/APKBUILD
@@ -13,7 +13,9 @@ makedepends="$depends_dev"
install=
subpackages=
source="http://dsommers.fedorapeople.org/python-ethtool/$_realname-$pkgver.tar.bz2
- python-ethtool-libnl-1.0-support.patch"
+ python-ethtool-libnl-1.0-support.patch
+ fix-includes-and-types.patch
+ "
_builddir="$srcdir"/$_realname-$pkgver
@@ -40,4 +42,11 @@ package() {
}
md5sums="2d13e2412948344b8375f5af4ced1c20 python-ethtool-0.7.tar.bz2
-188f260534eb838193e0e8c249b6a33c python-ethtool-libnl-1.0-support.patch"
+188f260534eb838193e0e8c249b6a33c python-ethtool-libnl-1.0-support.patch
+2f9b03956f7e31080718036ad387669f fix-includes-and-types.patch"
+sha256sums="5ac6543c2fb7ffc7188cfaee1fac2e2bf6a9f59ce4d62d47b037d3a5ccaefa48 python-ethtool-0.7.tar.bz2
+6682d46a027a4b83b2724625ab0518d224b0805a7bddeb237f497cea7945a932 python-ethtool-libnl-1.0-support.patch
+5d2815a5e883b9aebaefbbad11485f15332c6e8484ed6ee57c7884b617a8085f fix-includes-and-types.patch"
+sha512sums="ee258bbb308d405c7089ab3a9e307c3bdafe557d220a2fad2498af3c54938ef9093973cdde52b6b971d07f888698af42bdcdbff00300c461248cfb2bdc3c35f5 python-ethtool-0.7.tar.bz2
+f3b3fbebfc276de712383f24439539bc649dd8cb91c9f63dd53ddf2c074592eb8deb22200947237e52dc6262c1dd3c4729e3912a40d42634a949c8b23deb96c9 python-ethtool-libnl-1.0-support.patch
+d600fb49864b328be7dae349d948e6f32d1608e590c5dec5289ac6873bb1386527a5eb05e310a94033bc2e48c019b23a88da277b14ad99c798935c9d9359e4c9 fix-includes-and-types.patch"
diff --git a/main/py-ethtool/fix-includes-and-types.patch b/main/py-ethtool/fix-includes-and-types.patch
new file mode 100644
index 000000000..da655f7c6
--- /dev/null
+++ b/main/py-ethtool/fix-includes-and-types.patch
@@ -0,0 +1,25 @@
+--- python-ethtool-0.7.orig/python-ethtool/etherinfo.c
++++ python-ethtool-0.7/python-ethtool/etherinfo.c
+@@ -16,7 +16,6 @@
+ */
+
+ #include <Python.h>
+-#include <bits/sockaddr.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/types.h>
+--- python-ethtool-0.7.orig/python-ethtool/ethtool.c
++++ python-ethtool-0.7/python-ethtool/ethtool.c
+@@ -41,9 +41,9 @@
+ #endif
+
+ typedef unsigned long long u64;
+-typedef __uint32_t u32;
+-typedef __uint16_t u16;
+-typedef __uint8_t u8;
++typedef uint32_t u32;
++typedef uint16_t u16;
++typedef uint8_t u8;
+
+ #include "ethtool-copy.h"
+ #include <linux/sockios.h> /* for SIOCETHTOOL */