summaryrefslogtreecommitdiffstats
path: root/main/py-twisted-names
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-12 13:14:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-12 13:14:26 +0000
commite468f79da203c2b32eb6b6978fcd6cc8d3df1b7d (patch)
tree628418ba55245dc9e029e59398eabd61e58dd245 /main/py-twisted-names
parentd973cdfd7f126fd117b932e9b425d30df7c72889 (diff)
downloadaports-e468f79da203c2b32eb6b6978fcd6cc8d3df1b7d.tar.bz2
aports-e468f79da203c2b32eb6b6978fcd6cc8d3df1b7d.tar.xz
main/py-twisted-names: moved from testing
Diffstat (limited to 'main/py-twisted-names')
-rw-r--r--main/py-twisted-names/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/py-twisted-names/APKBUILD b/main/py-twisted-names/APKBUILD
new file mode 100644
index 000000000..bfc31f569
--- /dev/null
+++ b/main/py-twisted-names/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Jeff Bilyk <jbilyk@alpinelinux.org>
+# Maintainer:
+
+pkgname=py-twisted-names
+_pkgname=TwistedNames
+pkgver=12.0.0
+pkgrel=0
+pkgdesc="Python Twisted Names DNS server and resolver library"
+url="http://twistedmatrix.com/trac/wiki/TwistedNames"
+arch="noarch"
+license="MIT"
+depends="py-twisted"
+makedepends="python-dev"
+source="http://twistedmatrix.com/Releases/Names/12.0/$_pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver/
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+
+}
+
+md5sums="1e7b0f1c60d550712245455080f85115 TwistedNames-12.0.0.tar.bz2"