summaryrefslogtreecommitdiffstats
path: root/main/py-twisted
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-12 13:14:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-12 13:14:26 +0000
commitfa581d4bece7b1691e6f66f18990d96de1ffb81b (patch)
tree2b704de703db1926c04788162cb32af41fbf03d1 /main/py-twisted
parentec67cb10342c14ce353fd7dfdb90b02433c5fff7 (diff)
downloadaports-fa581d4bece7b1691e6f66f18990d96de1ffb81b.tar.bz2
aports-fa581d4bece7b1691e6f66f18990d96de1ffb81b.tar.xz
main/py-twisted: moved from testing
Diffstat (limited to 'main/py-twisted')
-rw-r--r--main/py-twisted/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/py-twisted/APKBUILD b/main/py-twisted/APKBUILD
new file mode 100644
index 000000000..e8c18293c
--- /dev/null
+++ b/main/py-twisted/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-twisted
+_pkgname=Twisted
+pkgver=12.0.0
+pkgrel=1
+pkgdesc="Asynchronous networking framework written in Python."
+url="http://twistedmatrix.com/"
+arch="all"
+license="MIT"
+depends="py-crypto py-zope-interface"
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://twistedmatrix.com/Releases/Core/${pkgver%.*}/"$_pkgname"Core-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/"$_pkgname"Core-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ _mans="manhole.1 pyhtmlizer.1 tap2deb.1 tapconvert.1 trial.1 twistd.1"
+ for _man in $_mans; do
+ install -m644 -D "$_builddir"/doc/man/$_man \
+ "$pkgdir"/usr/share/man/man1/$_man || return 1
+ done
+}
+
+md5sums="d231ae966799eedaab4c62e062e227e0 TwistedCore-12.0.0.tar.bz2"