summaryrefslogtreecommitdiffstats
path: root/main/qt
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-12 20:57:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-12 20:58:32 +0000
commit47dbc672162b1dd33a1a6534af690cc0bb9d0949 (patch)
treee0129b17fb29e1e4f1533123246cb40de565be63 /main/qt
parentf065b719ee144e91ac4d07490b58ecf7de0b24cd (diff)
downloadaports-47dbc672162b1dd33a1a6534af690cc0bb9d0949.tar.bz2
aports-47dbc672162b1dd33a1a6534af690cc0bb9d0949.tar.xz
main/qt: remove rpath, build fix for gcc-4.7
Diffstat (limited to 'main/qt')
-rw-r--r--main/qt/APKBUILD8
-rw-r--r--main/qt/qt-4.8.1-webkit-no_Werror.patch12
2 files changed, 18 insertions, 2 deletions
diff --git a/main/qt/APKBUILD b/main/qt/APKBUILD
index dfcebb498..8f3b47d70 100644
--- a/main/qt/APKBUILD
+++ b/main/qt/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt
pkgver=4.8.2
-pkgrel=0
+pkgrel=1
pkgdesc="A cross-platform application and UI framework"
url="http://qt.nokia.com/"
arch="all"
@@ -21,6 +21,7 @@ install=
source="ftp://ftp.qt.nokia.com/qt/source/qt-everywhere-opensource-src-$pkgver.tar.gz
qt-gtk-theme-fix.patch
qsettings-recursive-global-mutex.patch
+ qt-4.8.1-webkit-no_Werror.patch
assistant.desktop
designer.desktop
linguist.desktop
@@ -90,6 +91,7 @@ build() {
-gtkstyle \
-opengl \
-no-openvg \
+ -no-rpath \
-glib \
|| return 1
qmake && make
@@ -98,7 +100,8 @@ build() {
package() {
cd "$_builddir"
make INSTALL_ROOT="$pkgdir" install
- rm "$pkgdir"/usr/lib/*.la
+ rm -r "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/tests || return 1
# install missing icons and desktop files
for icon in tools/linguist/linguist/images/icons/linguist-*-32.png ; do
@@ -235,6 +238,7 @@ x11() {
md5sums="3c1146ddf56247e16782f96910a8423b qt-everywhere-opensource-src-4.8.2.tar.gz
91e8b5ea1e682ae51b60a27d01d7d381 qt-gtk-theme-fix.patch
7467e168418c50b2737b4b2fab4448fe qsettings-recursive-global-mutex.patch
+b7535d9515a3990f684ff52dbd3328e1 qt-4.8.1-webkit-no_Werror.patch
a445c6917086d80f1cfc1e40cb6b0132 assistant.desktop
d457f0a0ad68a3861c3cadefe3b42ded designer.desktop
668331d9798a0e2b94381efb7be4c513 linguist.desktop
diff --git a/main/qt/qt-4.8.1-webkit-no_Werror.patch b/main/qt/qt-4.8.1-webkit-no_Werror.patch
new file mode 100644
index 000000000..ef5d55d5e
--- /dev/null
+++ b/main/qt/qt-4.8.1-webkit-no_Werror.patch
@@ -0,0 +1,12 @@
+diff -up qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri.no_Werror qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri
+--- qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri.no_Werror 2012-03-14 15:01:29.000000000 +0100
++++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri 2012-03-28 17:12:33.391294004 +0200
+@@ -102,8 +102,6 @@ CONFIG -= warn_on
+
+ # Treat warnings as errors on x86/Linux/GCC
+ linux-g++* {
+- !CONFIG(standalone_package):isEqual(QT_ARCH,x86_64)|isEqual(QT_ARCH,i386): QMAKE_CXXFLAGS += -Werror
+-
+ greaterThan(QT_GCC_MAJOR_VERSION, 3):greaterThan(QT_GCC_MINOR_VERSION, 5) {
+ if (!contains(QMAKE_CXXFLAGS, -std=c++0x) && !contains(QMAKE_CXXFLAGS, -std=gnu++0x)) {
+ # We need to deactivate those warnings because some names conflicts with upcoming c++0x types (e.g.nullptr).