summaryrefslogtreecommitdiffstats
path: root/main/rp-pppoe
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-09-30 11:59:14 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-09-30 11:59:14 +0000
commit51f9990c81320981b106f3825ec80cf89f44e819 (patch)
treea8437b01e543414ea2e5ca194aea520b7b842301 /main/rp-pppoe
parent9b3daba3fe823761dde3a312b21319e0f800c3c0 (diff)
downloadaports-51f9990c81320981b106f3825ec80cf89f44e819.tar.bz2
aports-51f9990c81320981b106f3825ec80cf89f44e819.tar.xz
main/rp-pppoe: fixed support for pppd and fix for initd
Diffstat (limited to 'main/rp-pppoe')
-rw-r--r--main/rp-pppoe/APKBUILD7
-rw-r--r--main/rp-pppoe/rp-pppoe.initd2
2 files changed, 5 insertions, 4 deletions
diff --git a/main/rp-pppoe/APKBUILD b/main/rp-pppoe/APKBUILD
index d3adcf265..b34cc822d 100644
--- a/main/rp-pppoe/APKBUILD
+++ b/main/rp-pppoe/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=rp-pppoe
pkgver=3.10
-pkgrel=8
+pkgrel=9
pkgdesc="Roaring Penguin\'s Point-to-Point Protocol over Ethernet client"
url="http://www.roaringpenguin.com/pppoe/"
arch="all"
@@ -22,7 +22,8 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --enable-plugin=/usr/include/pppd
make all || return 1
}
@@ -33,4 +34,4 @@ package() {
}
md5sums="d58a13cc4185bca6121a606ff456dec0 rp-pppoe-3.10.tar.gz
-6e98984f57c7b21735a503259b8e700e rp-pppoe.initd"
+f558de3e8cbb74e38218f8232c2da271 rp-pppoe.initd"
diff --git a/main/rp-pppoe/rp-pppoe.initd b/main/rp-pppoe/rp-pppoe.initd
index 186119996..b580dbe07 100644
--- a/main/rp-pppoe/rp-pppoe.initd
+++ b/main/rp-pppoe/rp-pppoe.initd
@@ -6,7 +6,7 @@ depend() {
start() {
ebegin "Starting PPPOE Server"
- test -x /usr/sbin/pppoe-server -a -f /etc/ppp/pppoe-server-options || exit 0
+ test -x /usr/sbin/pppoe-server || exit 0
start-stop-daemon --start --exec /usr/sbin/pppoe-server -- ${PPPOE_PARAMS}
eend $?
}