summaryrefslogtreecommitdiffstats
path: root/main/ruby-treetop
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-15 13:27:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-15 14:22:19 +0000
commit1a2b3d8b411ac1de6d1904dbbbac108ab0c939bf (patch)
treeb13b9c88e33ef64c928769c0cc2677e87ae745c3 /main/ruby-treetop
parent7606caa49bdd0eed8f3c467308ca0d16e822a511 (diff)
downloadaports-1a2b3d8b411ac1de6d1904dbbbac108ab0c939bf.tar.bz2
aports-1a2b3d8b411ac1de6d1904dbbbac108ab0c939bf.tar.xz
main/ruby-treetop: new aport
A Ruby-based text parsing and interpretation DSL https://github.com/cjheath/treetop
Diffstat (limited to 'main/ruby-treetop')
-rw-r--r--main/ruby-treetop/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/ruby-treetop/APKBUILD b/main/ruby-treetop/APKBUILD
new file mode 100644
index 000000000..b96d5445c
--- /dev/null
+++ b/main/ruby-treetop/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_gemname=treetop
+pkgname=ruby-$_gemname
+pkgver=1.4.11
+pkgrel=0
+pkgdesc="A Ruby-based text parsing and interpretation DSL"
+url="https://github.com/cjheath/treetop"
+arch="noarch"
+license="MIT"
+depends="ruby ruby-polyglot"
+depends_dev=
+makedepends="$depends_dev ruby-gems"
+install=""
+subpackages=""
+source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem"
+
+_builddir="$srcdir"/$_realname-$pkgver
+build() {
+ return 0
+}
+
+package() {
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ local _geminstdir=$_gemdir/gems/$_gemname-$pkgver
+ mkdir -p "$pkgdir" || return 1
+
+ gem install --local --install-dir "$pkgdir"/$_gemdir \
+ --ignore-dependencies --verbose --no-rdoc --no-ri \
+ "$srcdir"/$_gemname-$pkgver.gem || return 1
+ rm -rf "$pkgdir"/$_gemdir/cache \
+ "$pkgdir"/$_geminstdir/ext \
+ "$pkgdir"/$_geminstdir/.require_paths
+}
+
+md5sums="ca275286fecd06159d4545c8424e8543 treetop-1.4.11.gem"