summaryrefslogtreecommitdiffstats
path: root/main/shorewall-shell
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-14 09:01:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-14 09:09:16 +0000
commita6ab887506d0b6151606959447e45060a7d980f6 (patch)
tree401b0dc6a7d1205dfb83fd3a5a0129a42bcefee3 /main/shorewall-shell
parent8b32f31aa3809b8894bd6d4ff2d3199892bd9f9b (diff)
downloadaports-a6ab887506d0b6151606959447e45060a7d980f6.tar.bz2
aports-a6ab887506d0b6151606959447e45060a7d980f6.tar.xz
main/shorewall-shell: do not restore default gw that you never modified
Shorewall's restore default gw will intentinally break multi routes When no 'balance' option is specified shorewall does not change the default gw so there is no point in restoring (breaking) it either.
Diffstat (limited to 'main/shorewall-shell')
-rw-r--r--main/shorewall-shell/APKBUILD4
-rw-r--r--main/shorewall-shell/shorewall-shell-providers-gateway-none.patch11
2 files changed, 13 insertions, 2 deletions
diff --git a/main/shorewall-shell/APKBUILD b/main/shorewall-shell/APKBUILD
index 1dc8c7094..c04a3c15a 100644
--- a/main/shorewall-shell/APKBUILD
+++ b/main/shorewall-shell/APKBUILD
@@ -2,7 +2,7 @@
pkgname=shorewall-shell
_v=4.2.11
pkgver=4.2.11
-pkgrel=1
+pkgrel=2
pkgdesc="Shoreline Firewall shell-based compiler."
url="http://www.shorewall.net/"
arch="noarch"
@@ -33,4 +33,4 @@ build() {
md5sums="518a7f389a6f606c109acb7dfbe18372 shorewall-shell-4.2.11.tar.bz2
64c01bc4f57203fb877bb334994eac38 shorewall-policyrouting.patch
79745ea284a08cb167b9a356ee0bff3b shorewall-shell-ipset.patch
-48ef4d6120a012a6441d604a120fb039 shorewall-shell-providers-gateway-none.patch"
+66b7249c5c56d104f62676c175e222d3 shorewall-shell-providers-gateway-none.patch"
diff --git a/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch b/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
index 223d3d8a5..531c37ed7 100644
--- a/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
+++ b/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
@@ -25,3 +25,14 @@
elif [ "x$gateway" != "x-" -a -n "$gateway" ]; then
indent >&3 << __EOF__
run_ip route replace $gateway src \$(find_first_interface_address $interface) dev $interface table $number
+--- ./lib.providers.orig
++++ ./lib.providers
+@@ -408,7 +408,7 @@
+ save_command "#"
+ save_command "# We don't have any 'balance' providers so we retore any default route that we've saved"
+ save_command "#"
+- save_command restore_default_route
++# save_command restore_default_route
+ fi
+
+ save_command "if [ -w /etc/iproute2/rt_tables ]; then"