summaryrefslogtreecommitdiffstats
path: root/main/shotwell
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-06-16 22:06:22 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2013-06-16 22:06:47 +0200
commitfa13348690eaaeaee3a700a60add33a2349e23bd (patch)
treeda447ff75fe4cd05d010837e0a3a40d5e40b60c8 /main/shotwell
parent05d15f79bc5bba9cbd055ca9c3db4bebde47f403 (diff)
downloadaports-fa13348690eaaeaee3a700a60add33a2349e23bd.tar.bz2
aports-fa13348690eaaeaee3a700a60add33a2349e23bd.tar.xz
main/shotwell: fix build
Diffstat (limited to 'main/shotwell')
-rw-r--r--main/shotwell/APKBUILD14
-rw-r--r--main/shotwell/shotwell-0.14.1-LibRaw.patch26
-rw-r--r--main/shotwell/shotwell-libraw.patch150
3 files changed, 35 insertions, 155 deletions
diff --git a/main/shotwell/APKBUILD b/main/shotwell/APKBUILD
index 452781ce4..c42203250 100644
--- a/main/shotwell/APKBUILD
+++ b/main/shotwell/APKBUILD
@@ -14,7 +14,8 @@ makedepends="intltool vala libgee-dev libunique3-dev webkitgtk-dev libexif-dev
libgexiv2-dev libraw-dev librsvg-dev json-glib-dev
m4 gst-plugins-base1-dev bash gtk+3.0-dev rest-dev"
install=
-source="http://yorba.org/download/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz"
+source="http://yorba.org/download/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz
+ shotwell-0.14.1-LibRaw.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -22,7 +23,7 @@ prepare() {
for i in $source; do
case $i in
*.patch)
- patch -p1 -i "$srcdir"/$i || return 1
+ patch -Np0 -i "$srcdir"/$i || return 1
;;
esac
done
@@ -42,6 +43,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="bb5783f9265e1ce2d4c9f354987c3ab1 shotwell-0.14.1.tar.xz"
-sha256sums="045c4833e23374b649e735661cedbbff8368624b6719547013db2c21c8402fef shotwell-0.14.1.tar.xz"
-sha512sums="cefc5130b7fd5bd2b7d7889c5ebba01e9a447e885ece8353e42cd4cd515c068722d2460a2cdf31a94824605091c06042e086986aff8fe2dd0b589ad2a2dce20b shotwell-0.14.1.tar.xz"
+md5sums="bb5783f9265e1ce2d4c9f354987c3ab1 shotwell-0.14.1.tar.xz
+e88e1cb2c546ad5601602184d078cb0b shotwell-0.14.1-LibRaw.patch"
+sha256sums="045c4833e23374b649e735661cedbbff8368624b6719547013db2c21c8402fef shotwell-0.14.1.tar.xz
+bc8daf4a573562939fd210e0edafa8a5555099e3c213b61475b38c205d4f2fb0 shotwell-0.14.1-LibRaw.patch"
+sha512sums="cefc5130b7fd5bd2b7d7889c5ebba01e9a447e885ece8353e42cd4cd515c068722d2460a2cdf31a94824605091c06042e086986aff8fe2dd0b589ad2a2dce20b shotwell-0.14.1.tar.xz
+4db718df12bb46eab032cf59665d07e94941faeee7283cbf474e7b9be928885bd394076a88dc94cb84282610ac48b2d3b94d2525caf5f20df57b2dccbb37679d shotwell-0.14.1-LibRaw.patch"
diff --git a/main/shotwell/shotwell-0.14.1-LibRaw.patch b/main/shotwell/shotwell-0.14.1-LibRaw.patch
new file mode 100644
index 000000000..996ac60f1
--- /dev/null
+++ b/main/shotwell/shotwell-0.14.1-LibRaw.patch
@@ -0,0 +1,26 @@
+--- src/photos/GRaw.vala 2013-04-02 19:54:23.000000000 -0500
++++ src/photos/GRaw.vala 2013-05-31 07:28:54.118450454 -0500
+@@ -244,7 +244,7 @@
+ // threshold
+ output_params->half_size = half_size;
+ // four_color_rgb
+- output_params->document_mode = GRaw.DocMode.STANDARD;
++ //output_params->document_mode = GRaw.DocMode.STANDARD;
+ output_params->highlight = GRaw.HighlightMode.CLIP;
+ output_params->use_auto_wb = true;
+ output_params->use_camera_wb = true;
+--- src/photos/GRaw.vala 2013-05-31 07:30:19.000000000 -0500
++++ src/photos/GRaw.vala 2013-05-31 07:37:33.691438861 -0500
+@@ -167,9 +167,9 @@
+ throw_exception("adjust_sizes_info_only", proc.adjust_sizes_info_only());
+ }
+
+- public void document_mode_processing() throws Exception {
+- throw_exception("document_mode_processing", proc.document_mode_processing());
+- }
++ //public void document_mode_processing() throws Exception {
++ // throw_exception("document_mode_processing", proc.document_mode_processing());
++ //}
+
+ public unowned LibRaw.ImageOther get_image_other() {
+ return proc.get_image_other();
diff --git a/main/shotwell/shotwell-libraw.patch b/main/shotwell/shotwell-libraw.patch
deleted file mode 100644
index 5c2f9af75..000000000
--- a/main/shotwell/shotwell-libraw.patch
+++ /dev/null
@@ -1,150 +0,0 @@
-diff --git a/src/photos/GRaw.vala b/src/photos/GRaw.vala
-index cb32289..c2463a2 100644
---- a/src/photos/GRaw.vala
-+++ b/src/photos/GRaw.vala
-@@ -34,11 +34,11 @@ public errordomain Exception {
- OUT_OF_ORDER_CALL,
- NO_THUMBNAIL,
- UNSUPPORTED_THUMBNAIL,
-- CANNOT_ADDMASK,
- OUT_OF_MEMORY,
- DATA_ERROR,
- IO_ERROR,
- CANCELLED_BY_CALLBACK,
-+ BAD_CROP,
- SYSTEM_ERROR
- }
-
-@@ -163,10 +163,6 @@ public class Processor {
- proc = new LibRaw.Processor(options);
- }
-
-- public void add_masked_borders_to_bitmap() {
-- proc.add_masked_borders_to_bitmap();
-- }
--
- public void adjust_sizes_info_only() throws Exception {
- throw_exception("adjust_sizes_info_only", proc.adjust_sizes_info_only());
- }
-@@ -215,10 +211,6 @@ public class Processor {
- throw_exception("ppm_tiff_writer", proc.ppm_tiff_writer(filename));
- }
-
-- public void rotate_fuji_raw() throws Exception {
-- throw_exception("rotate_fuji_raw", proc.rotate_fuji_raw());
-- }
--
- public void thumb_writer(string filename) throws Exception {
- throw_exception("thumb_writer", proc.thumb_writer(filename));
- }
-@@ -262,7 +254,6 @@ public class Processor {
- // camera_profile
- // bad_pixels
- // dark_frame
-- output_params->filtering_mode = LibRaw.Filtering.AUTOMATIC;
- output_params->output_bps = 8;
- // output_tiff
- output_params->user_flip = GRaw.Flip.FROM_SOURCE;
-@@ -303,9 +294,6 @@ private void throw_exception(string caller, LibRaw.Result result) throws Excepti
- case LibRaw.Result.UNSUPPORTED_THUMBNAIL:
- throw new Exception.UNSUPPORTED_THUMBNAIL(msg);
-
-- case LibRaw.Result.CANNOT_ADDMASK:
-- throw new Exception.CANNOT_ADDMASK(msg);
--
- case LibRaw.Result.UNSUFFICIENT_MEMORY:
- throw new Exception.OUT_OF_MEMORY(msg);
-
-@@ -318,6 +306,9 @@ private void throw_exception(string caller, LibRaw.Result result) throws Excepti
- case LibRaw.Result.CANCELLED_BY_CALLBACK:
- throw new Exception.CANCELLED_BY_CALLBACK(msg);
-
-+ case LibRaw.Result.BAD_CROP:
-+ throw new Exception.BAD_CROP(msg);
-+
- default:
- return;
- }
-diff --git a/vapi/libraw.vapi b/vapi/libraw.vapi
-index 55f35cf..a7af4af 100644
---- a/vapi/libraw.vapi
-+++ b/vapi/libraw.vapi
-@@ -14,17 +14,6 @@ public unowned string version();
-
- public unowned string versionNumber();
-
--[CCode (cname="enum libraw_Filtering", cprefix="LIBRAW_FILTERING_")]
--public enum Filtering {
-- DEFAULT,
-- NOZEROES,
-- NOBLACK,
-- NORAWCURVE,
-- NONE,
-- LIBRAWOWN,
-- AUTOMATIC
--}
--
- [SimpleType]
- [CCode (cname="libraw_imgother_t")]
- public struct ImageOther {
-@@ -121,7 +110,6 @@ public struct OutputParams {
- public bool use_camera_wb;
- public bool use_camera_matrix;
- public int output_color;
-- public Filtering filtering_mode;
- public int output_bps;
- public bool output_tiff;
- public int user_flip;
-@@ -132,6 +120,30 @@ public struct OutputParams {
- public bool no_auto_bright;
- public float auto_bright_thr;
- public int use_fuji_rotate;
-+ public int green_matching;
-+
-+ /* DCB parameters */
-+ public int dcb_iterations;
-+ public int dcb_enhance_fl;
-+ public int fbdd_noiserd;
-+
-+ /* VCD parameters */
-+ public int eeci_refine;
-+ public int es_med_passes;
-+ /* AMaZE*/
-+ public int ca_correc;
-+ public float cared;
-+ public float cablue;
-+ public int cfaline;
-+ public float linenoise;
-+ public int cfa_clean;
-+ public float lclean;
-+ public float cclean;
-+ public int cfa_green;
-+ public float green_thresh;
-+ public int exp_correc;
-+ public float exp_shift;
-+ public float exp_preser;
-
- public void set_chromatic_aberrations(double red_multiplier, double green_multiplier) {
- aber[0] = red_multiplier;
-@@ -171,7 +183,6 @@ public class Processor {
- [CCode (cname="libraw_init")]
- public Processor(Options flags = Options.NONE);
-
-- public void add_masked_borders_to_bitmap();
- public Result adjust_sizes_info_only();
- [CCode (cname="libraw_dcraw_document_mode_processing")]
- public Result document_mode_processing();
-@@ -216,11 +227,11 @@ public enum Result {
- OUT_OF_ORDER_CALL,
- NO_THUMBNAIL,
- UNSUPPORTED_THUMBNAIL,
-- CANNOT_ADDMASK,
- UNSUFFICIENT_MEMORY,
- DATA_ERROR,
- IO_ERROR,
-- CANCELLED_BY_CALLBACK;
-+ CANCELLED_BY_CALLBACK,
-+ BAD_CROP;
-
- [CCode (cname="LIBRAW_FATAL_ERROR")]
- public bool is_fatal_error();