summaryrefslogtreecommitdiffstats
path: root/main/sipp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-09-18 12:35:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-18 12:35:15 +0000
commita1ed52578e18f6560c21d6c92c1c51213dd1503a (patch)
treee5bc22e69d21df32f55cf522ad37640c0d268a20 /main/sipp
parent9b2883e30dbbbee4cbd60c2bdeec4e1fd2882efc (diff)
downloadaports-a1ed52578e18f6560c21d6c92c1c51213dd1503a.tar.bz2
aports-a1ed52578e18f6560c21d6c92c1c51213dd1503a.tar.xz
main/sipp: moved from testing
Diffstat (limited to 'main/sipp')
-rw-r--r--main/sipp/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/sipp/APKBUILD b/main/sipp/APKBUILD
new file mode 100644
index 000000000..6a7dda1ee
--- /dev/null
+++ b/main/sipp/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Robert Boisvert <rdboisvert@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=sipp
+pkgver=3.3
+pkgrel=1
+pkgdesc="A test tool / traffic generator for the SIP protocol"
+url="http://sipp.sourceforge.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="autoconf automake openssl-dev libpcap-dev ncurses-dev lksctp-tools-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ autoreconf -ivf
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-openssl \
+ --with-pcap \
+ --with-sctp \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/share/"$pkgname"
+ install -m444 -D pcap/* "$pkgdir"/usr/share/"$pkgname"/
+}
+
+md5sums="8c1d513423f9dabee799e738b737e311 sipp-3.3.tar.gz"
+sha256sums="17fd02e6aa71d44a90c65e84a1aa39d3aa329990d4aa48e4fb4b895304dbc920 sipp-3.3.tar.gz"
+sha512sums="ab42a71426ae381b9cd1f36e1d64d5c4bfccc1359973e1909f9e9d0ce3b3a4391056250371708b12be0e7de998e88b9224c9f307b1d2ce437942103b6ad10d2b sipp-3.3.tar.gz"