summaryrefslogtreecommitdiffstats
path: root/main/smokeping
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-19 12:46:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-19 12:46:02 +0000
commit0396fe7e601e603614e8a128b6474cbc145134d5 (patch)
tree237c3b43cd813845c2b56905ac1d1e6cc54cc75f /main/smokeping
parentd2c01f95447c189e44f7761c6051e7ecd15f9421 (diff)
downloadaports-0396fe7e601e603614e8a128b6474cbc145134d5.tar.bz2
aports-0396fe7e601e603614e8a128b6474cbc145134d5.tar.xz
main/smokeping: init.d fixes
- replace opts. ref #943 - start after firewall
Diffstat (limited to 'main/smokeping')
-rw-r--r--main/smokeping/APKBUILD4
-rw-r--r--main/smokeping/smokeping.initd12
2 files changed, 5 insertions, 11 deletions
diff --git a/main/smokeping/APKBUILD b/main/smokeping/APKBUILD
index 163b72fc5..22c465a39 100644
--- a/main/smokeping/APKBUILD
+++ b/main/smokeping/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=smokeping
pkgver=2.6.1
-pkgrel=5
+pkgrel=6
pkgdesc="Smokeping network latency monitoring"
pkgusers="smokeping"
pkggroups="smokeping"
@@ -129,7 +129,7 @@ package() {
}
md5sums="f4a5437b71e02f982f08bf318bb9857d smokeping-2.6.1.tar.gz
-38fe448bd14ebfb2a22dbd9fc98a59e7 smokeping.initd
+a63b42b8165f9c728706ac112658548b smokeping.initd
b3f3c968c582adb9e4e0fdcc9c7163e9 0001-fix-sysconfdir-in-etc.patch
2bdafaade171bfb2241d1e6450fb094a 0002-fix-sysconfdir-in-doc.patch
1942e4eceecb80b4bbe4cfc95e3e642f 0003-fix-sysconfdir-in-lib.patch
diff --git a/main/smokeping/smokeping.initd b/main/smokeping/smokeping.initd
index 5a21fecd6..159e54948 100644
--- a/main/smokeping/smokeping.initd
+++ b/main/smokeping/smokeping.initd
@@ -2,11 +2,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-opts="${opts} dump reload restore"
+extra_started_commands="reload"
+extra_stopped_commands="dump restore"
depend() {
need net
use dns
+ after firewall
}
checkconfig() {
@@ -48,10 +50,6 @@ reload() {
dump() {
ebegin "Dumping smokeping rrd files to XML for backup or upgrade use"
- if service_started "${myservice}" ; then
- eerror "You need to stop smokeping before dumping files!"
- return 1
- fi
for f in `find /var/lib/smokeping -name '*.rrd' -print` ; do
f_xml=`dirname $f`/`basename $f .rrd`.xml
rrdtool dump "$f" > "${f_xml}"
@@ -62,10 +60,6 @@ dump() {
restore() {
ebegin "Restoring smokeping rrd files from XML dump files"
- if service_started "${myservice}" ; then
- eerror "You need to stop smokeping before restoring files!"
- return 1
- fi
for f in `find /var/lib/smokeping -name '*.xml' -print` ; do
f_rrd=`dirname $f`/`basename $f .xml`.rrd
mv -f "${f_rrd}" "${f_rrd}.bak"