summaryrefslogtreecommitdiffstats
path: root/main/smokeping
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-14 08:32:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-14 08:33:24 +0000
commit8766dc4e2edda9c665dcb54d7a4f561bb5d623fc (patch)
tree059ed9bbf8f903b1fa85684cae44792746ffbc08 /main/smokeping
parentafefb2d592d3dc40ce683d4dd1b9dc09d8ac478d (diff)
downloadaports-8766dc4e2edda9c665dcb54d7a4f561bb5d623fc.tar.bz2
aports-8766dc4e2edda9c665dcb54d7a4f561bb5d623fc.tar.xz
main/smokeping: fix build with musl
Diffstat (limited to 'main/smokeping')
-rw-r--r--main/smokeping/APKBUILD6
-rw-r--r--main/smokeping/musl-lc_numeric-utf8.patch15
2 files changed, 20 insertions, 1 deletions
diff --git a/main/smokeping/APKBUILD b/main/smokeping/APKBUILD
index 32f828121..ac0b50c33 100644
--- a/main/smokeping/APKBUILD
+++ b/main/smokeping/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=smokeping
pkgver=2.6.9
-pkgrel=0
+pkgrel=1
pkgdesc="Smokeping network latency monitoring"
pkgusers="smokeping"
pkggroups="smokeping"
@@ -11,6 +11,7 @@ url="http://oss.oetiker.ch/smokeping/"
source="http://oss.oetiker.ch/smokeping/pub/smokeping-$pkgver.tar.gz
smokeping.initd
smokeping-perl-5.18.patch
+ musl-lc_numeric-utf8.patch
xss-fix-from-Steven-Chamberlain.patch"
depends="perl fping rrdtool perl-rrd
perl-uri
@@ -133,12 +134,15 @@ package() {
md5sums="0c2361b734866dd37facf2af3f8f7144 smokeping-2.6.9.tar.gz
a63b42b8165f9c728706ac112658548b smokeping.initd
d6aaecc3110968671248b7bebbdb087b smokeping-perl-5.18.patch
+5b0bac1be9c63c1f36ff7c2979af4317 musl-lc_numeric-utf8.patch
cee64c8fe5d813534dfb29c2cd3a1324 xss-fix-from-Steven-Chamberlain.patch"
sha256sums="cd551d4384d8b19879d128ea0566bd680c19bb4ad8664a3c5a304604746f8863 smokeping-2.6.9.tar.gz
1b83d2e35e922e71bb3c91deee7c247cfbaebe47022451aabde87b790c5a61ca smokeping.initd
961bcb8979de2ff508c988d79f8b54bb936fc29ed8bf28c6377458c12a1e3f2f smokeping-perl-5.18.patch
+5cb6dd9ce63446b5cfc3f1bba9e39fb91a6d18c512e5a7e153bb6007660466dd musl-lc_numeric-utf8.patch
f7750494a81e56dac2d8c7bc996eb63ac590168fff92d237e883807c036f07ac xss-fix-from-Steven-Chamberlain.patch"
sha512sums="ab3cec15fd9f90510f902da7ce5bac5915558cac198cc88f0ce193a53a0158c9055e28c8c6671cc6653ac42ab51346e1eb19e537f1ab5c234fd498c6b777499d smokeping-2.6.9.tar.gz
b1d6f769b870a14856f4e4f6e699d6a9eb7744d9c447e5cd799cf21dd1eb83807aaa270029e15a49c709e8a9160c395d264bcc1d3281233160e2a907e61473ad smokeping.initd
8b415778970ca9093fb8847cb391aea2546041512496e2f74e755358f2d6dd0a9e6e332c8a9c90a09da5f3eeeb4aabd3f1e188c1d63e324a17ee06f20e259ca2 smokeping-perl-5.18.patch
+e6bc389d8edbc000f5ad65848308197b3eb1ddb24bfa9df9c05fa027103952484383b7e021bea86795dceccdcf3f3d51a24c22cae3a68dc5afa30a72b2dbf803 musl-lc_numeric-utf8.patch
ab13cbf69a8b7d9cce7684eaf6a61ff5d827bcd4abc04cec7df47a97ab4d73eac5034addcb8e061ced246a2dcff69d04a9114b89e6c20014e2f3eb6c8fff0c11 xss-fix-from-Steven-Chamberlain.patch"
diff --git a/main/smokeping/musl-lc_numeric-utf8.patch b/main/smokeping/musl-lc_numeric-utf8.patch
new file mode 100644
index 000000000..bb702299e
--- /dev/null
+++ b/main/smokeping/musl-lc_numeric-utf8.patch
@@ -0,0 +1,15 @@
+The local is returned as C.UTF-8 on musl which should be ok for numeric
+operations.
+
+--- ./lib/Smokeping.pm.orig
++++ ./lib/Smokeping.pm
+@@ -31,7 +31,8 @@
+ my $xssBadRx = qr/[<>%&'";]/;
+
+ $ENV{'LC_NUMERIC'}='C';
+-if (setlocale(LC_NUMERIC,"") ne "C") {
++my $lc_numeric = setlocale(LC_NUMERIC,"");
++if ($lc_numeric ne "C" && ! $lc_numeric =~ m/^C\./) {
+ if ($ENV{'LC_ALL'} eq 'C') {
+ # This has got to be a bug in perl/mod_perl, apache or libc
+ die("Your internalization implementation on your operating system is "