summaryrefslogtreecommitdiffstats
path: root/main/sqlite
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-13 10:41:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-13 10:41:53 +0000
commit561b3503e3ea37da4589e573d4bfbec004b8f543 (patch)
tree4bd573b0232796c5b1655c5472a08846758e6302 /main/sqlite
parent1ae19df2b98aef5cf89a25eeed2846f52572527b (diff)
downloadaports-561b3503e3ea37da4589e573d4bfbec004b8f543.tar.bz2
aports-561b3503e3ea37da4589e573d4bfbec004b8f543.tar.xz
main/sqlite: upgrade to 3.7.4
Diffstat (limited to 'main/sqlite')
-rw-r--r--main/sqlite/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/main/sqlite/APKBUILD b/main/sqlite/APKBUILD
index 3de3ada99..e614ce4bb 100644
--- a/main/sqlite/APKBUILD
+++ b/main/sqlite/APKBUILD
@@ -1,18 +1,23 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=sqlite
-pkgver=3.7.3
+pkgver=3.7.4
+_x=${pkgver%%.*}
+_y=${pkgver%.*}
+_y=${_y#*.}
+_z=${pkgver##*.}
+_ver=${_x}0${_y}0${_z}00
pkgrel=0
pkgdesc="A C library that implements an SQL database engine"
url="http://www.sqlite.org/"
license="custom"
depends=""
makedepends="tcl"
-source="http://www.sqlite.org/$pkgname-$pkgver.tar.gz
+source="http://www.sqlite.org/$pkgname-autoconf-$_ver.tar.gz
license.txt"
subpackages="$pkgname-doc $pkgname-dev"
-_builddir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-autoconf-$_ver
prepare() {
cd "$_builddir"
}
@@ -21,7 +26,6 @@ build() {
cd "$_builddir"
export LTLINK_EXTRAS="-ldl"
export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_ENABLE_FTS3_PARENTHESIS -Iext/fts3"
-
./configure --prefix=/usr \
--enable-threadsafe \
--enable-load-extension \
@@ -44,5 +48,5 @@ package() {
install -Dm644 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
}
-md5sums="5437978aae90350cf984993091e0d695 sqlite-3.7.3.tar.gz
+md5sums="8f0c690bfb33c3cbbc2471c3d9ba0158 sqlite-autoconf-3070400.tar.gz
c1cdbc5544034d9012e421e75a5e4890 license.txt"