summaryrefslogtreecommitdiffstats
path: root/main/squashfs-tools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-21 20:19:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-21 20:20:41 +0000
commit972f4cacc1f201eaa440d2b9f91f8a47033f6543 (patch)
treeff9d88a708ceff6f9b7ab9eb001c176f97bcc03c /main/squashfs-tools
parent5b326f5f674f1f5374d6c7264cb16809688e3ea5 (diff)
downloadaports-972f4cacc1f201eaa440d2b9f91f8a47033f6543.tar.bz2
aports-972f4cacc1f201eaa440d2b9f91f8a47033f6543.tar.xz
main/squashfs-tools: upgrade to 4.1
Diffstat (limited to 'main/squashfs-tools')
-rw-r--r--main/squashfs-tools/APKBUILD14
-rw-r--r--main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch22
2 files changed, 5 insertions, 31 deletions
diff --git a/main/squashfs-tools/APKBUILD b/main/squashfs-tools/APKBUILD
index f5ac12c8d..9b8332405 100644
--- a/main/squashfs-tools/APKBUILD
+++ b/main/squashfs-tools/APKBUILD
@@ -1,19 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=squashfs-tools
-pkgver=4.0
-pkgrel=1
+pkgver=4.1
+pkgrel=0
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="http://squashfs.sourceforge.net"
license="GPL"
depends=
-makedepends="zlib-dev"
-source="http://downloads.sourceforge.net/sourceforge/squashfs/squashfs$pkgver.tar.gz
- squashfs-tools-4.0-uclibc-get_nprocs.patch"
+makedepends="zlib-dev attr-dev"
+source="http://downloads.sourceforge.net/sourceforge/squashfs/squashfs$pkgver.tar.gz"
build() {
cd "$srcdir"/squashfs$pkgver/$pkgname
- patch -p2 -i "$srcdir"/squashfs-tools-4.0-uclibc-get_nprocs.patch \
- || return 1
make
}
@@ -22,5 +19,4 @@ package() {
mkdir -p "$pkgdir"/sbin
cp -a mksquashfs unsquashfs "$pkgdir"/sbin
}
-md5sums="a3c23391da4ebab0ac4a75021ddabf96 squashfs4.0.tar.gz
-761580c100eeffb60ebbda62d724bd3f squashfs-tools-4.0-uclibc-get_nprocs.patch"
+md5sums="8e1b2b96f5d5f3fe48fef226ae8cd341 squashfs4.1.tar.gz"
diff --git a/main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch b/main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch
deleted file mode 100644
index 9c6312f16..000000000
--- a/main/squashfs-tools/squashfs-tools-4.0-uclibc-get_nprocs.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/squashfs-tools/mksquashfs.c Wed Dec 2 10:30:31 2009
-+++ b/squashfs-tools/mksquashfs.c Wed Dec 2 10:31:34 2009
-@@ -3705,7 +3705,7 @@
- processors = 1;
- }
- #else
-- processors = get_nprocs();
-+ processors = sysconf(_SC_NPROCESSORS_ONLN);
- #endif
- }
-
---- a/squashfs-tools/unsquashfs.c Wed Dec 2 10:30:31 2009
-+++ b/squashfs-tools/unsquashfs.c Wed Dec 2 10:31:34 2009
-@@ -1811,7 +1811,7 @@
- processors = 1;
- }
- #else
-- processors = get_nprocs();
-+ processors = sysconf(_SC_NPROCESSORS_ONLN);
- #endif
- }
-