summaryrefslogtreecommitdiffstats
path: root/main/strace
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-20 14:33:39 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-20 14:33:39 +0000
commit450091c812044a2d9de51a69499f2c6f1ead9dee (patch)
treefcf2c7f77e05b5d8ccaf9a0dff38ed44ef6ade39 /main/strace
parente53afc7d2fac85802f1423c92b0be9f89537b0df (diff)
downloadaports-450091c812044a2d9de51a69499f2c6f1ead9dee.tar.bz2
aports-450091c812044a2d9de51a69499f2c6f1ead9dee.tar.xz
main/strace: fix musl patch to not break glibc/uclibc build
Diffstat (limited to 'main/strace')
-rw-r--r--main/strace/APKBUILD6
-rw-r--r--main/strace/strace-musl.patch66
2 files changed, 27 insertions, 45 deletions
diff --git a/main/strace/APKBUILD b/main/strace/APKBUILD
index 786581f75..58bb8fc3b 100644
--- a/main/strace/APKBUILD
+++ b/main/strace/APKBUILD
@@ -43,8 +43,8 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
md5sums="c575ef43829586801f514fd91bfe7575 strace-4.8.tar.xz
-7a27c8df5e5706da84cc245016d903a8 strace-musl.patch"
+fc85884e1534d30fa9f1e40d7d4cea3a strace-musl.patch"
sha256sums="f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8 strace-4.8.tar.xz
-3bc11f19513abea2c21c71e89f715179e663d8ded7aaf84e0b926ac57478809d strace-musl.patch"
+40415d739a86b300f93deead48fe08e0cc79bc7af9f3575b151c5b84b6619848 strace-musl.patch"
sha512sums="c3316382f60cd4d02eec1eef46a0ef2d000afbccf2c176a6fec652e1b3391685f0e33f184497cb3ccf54d72d460471a4945d3a864fb5bce1f45f32fdf132cfe3 strace-4.8.tar.xz
-7cdb95e409bf7f2a16d5abc1a551dafed9d46dbed1b6bfaa4f6b6331eda98d119cc0c6b93072af1c97d4618737383a4da116111264ab4298ce47f13f575d5193 strace-musl.patch"
+e8b1d7eb5be1779492a3633d8559d7c17bb1fb185068a0ec21c3d451ba048ca9813a93a46d1abadbc4231ef00feb72b6b72c56dd0621ede2d64a9789c5e74507 strace-musl.patch"
diff --git a/main/strace/strace-musl.patch b/main/strace/strace-musl.patch
index 46935b137..746d9cb6a 100644
--- a/main/strace/strace-musl.patch
+++ b/main/strace/strace-musl.patch
@@ -1,7 +1,6 @@
-Binary files strace-4.8.orig/count.o and strace-4.8/count.o differ
-diff -x '*Po' -ru strace-4.8.orig/defs.h strace-4.8/defs.h
+diff -ru strace-4.8.orig/defs.h strace-4.8/defs.h
--- strace-4.8.orig/defs.h 2013-05-14 14:10:42.000000000 +0000
-+++ strace-4.8/defs.h 2013-09-10 16:34:31.319995356 +0000
++++ strace-4.8/defs.h 2013-09-20 14:30:38.785856744 +0000
@@ -155,7 +155,7 @@
|| defined(METAG) \
|| defined(TILE) \
@@ -20,9 +19,9 @@ diff -x '*Po' -ru strace-4.8.orig/defs.h strace-4.8/defs.h
# define PTRACE_PEEKUSER PTRACE_PEEKUSR
# define PTRACE_POKEUSER PTRACE_POKEUSR
#endif
-diff -x '*Po' -ru strace-4.8.orig/desc.c strace-4.8/desc.c
+diff -ru strace-4.8.orig/desc.c strace-4.8/desc.c
--- strace-4.8.orig/desc.c 2013-05-01 22:39:10.000000000 +0000
-+++ strace-4.8/desc.c 2013-09-10 16:26:58.639995444 +0000
++++ strace-4.8/desc.c 2013-09-20 14:30:38.795856744 +0000
@@ -299,7 +299,7 @@
#ifdef X32
tprintf(", start=%lld, len=%lld", fl.l_start, fl.l_len);
@@ -32,10 +31,9 @@ diff -x '*Po' -ru strace-4.8.orig/desc.c strace-4.8/desc.c
#endif
if (getlk)
tprintf(", pid=%lu}", (unsigned long) fl.l_pid);
-Binary files strace-4.8.orig/desc.o and strace-4.8/desc.o differ
-diff -x '*Po' -ru strace-4.8.orig/file.c strace-4.8/file.c
+diff -ru strace-4.8.orig/file.c strace-4.8/file.c
--- strace-4.8.orig/file.c 2013-05-06 18:23:01.000000000 +0000
-+++ strace-4.8/file.c 2013-09-11 06:12:07.569985853 +0000
++++ strace-4.8/file.c 2013-09-20 14:30:38.795856744 +0000
@@ -632,7 +632,7 @@
return 0;
}
@@ -63,11 +61,9 @@ diff -x '*Po' -ru strace-4.8.orig/file.c strace-4.8/file.c
int
sys_getdents64(struct tcb *tcp)
{
-Binary files strace-4.8.orig/file.o and strace-4.8/file.o differ
-Binary files strace-4.8.orig/mem.o and strace-4.8/mem.o differ
-diff -x '*Po' -ru strace-4.8.orig/net.c strace-4.8/net.c
+diff -ru strace-4.8.orig/net.c strace-4.8/net.c
--- strace-4.8.orig/net.c 2013-05-17 22:20:02.000000000 +0000
-+++ strace-4.8/net.c 2013-09-10 16:21:10.969995511 +0000
++++ strace-4.8/net.c 2013-09-20 14:30:38.805856744 +0000
@@ -95,12 +95,14 @@
#endif
@@ -83,11 +79,9 @@ diff -x '*Po' -ru strace-4.8.orig/net.c strace-4.8/net.c
static const struct xlat domains[] = {
#ifdef PF_UNSPEC
-Only in strace-4.8: net.o
-Only in strace-4.8: pathtrace.o
-diff -x '*Po' -ru strace-4.8.orig/process.c strace-4.8/process.c
+diff -ru strace-4.8.orig/process.c strace-4.8/process.c
--- strace-4.8.orig/process.c 2013-05-17 22:22:19.000000000 +0000
-+++ strace-4.8/process.c 2013-09-10 16:25:04.069995466 +0000
++++ strace-4.8/process.c 2013-09-20 14:30:38.805856744 +0000
@@ -2857,7 +2857,7 @@
if (umove(tcp, tcp->u_arg[2], &p) < 0)
tprintf(", %#lx", tcp->u_arg[2]);
@@ -115,13 +109,9 @@ diff -x '*Po' -ru strace-4.8.orig/process.c strace-4.8/process.c
}
return 0;
}
-Only in strace-4.8: process.o
-Only in strace-4.8: quota.o
-Only in strace-4.8: resource.o
-Only in strace-4.8: scsi.o
-diff -x '*Po' -ru strace-4.8.orig/signal.c strace-4.8/signal.c
+diff -ru strace-4.8.orig/signal.c strace-4.8/signal.c
--- strace-4.8.orig/signal.c 2013-05-23 13:41:23.000000000 +0000
-+++ strace-4.8/signal.c 2013-09-10 16:32:38.429995378 +0000
++++ strace-4.8/signal.c 2013-09-20 14:30:38.815856744 +0000
@@ -59,6 +59,7 @@
#ifdef IA64
# include <asm/ptrace_offsets.h>
@@ -130,12 +120,9 @@ diff -x '*Po' -ru strace-4.8.orig/signal.c strace-4.8/signal.c
#if defined(SPARC) || defined(SPARC64) || defined(MIPS)
typedef struct {
-Only in strace-4.8: signal.o
-Only in strace-4.8: sock.o
-Only in strace-4.8: strace
-diff -x '*Po' -ru strace-4.8.orig/strace.c strace-4.8/strace.c
+diff -ru strace-4.8.orig/strace.c strace-4.8/strace.c
--- strace-4.8.orig/strace.c 2013-05-28 21:49:16.000000000 +0000
-+++ strace-4.8/strace.c 2013-09-10 16:31:07.969995395 +0000
++++ strace-4.8/strace.c 2013-09-20 14:30:38.815856744 +0000
@@ -506,7 +506,7 @@
perror_msg_and_die("dup2");
close(fds[0]);
@@ -145,11 +132,9 @@ diff -x '*Po' -ru strace-4.8.orig/strace.c strace-4.8/strace.c
perror_msg_and_die("Can't execute '%s'", _PATH_BSHELL);
}
-Only in strace-4.8: strace.o
-Only in strace-4.8: stream.o
-diff -x '*Po' -ru strace-4.8.orig/syscall.c strace-4.8/syscall.c
+diff -ru strace-4.8.orig/syscall.c strace-4.8/syscall.c
--- strace-4.8.orig/syscall.c 2013-05-14 14:10:42.000000000 +0000
-+++ strace-4.8/syscall.c 2013-09-10 16:32:21.969995381 +0000
++++ strace-4.8/syscall.c 2013-09-20 14:30:38.825856744 +0000
@@ -72,13 +72,7 @@
# include <elf.h>
#endif
@@ -165,21 +150,18 @@ diff -x '*Po' -ru strace-4.8.orig/syscall.c strace-4.8/syscall.c
#ifndef ERESTARTSYS
# define ERESTARTSYS 512
-Only in strace-4.8: syscall.o
-Only in strace-4.8: system.o
-Only in strace-4.8: term.o
-diff -x '*Po' -ru strace-4.8.orig/time.c strace-4.8/time.c
+diff -ru strace-4.8.orig/time.c strace-4.8/time.c
--- strace-4.8.orig/time.c 2012-05-01 21:17:51.000000000 +0000
-+++ strace-4.8/time.c 2013-09-10 16:36:36.469995332 +0000
-@@ -774,7 +774,7 @@
++++ strace-4.8/time.c 2013-09-20 14:32:49.165856719 +0000
+@@ -774,7 +774,11 @@
/* _pad[0] is the _tid field which might not be
present in the userlevel definition of the
struct. */
-- tprintf("{%d}", sev._sigev_un._pad[0]);
-+ tprintf("{%d}", (int) sev.__pad[0]);
++#if defined(__GLIBC__)
+ tprintf("{%d}", sev._sigev_un._pad[0]);
++#else
++ tprintf("{%d}", (int) sev._pad[0]);
++#endif
else if (sev.sigev_notify == SIGEV_THREAD)
tprintf("{%p, %p}", sev.sigev_notify_function,
sev.sigev_notify_attributes);
-Only in strace-4.8: time.o
-Only in strace-4.8: util.o
-Only in strace-4.8: vsprintf.o