summaryrefslogtreecommitdiffstats
path: root/main/syslinux
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-30 12:51:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-30 12:53:03 +0000
commit1b50a0c4feb3bb6e080ccde6c962f116a7432d7d (patch)
tree2bf879d0a37c30026711fe3d3a361207e477cf33 /main/syslinux
parent88b3c34113eb72af5c755395537cdc08e4fb9cf0 (diff)
downloadaports-1b50a0c4feb3bb6e080ccde6c962f116a7432d7d.tar.bz2
aports-1b50a0c4feb3bb6e080ccde6c962f116a7432d7d.tar.xz
main/syslinux: update-extlinux: autodetect poweroff.c32
and trivial fix for comment in conf
Diffstat (limited to 'main/syslinux')
-rw-r--r--main/syslinux/APKBUILD14
-rwxr-xr-xmain/syslinux/update-extlinux15
-rw-r--r--main/syslinux/update-extlinux.conf2
3 files changed, 17 insertions, 14 deletions
diff --git a/main/syslinux/APKBUILD b/main/syslinux/APKBUILD
index b10cef1f9..d853f64da 100644
--- a/main/syslinux/APKBUILD
+++ b/main/syslinux/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
pkgver=5.10
-pkgrel=2
+pkgrel=3
_ver=${pkgver/_/-}
pkgdesc="Boot loader for the Linux operating system"
url="http://syslinux.org"
@@ -48,11 +48,11 @@ package() {
}
md5sums="67c8a85ca275d13b4f7f6139dd47d999 syslinux-5.10.tar.xz
-51df240c4da940cfb52cd8f31876402f update-extlinux.conf
-a7fc8fa30d7ae47e27ef15923ab3d05a update-extlinux"
+eecad085e8e923350d85cef181d6dd53 update-extlinux.conf
+89fb72c4dd47516402bc91a3cdf2b4d5 update-extlinux"
sha256sums="4b52d7647d5584c69764c06a836e0d524e5246bf2e94f68cf86342c415508422 syslinux-5.10.tar.xz
-8a626b74355b54f5a538b5e42094955987a7ca547d8b2a78797a5e3ca11cff1f update-extlinux.conf
-b54eb30280875e101623e362921b89cfe641648c14502aa1f5e04f9a52c492d4 update-extlinux"
+a1ec8055cc2e67f997d29e46fa568af8cb64eea061cc1ba3ddc2ff661854bd39 update-extlinux.conf
+0dce3d534ab4288872c7654d7408d35896f508d486ad7d02cdaaf5fee37f6ae5 update-extlinux"
sha512sums="56422e14b4aa53ca1a5811da0582dbbb349aa52b9e78868bbedc24c67ef2420c4d0ac63fd68c7f0adc2c22606196276265d503b5b6f9d3d796d9ce42845bbdb5 syslinux-5.10.tar.xz
-28f828f81abe183b4206438af639649391c54db4514cae426bba2635b195f6e3f95500df63b8e7085fe9c909139518e64e73c69e75273b0ccdf4f876b38875a5 update-extlinux.conf
-4e929064fee5b76384608e426d689d536f705304a3998b0044882d03d79f8cc1f4a7be1a1e9b3690a1d2a3cba1ef5dca2989bb6d0223402770741be6de7bbce0 update-extlinux"
+0899fdf40c9999ebe58355d4cade793fc35dd320971190018217afdadafa930f38dc25c91e0b991d89e8e6018bd6c5185eeb15a84be4e31bcbfcccecfdc2a494 update-extlinux.conf
+848940244b9547c8d5d721b494cda199ea5785e306e8ac2124640f89ba7837d4a6e3a9a09fd2c5cd662d3ba66c5f81fcb1ec1f52fae9fade45b1ff10d7fc2b61 update-extlinux"
diff --git a/main/syslinux/update-extlinux b/main/syslinux/update-extlinux
index 43a602ee0..26eb4c70b 100755
--- a/main/syslinux/update-extlinux
+++ b/main/syslinux/update-extlinux
@@ -171,13 +171,16 @@ elif [ -f "/boot/memtest" ]; then
echo "" >> $conf.new
fi
-if [ -f "/boot/reboot.c32" ]; then
- everbose "Found reboot"
- echo "LABEL reboot" >> $conf.new
- echo " MENU LABEL Reboot" >> $conf.new
- echo " COM32 reboot.c32" >> $conf.new
+for i in reboot poweroff; do
+ [ -f "/boot/$i.c32" ] || continue
+ everbose "Found $i"
+ # make first char capital
+ cap=$( echo $i | awk '{sub(".", substr(toupper($0),1,1), $0); print}' )
+ echo "LABEL $i" >> $conf.new
+ echo " MENU LABEL $cap" >> $conf.new
+ echo " COM32 $i.c32" >> $conf.new
echo "" >> $conf.new
-fi
+done
if cmp -s $conf.new $conf; then
everbose "Configuration unchanged."
diff --git a/main/syslinux/update-extlinux.conf b/main/syslinux/update-extlinux.conf
index 80eb5f13f..49ad8a46e 100644
--- a/main/syslinux/update-extlinux.conf
+++ b/main/syslinux/update-extlinux.conf
@@ -53,7 +53,7 @@ xen_opts=dom0_mem=256M
# will use it, else a separate menu entry will be auto-generated for
# memtest
-# optional passwd
+# optional password
# you can generate a SHA512 password using: mkpasswd
#
# if you assign a password, you should make this file world-unreadable