summaryrefslogtreecommitdiffstats
path: root/main/thunar-vcs-plugin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-29 11:50:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-29 11:50:12 +0000
commit2496e67d5cde9f474cb176f8b88737283dd519b8 (patch)
treee168d8647ff361ad50eef3d3c1278a281818c28e /main/thunar-vcs-plugin
parentd052cd88466dc7d0dcd10d8ca35deb5bafa7c4fa (diff)
downloadaports-2496e67d5cde9f474cb176f8b88737283dd519b8.tar.bz2
aports-2496e67d5cde9f474cb176f8b88737283dd519b8.tar.xz
main/thunar-vcs-plugin: moved from testing
Diffstat (limited to 'main/thunar-vcs-plugin')
-rw-r--r--main/thunar-vcs-plugin/APKBUILD72
1 files changed, 72 insertions, 0 deletions
diff --git a/main/thunar-vcs-plugin/APKBUILD b/main/thunar-vcs-plugin/APKBUILD
new file mode 100644
index 000000000..a91443366
--- /dev/null
+++ b/main/thunar-vcs-plugin/APKBUILD
@@ -0,0 +1,72 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=thunar-vcs-plugin
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Version Contol System plugin for the Thunar filemanager"
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+arch="all"
+license="GPLv2+"
+depends=
+makedepends="thunar-dev subversion-dev apr-dev util-linux-ng-dev"
+install=""
+subpackages="$pkgname-git:_git $pkgname-svn:_svn"
+source="http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/thunar-vcs-plugin-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ # quick and dirty fix for apr linking
+ sed -i -e 's/APR_LDFLAGS/APR_LIBS/' thunar-vcs-plugin/Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/xfce4 \
+ --disable-static \
+ --enable-subversion \
+ --enable-git \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/thunarx-*/*.la
+}
+
+_mv_files() {
+ local i
+ for i in "$@"; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ done
+}
+
+_git() {
+ pkgdesc="Git support for thunar-vcs-plugin"
+ depends=
+ install_if="thunar-vcs-plugin git"
+ cd "$pkgdir"
+ _mv_files usr/lib/xfce4/tvp-git-helper \
+ usr/share/icons/hicolor/*/apps/git.png
+}
+
+_svn() {
+ pkgdesc="Subversion support for thunar-vcs-plugin"
+ depends=
+ install_if="thunar-vcs-plugin subversion"
+ cd "$pkgdir"
+ _mv_files usr/lib/xfce4/tvp-svn-helper \
+ usr/share/icons/hicolor/*/apps/subversion.png
+}
+
+md5sums="b2321096c706e42b85987f0114ab73bc thunar-vcs-plugin-0.1.4.tar.bz2"