summaryrefslogtreecommitdiffstats
path: root/main/thunar
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-20 06:54:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-20 07:16:47 +0000
commitf7108a52947196e71078ba32ad93ede3b607db1e (patch)
treeb8f048fd8e5668ab0a677deb0f5f931703cb96f0 /main/thunar
parent443af6fbde8be65de45228a926e021f8be852d39 (diff)
downloadaports-f7108a52947196e71078ba32ad93ede3b607db1e.tar.bz2
aports-f7108a52947196e71078ba32ad93ede3b607db1e.tar.xz
main/thunar: upgrade to 1.3.0
Diffstat (limited to 'main/thunar')
-rw-r--r--main/thunar/APKBUILD36
-rw-r--r--main/thunar/thunar-sendto-audacious-playlist.desktop14
-rw-r--r--main/thunar/thunar-sendto-bluetooth.desktop13
3 files changed, 55 insertions, 8 deletions
diff --git a/main/thunar/APKBUILD b/main/thunar/APKBUILD
index 3f788af17..c12ffef3c 100644
--- a/main/thunar/APKBUILD
+++ b/main/thunar/APKBUILD
@@ -1,23 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=thunar
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=0
pkgdesc="File manager for Xfce"
url="http://thunar.xfce.org"
arch="all"
license="GPL2 LGPL2"
subpackages="$pkgname-dev $pkgname-doc"
-depends="desktop-file-utils hicolor-icon-theme"
+depends="desktop-file-utils hicolor-icon-theme shared-mime-info"
makedepends="libexif-dev xfce4-panel-dev exo-dev pcre-dev udev-dev
- libnotify-dev startup-notification-dev libxfce4ui-dev"
+ libnotify-dev startup-notification-dev libxfce4ui-dev dbus-glib-dev"
install=
-source="http://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar.bz2"
+source="http://archive.xfce.org/src/xfce/thunar/${pkgver%.*}/Thunar-$pkgver.tar.bz2
+ thunar-sendto-audacious-playlist.desktop
+ thunar-sendto-bluetooth.desktop
+ "
-depends_dev="gtk+-dev glib-dev"
+depends_dev="gtk+-dev glib-dev exo-dev"
_builddir="$srcdir"/Thunar-$pkgver
prepare() {
cd "$_builddir"
+ # fix icon in thunar-sendto-email.desktop
+ sed -i 's!internet-mail!mail-message-new!' \
+ plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
}
build() {
@@ -28,14 +34,28 @@ build() {
--localstatedir=/var \
--disable-static \
--enable-exif \
- --enable-pcre
+ --enable-pcre \
+ --enable-dbus \
+ || return 1
make || return 1
}
package() {
cd "$_builddir"
+ local f
make DESTDIR="$pkgdir" install || return 1
- sed -i 's:x-directory/gnome-default-handler;::' "$pkgdir"/usr/share/applications/Thunar-folder-handler.desktop
+ sed -i -e 's:x-directory/gnome-default-handler;::' \
+ "$pkgdir"/usr/share/applications/Thunar-folder-handler.desktop
+ for f in $source; do
+ case $f in
+ thunar-sendto*.desktop)
+ install -m644 "$srcdir"/$f \
+ "$pkgdir"/usr/share/Thunar/sendto/ || return 1
+ ;;
+ esac
+ done
}
-md5sums="d8dce796890619d67aed0cd7ef84c7b1 Thunar-1.2.1.tar.bz2"
+md5sums="ab6f728384c0d925b40afae2f41268f3 Thunar-1.3.0.tar.bz2
+5a1e2ed692f3f95113339f5646f83af3 thunar-sendto-audacious-playlist.desktop
+1131368b7360a0132d5b36ff2cae898a thunar-sendto-bluetooth.desktop"
diff --git a/main/thunar/thunar-sendto-audacious-playlist.desktop b/main/thunar/thunar-sendto-audacious-playlist.desktop
new file mode 100644
index 000000000..97f985318
--- /dev/null
+++ b/main/thunar/thunar-sendto-audacious-playlist.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=Audacious Playlist
+Name[de]=Audacious Wiedergabeliste
+GenericName=Audio Playlist
+GenericName[de]= Wiedergabeliste
+Comment=Enque files to playlist
+Comment[de]=Dateien zur Wiedergabeliste hinzufügen
+Exec=audacious -e %F
+TryExec=audacious
+Icon=audacious
+MimeType=audio/prs.sid;audio/x-flac;audio/x-it;audio/x-mod;audio/x-ms-wma;audio/x-musepack;audio/x-s3m;audio/x-stm;audio/x-xm;application/ogg;audio/x-vorbis+ogg;inode/directory;
+Terminal=false
+Type=Application
diff --git a/main/thunar/thunar-sendto-bluetooth.desktop b/main/thunar/thunar-sendto-bluetooth.desktop
new file mode 100644
index 000000000..98899f69a
--- /dev/null
+++ b/main/thunar/thunar-sendto-bluetooth.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=Bluetooth OBEX Recipient
+Name[de]=Bluetooth OBEX Empfänger
+GenericName=Bluetooth Recipient
+GenericName[de]=Bluetooth Empfänger
+Comment=Send selected files via Bluetooth
+Comment[de]=Ausgewählte Dateien per Bluetooth senden
+Exec=bluetooth-sendto %F
+TryExec=bluetooth-sendto
+Icon=bluetooth
+Terminal=false
+Type=Application